LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 09-23-2014, 05:53 AM   #1
your_shadow03
Senior Member
 
Registered: Jun 2008
Location: Germany
Distribution: Slackware
Posts: 1,461
Blog Entries: 6

Rep: Reputation: 51
454 4.7.0 TLS not available due to local problem


Hello,

I am unable to send mail through Redmine settings > Outgoing email address. I am able to get this command working:

#echo "hello" | mail -s hi accounts@brand.net

I setup redmine on CentOS 6.5. My /var/www/redmine/config/configuration.yaml looks like:

Code:
production:
   email_delivery:
    delivery_method: :smtp
    smtp_settings:
     address: "brand.net"
     port: 25
     domain: "brand.net"
     authentication: :login
     user_name: "mo@brand.net"
     password: 'mypassword'
     openssl_verify_mode: 'none'
While I browse to Redmine > Settings > Email notifications > Send a test mail. It throws the error:

Code:
An error occurred while sending mail (454 4.7.0 TLS not available due to local problem )
I followed https://www.linode.com/docs/email/po...x-smtp-debian7 guide on my machine( debian config is very similar to CentOS for postfix). I am not using any relay server but just own smtp server.

My maillog says:
Code:
x/smtpd[18738]: connect from smtp.brand.net[94.242.254.47]
Sep 23 16:10:15 LU1 postfix/smtpd[18738]: lost connection after STARTTLS from smtp.brand.net[94.242.x.x]
Sep 23 16:10:15 LU1 postfix/cleanup[18740]: E2F2B189C0D4: message-id=<20140923141015.E2F2B189C0D4@brand.net>
Sep 23 16:10:15 LU1 postfix/qmgr[16795]: E2F2B189C0D4: from=<double-bounce@brand.net>, size=881, nrcpt=1 (queue active)
Sep 23 16:10:15 LU1 postfix/smtpd[18738]: disconnect from smtp.brand.net[94.242.x.x]
Sep 23 16:10:16 LU1 postfix/smtp[18742]: E2F2B189C0D4: to=<postmaster@localhost.localdomain>, orig_to=<postmaster>, relay=none, delay=0.09, delays=0.06/0/0.03/0, dsn=5.4.4, status=bounced (Host or domain name not found. Name service error for name=localhost.localdomain type=AAAA: Host not found)
Sep 23 16:10:16 LU1 postfix/bounce[18743]: warning: E2F2B189C0D4: undeliverable postmaster notification discarded
Sep 23 16:10:16 LU1 postfix/qmgr[16795]: E2F2B189C0D4: removed

Last edited by your_shadow03; 09-23-2014 at 08:11 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
local ip resolving taking time due to /etc/resolv.conf NagaManjunath Linux - Newbie 4 04-14-2014 09:42 AM
exim "454 TLS currently unavailable" bicpen Linux - Server 2 01-23-2011 10:17 AM
Openlap + TLS not working due to certificate issues pazzport Linux - Server 3 03-30-2009 05:24 PM
LXer: GnuTLS Release Removes TLS Authorization Due to Patent Issue LXer Syndicated Linux News 0 10-22-2007 02:50 AM
FC6 not booting up due to addition of line to /etc/rc.d/rc.local rajat Linux - Server 1 05-24-2007 03:24 AM


All times are GMT -5. The time now is 06:45 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration