LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Closed Thread
  Search this Thread
Old 07-29-2012, 01:38 PM   #1
mjainit
LQ Newbie
 
Registered: Jul 2012
Posts: 3

Rep: Reputation: Disabled
Unhappy 3G USB modem problem with usb_modeswithch Archlinux


I'm using archlinux.

Recently I bought new USB 3g modem. Modem is HSPADataCard LW 272 (Teracom). Here is my lsusb output after connecting the modem,
Bus 001 Device 002: ID 8087:0020 Intel Corp. Integrated Rate Matching Hub
Bus 002 Device 002: ID 8087:0020 Intel Corp. Integrated Rate Matching Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 003: ID 0c45:6409 Microdia Webcam
Bus 002 Device 004: ID 230d:0101
The last one is my modem. I have installed modemmanager. I'm trying to switch mode using usb_modeswitch, Here is the output,
Command :- sudo usb_modeswitch -v 230d -p 0101 -u 3

Output :-
Looking for default devices ...
found matching product ID
Getting the current device configuration ...
OK, got current device configuration (1)
Found device in default mode, class or configuration (1)
Accessing device 004 on bus 002 ...
Getting the current device configuration ...
OK, got current device configuration (1)
Using first interface: 0x00
Using endpoints 0x07 (out) and 0x87 (in)
Inquiring device details; driver will be detached ...
Looking for active driver ...
No driver found. Either detached before or never attached
SCSI inquiry data (for identification)
-------------------------
Vendor String: HSPA
Model String: CD-ROM
Revision String: 0000
-------------------------
USB description data (for identification)
-------------------------
Manufacturer: HSPADataCard
Product: HSPADataCardA
Serial No.: 8444311594054030
-------------------------
Changing configuration to 3 ...
Device is busy, trying to detach kernel driver
Looking for active driver ...
No driver found. Either detached before or never attached
Device is busy, trying to detach kernel driver
Looking for active driver ...
No driver found. Either detached before or never attached
Device is busy, trying to detach kernel driver
Looking for active driver ...
No driver found. Either detached before or never attached
Device is busy, trying to detach kernel driver
Looking for active driver ...
No driver found. Either detached before or never attached
Setting the configuration returned error -2. Trying to continue
-> Run lsusb to note any changes. Bye.

If I'm not wrong then my modem is mounted as usb storage device with kernel driver scsi_mod , But usb_modeswitch is not able to find driver to detach the device.
Can someone tell how to switch mode or detect my modem?
 
Old 07-29-2012, 08:11 PM   #2
unSpawn
Moderator
 
Registered: May 2001
Posts: 29,353
Blog Entries: 55

Rep: Reputation: 3541Reputation: 3541Reputation: 3541Reputation: 3541Reputation: 3541Reputation: 3541Reputation: 3541Reputation: 3541Reputation: 3541Reputation: 3541Reputation: 3541
Please post your thread in only one forum. Posting a single thread in the most relevant forum will make it easier for members to help you and will keep the discussion in one place. This thread should be closed because it is a duplicate of http://www.linuxquestions.org/questi...ux-4175419212/.
 
  


Closed Thread


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
3G USB modem problem with usb_modeswithch Archlinux mjainit Linux - Networking 2 08-03-2012 08:29 AM
SOLVED : P new install of archlinux with archlinux-2010.05-core-i686.iso elenger Arch 1 08-18-2011 01:55 PM
problem with configuring my usb edge modem (wvdialconf can not detect modem):fedora 9 Asif Akter Linux - Hardware 1 01-10-2011 06:06 AM
Problem with usb pendrive and usb modem ZTE ZXDSL 852 AM33N Linux - Hardware 3 12-10-2008 03:25 AM
Problem with Mandrake 10.0 Community, Sagem usb modem and logitech usb mouse. al370601 Mandriva 4 04-29-2004 06:48 PM


All times are GMT -5. The time now is 04:48 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration