LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 12-04-2009, 12:19 PM   #1
lemon09
Member
 
Registered: Jun 2009
Location: kolkata,India
Distribution: Mandriva,openSuse,Mint,Debian
Posts: 285
Blog Entries: 1

Rep: Reputation: 37
3D desktops effect not supported


I recently installed Mandriva 2010 in my machine, but the thing is that I can't apply 3D desktop effects....it says my machine do not support 3D desktop effects.
To be specific I have ASUS motherboard with AMD (phenom x3)processor...it has NVIDIA chipset....how can I install 3D effects...please help.
 
Old 12-04-2009, 12:35 PM   #2
lugoteehalt
Senior Member
 
Registered: Sep 2003
Location: UK
Distribution: Debian
Posts: 1,215
Blog Entries: 2

Rep: Reputation: 49
You could probably try putting some of the next into /etc/X11/xorg.conf, certainly the 'Section "Extensions"
Option "Composite" "Enable"
EndSection' should be in.
Code:
Section "Screen"

<snip>

    Option         "RenderAccel" "true"
    Option         "AddARGBGLXVisuals" "true"
    Option         "AllowGLXWithComposite" "true"
    Option         "TrippleBuffer" "true"
    
<snip>

EndSection

Section "Extensions"
    Option         "Composite" "Enable"
EndSection
Then, if you're using KDE, for example enable 'translucency' in the control centre. If using Enlightenment 17 install the 'bling' *module*.

Last edited by lugoteehalt; 12-04-2009 at 12:38 PM.
 
Old 12-04-2009, 12:41 PM   #3
bret381
Member
 
Registered: Nov 2009
Location: Alabama
Distribution: Arch x86_64
Posts: 650

Rep: Reputation: 78
You will probably need to install the nvidia drivers from nvidia's website

http://www.nvidia.com/Download/index.aspx?lang=en-us
 
Old 12-05-2009, 02:11 AM   #4
lemon09
Member
 
Registered: Jun 2009
Location: kolkata,India
Distribution: Mandriva,openSuse,Mint,Debian
Posts: 285
Blog Entries: 1

Original Poster
Rep: Reputation: 37
Quote:
Originally Posted by lugoteehalt View Post
You could probably try putting some of the next into /etc/X11/xorg.conf, certainly the 'Section "Extensions"
Option "Composite" "Enable"
EndSection' should be in.
Code:
Section "Screen"

<snip>

    Option         "RenderAccel" "true"
    Option         "AddARGBGLXVisuals" "true"
    Option         "AllowGLXWithComposite" "true"
    Option         "TrippleBuffer" "true"
    
<snip>

EndSection

Section "Extensions"
    Option         "Composite" "Enable"
EndSection
Then, if you're using KDE, for example enable 'translucency' in the control centre. If using Enlightenment 17 install the 'bling' *module*.
I don't understand what you say!!!!!!!!!
may the following code can help you....
Code:
[lemon@localhost ~]$ cat /etc/X11/xorg.conf|more
# File generated by XFdrake (rev )              

# **********************************************************************
# Refer to the xorg.conf man page for details about the format of       
# this file.                                                            
# **********************************************************************

Section "ServerFlags"
    Option "DontZap" "False" # disable <Ctrl><Alt><BS> (server abort)
    AllowMouseOpenFail # allows the server to start up even if the mouse does not work
    #DontZoom # disable <Ctrl><Alt><KP_+>/<KP_-> (resolution switching)               
EndSection                                                                            

Section "Module"
    Disable "dri"
    Load "dbe" # Double-Buffering Extension
    Load "v4l" # Video for Linux           
    Load "extmod"                          
    Load "glx" # 3D layer                  
EndSection

Section "Monitor"
    Identifier "monitor1"
    VendorName "Plug'n Play"
    ModelName "DELL E1709W"
    HorizSync 30-83
    VertRefresh 56-75

    # Monitor preferred modeline (59.9 Hz vsync, 55.9 kHz hsync, ratio 16/10, 98 dpi)
    ModeLine "1440x900" 106.5 1440 1520 1672 1904 900 903 909 934 +hsync -vsync

    # TV fullscreen mode or DVD fullscreen output.
    # 768x576 @ 79 Hz, 50 kHz hsync
    ModeLine "768x576"     50.00  768  832  846 1000   576  590  595  630

    # 768x576 @ 100 Hz, 61.6 kHz hsync
    ModeLine "768x576"     63.07  768  800  960 1024   576  578  590  616
EndSection

Section "Device"
    Identifier "device1"
    VendorName "nVidia Corporation"
    BoardName "NVIDIA GeForce 6100 and later"
    Driver "nv"
    Option "DPMS"
EndSection

Section "Screen"
    Identifier "screen1"
    Device "device1"
    Monitor "monitor1"
EndSection

Section "ServerLayout"
    Identifier "layout1"
    Screen "screen1"
EndSection
now can you help me????
 
Old 12-05-2009, 02:33 AM   #5
lemon09
Member
 
Registered: Jun 2009
Location: kolkata,India
Distribution: Mandriva,openSuse,Mint,Debian
Posts: 285
Blog Entries: 1

Original Poster
Rep: Reputation: 37
well friends when i try to enable the 3D desktop effects from the KDE controls....it says that 3D desktop effect is not supported by the given configuration options.
 
Old 12-05-2009, 04:12 AM   #6
Davno
Member
 
Registered: Mar 2004
Location: Montreal, Canada
Distribution: Mandriva 2010.2
Posts: 148

Rep: Reputation: 24
Like Bret381 said, you need to install the proper video driver for your card, unless you installed Mandriva 2010 Powerpack edition, wich probably has your driver on the dvd, you will have to download and install that driver manually.
 
Old 12-05-2009, 06:31 PM   #7
eeeBu
Member
 
Registered: Nov 2009
Distribution: Ubuntu karmic koala
Posts: 71

Rep: Reputation: 16
Quote:
Originally Posted by lemon09 View Post
well friends when i try to enable the 3D desktop effects from the KDE controls....it says that 3D desktop effect is not supported by the given configuration options.
i think you have to Activate the GPU drivers

im not sure about Madriva but i know in Ubuntu you have to go to

System -> Administrator -> Hardware Drivers

I hope its that simple on Madriva

im pretty confident that once you install that it will work

Last edited by eeeBu; 12-05-2009 at 06:33 PM.
 
Old 12-06-2009, 01:25 AM   #8
lugoteehalt
Senior Member
 
Registered: Sep 2003
Location: UK
Distribution: Debian
Posts: 1,215
Blog Entries: 2

Rep: Reputation: 49
Quote:
Originally Posted by lemon09 View Post
I don't understand what you say!!!!!!!!!
I mean would have thought you need to change the file. Perhaps try, as root,
Code:
cat >> /etc/X11/xorg.conf
Section "Extensions"
    Option         "Composite" "Enable"
EndSection
<ctrl+d>
i.e. type that lot, complete with <return>'s at a terminal and then hold down ctrl and hit 'd'. That will add the text to the end of the xorg.conf file. Or use a text editor, as root, to add the same thing.

You may well need to do as the others have said as well. If you are using KDE then you need to switch 3D on with: control center > window behavior > translucency tab > use transparency/shadows.

That's what you'd do in Debian, assuming your's the same.
 
Old 12-06-2009, 04:57 AM   #9
the trooper
Senior Member
 
Registered: Jun 2006
Location: England
Distribution: Debian Jessie Amd64
Posts: 1,477

Rep: Reputation: Disabled
Code:
Section "Device"
    Identifier "device1"
    VendorName "nVidia Corporation"
    BoardName "NVIDIA GeForce 6100 and later"
    Driver "nv"
    Option "DPMS"
EndSection
The op is using the 'nv' driver.This does not support 3d acceleration.
As already stated the op needs the proprietary driver from Nvidia.
 
Old 12-06-2009, 09:19 AM   #10
resetreset
Senior Member
 
Registered: Mar 2008
Location: Cyberspace
Distribution: Dynebolic, Ubuntu 10.10
Posts: 1,340

Rep: Reputation: 62
Just to give my input, when I was running previous versions of Fedora, on, I think, the same video card - GeForce 6100, I would never get resolutions of more than 800x600, forget 3D effects. When Fedora 11 came out, I get resolutions of upto 1280x1024, but then a couple of days later my motherboard video card went kaput and I bought a new one - an Nvidia one, where the resolution capabilities are the same. However I can't turn on 3D effects either, I posted here about it, read for yourself:
http://www.linuxquestions.org/questi...ora-11-765388/
 
Old 12-07-2009, 12:10 PM   #11
lemon09
Member
 
Registered: Jun 2009
Location: kolkata,India
Distribution: Mandriva,openSuse,Mint,Debian
Posts: 285
Blog Entries: 1

Original Poster
Rep: Reputation: 37
Quote:
The op is using the 'nv' driver.This does not support 3d acceleration.
well i have installed kmod-nvidia.....now the question is how to enable it as the default driver.
 
Old 12-07-2009, 12:48 PM   #12
lugoteehalt
Senior Member
 
Registered: Sep 2003
Location: UK
Distribution: Debian
Posts: 1,215
Blog Entries: 2

Rep: Reputation: 49
Quote:
Originally Posted by lemon09 View Post
well i have installed kmod-nvidia.....now the question is how to enable it as the default driver.
Assume they meant go to nvidia.com and download the driver installer, a *.run file, I think. Then, as root:
Code:
# bash /path/to/file/*.run
It then goes through a whole palaver of building a kernel interface and so on. It installs itself and removes the old driver. That what you did?
 
Old 12-08-2009, 01:37 AM   #13
lemon09
Member
 
Registered: Jun 2009
Location: kolkata,India
Distribution: Mandriva,openSuse,Mint,Debian
Posts: 285
Blog Entries: 1

Original Poster
Rep: Reputation: 37
Quote:
It then goes through a whole palaver of building a kernel interface and so on. It installs itself and removes the old driver. That what you did?
i did exactly the same but it reads something like this...
Code:
no precompiled kernel interface was found to match your kernel;
does that mean the kernel version did not match?????

how can i solve the problem now????
 
Old 12-08-2009, 02:41 AM   #14
lugoteehalt
Senior Member
 
Registered: Sep 2003
Location: UK
Distribution: Debian
Posts: 1,215
Blog Entries: 2

Rep: Reputation: 49
Quote:
Originally Posted by lemon09 View Post
i did exactly the same but it reads something like this...
Code:
no precompiled kernel interface was found to match your kernel;
does that mean the kernel version did not match?????

how can i solve the problem now????
At that point it usually asks to go to its web site and look for the appropriate kernel interface. If you give it permission, you don't have to, it usually says it can't find one. It then asks if you want it to build said interface, you say 'yes' presumably. It frequently fails and some fiddling around is required.

Last time I did it 'sh installerThing.run --update' fixed the problem - need to be connected to internet.

Basically you just tell it 'yes' all the time.

From memory you need to switch off X when doing above. In KDE:
Code:
ctrl+alt+del
Select 'new session'
Click 'console login' in one of the menus
$ su
$ <enter root password> or whatever if it's Ubuntu or something
# sh installerThing.run
Hope helps.
 
Old 12-08-2009, 04:28 AM   #15
lemon09
Member
 
Registered: Jun 2009
Location: kolkata,India
Distribution: Mandriva,openSuse,Mint,Debian
Posts: 285
Blog Entries: 1

Original Poster
Rep: Reputation: 37
Quote:
Last time I did it 'sh installerThing.run --update' fixed the problem - need to be connected to internet.
even that does not work!!!!!!
have a look at the log file:

Code:
nvidia-installer log file '/var/log/nvidia-installer.log'
creation time: Tue Dec  8 14:45:39 2009
installer version: 1.0.7

option status:
  license pre-accepted    : false
  update                  : false
  force update            : false
  expert                  : false
  uninstall               : false
  driver info             : false
  precompiled interfaces  : true
  no ncurses color        : false
  query latest version    : false
  OpenGL header files     : true
  no questions            : false
  silent                  : false
  no recursion            : false
  no backup               : false
  kernel module only      : false
  sanity                  : false
  add this kernel         : false
  no runlevel check       : false
  no network              : false
  no ABI note             : false
  no RPMs                 : false
  no kernel module        : false
  force SELinux           : default
  no X server check       : false
  no cc version check     : false
  force tls               : (not specified)
  X install prefix        : (not specified)
  X library install path  : (not specified)
  X module install path   : (not specified)
  OpenGL install prefix   : (not specified)
  OpenGL install libdir   : (not specified)
  utility install prefix  : (not specified)
  utility install libdir  : (not specified)
  doc install prefix      : (not specified)
  kernel name             : (not specified)
  kernel include path     : (not specified)
  kernel source path      : (not specified)
  kernel output path      : (not specified)
  kernel install path     : (not specified)
  proc mount point        : /proc
  ui                      : (not specified)
  tmpdir                  : /root/tmp
  ftp mirror              : ftp://download.nvidia.com
  RPM file list           : (not specified)

Using: nvidia-installer ncurses user interface
-> License accepted.
-> Installing NVIDIA driver version 190.42.
-> Performing CC sanity check with CC="cc".
-> Performing CC version check with CC="cc".
ERROR: Unable to find the kernel source tree for the currently running kernel. 
       Please make sure you have installed the kernel source files for your
       kernel and that they are properly configured; on Red Hat Linux systems,
       for example, be sure you have the 'kernel-source' or 'kernel-devel' RPM
       installed.  If you know the correct kernel source files are installed,
       you may specify the kernel source path with the '--kernel-source-path'
       command line option.
ERROR: Installation has failed.  Please see the file
       '/var/log/nvidia-installer.log' for details.  You may find suggestions
       on fixing installation problems in the README available on the Linux
       driver download page at www.nvidia.com.


it says
Code:
Unable to find the kernel source tree for the currently running kernel. 
Please make sure you have installed the kernel source files for your
kernel and that they are properly configured;
I tried installing kernel-devel separately but again it was in vain.
So how to get through this problem????
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
For 3D Effect ramesh mohite Fedora 1 10-22-2007 04:24 PM
Current effect ? brodo Slackware 3 04-21-2007 03:55 AM
Looking Glass Effect aggro1218 Linux - Software 4 03-01-2007 12:26 PM
Internet Explorer supported website (not supported by FF) itz2000 Linux - General 17 03-24-2006 09:28 PM
route - Changes take a while to take effect Khang Linux - Networking 4 10-28-2004 09:30 PM


All times are GMT -5. The time now is 02:28 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration