LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 10-30-2004, 06:57 PM   #1
kylecarrington
LQ Newbie
 
Registered: Oct 2004
Location: canada
Distribution: Fedora Core 2
Posts: 11

Rep: Reputation: 0
3Com 509B It all works! except Internet? sees eth0 but can't go active


Hi there!

I have an AMD Duron 600, 320 MB RAM, 2 fixed hard drives, both ATA 100/133. Linux is installed on my second drive, and I loaded the boot loader into the first sectors of the partition, not the hd1 mbr.

Grub figured it all out, and I now have dual boot, Win98 as my option, Linux as my default... all loads, except Linux sees my eth0 card, but cannot make it active. Fedora Core 2 install. eth0 is the only error in bottup (says its not connected - check cable...) It works fine in Windows, so I know there is cable net available.

eth0: 3Com 509B TPO

Thanks for any help! One thing I did notice is that my cmos is assigning the same IRQ for my sound card as my eth0, whether this would make a dif. i dont know? I'll try unplugging it, but I have no conflict in Windows.

Kyle
 
Old 10-30-2004, 07:02 PM   #2
trickykid
LQ Guru
 
Registered: Jan 2001
Posts: 24,149

Rep: Reputation: 234Reputation: 234Reputation: 234
Is it loading the 3com module for your card?

lsmod will display such information.

If it is loading the module, if not sure post the lsmod output here, have you configured the card? Did it ask to configured at install?
 
Old 10-30-2004, 10:23 PM   #3
kylecarrington
LQ Newbie
 
Registered: Oct 2004
Location: canada
Distribution: Fedora Core 2
Posts: 11

Original Poster
Rep: Reputation: 0
I am still very new to these terms, sorry, i don't have a linux book yet, so really, I have no clue what you are asking LOL

When it boots,

it finds the network adapter, names it appropriately, then tries to make a connection, can't, tells me:

bad cable? [failed]

something to that effect. If i knew the appropriate logs to share with you (their names and locations) I'd post them.

Seems my 98 crumbled in all the process of switching around ethernet cards to get something to work, so I had to reinstall it, now I'll have to do GRUB again? I guess... I dunno, this is all very very complicated compared to Windows, that's for sure.

Thanks
 
Old 10-30-2004, 10:28 PM   #4
jsutton
Member
 
Registered: Nov 2003
Location: Greenville, SC, USA
Distribution: (K)ubuntu 5.04 / Fedora 4
Posts: 113

Rep: Reputation: 15
I've experienced the same problems with the 3c905 card. My final solution was disabling Kudzu on bootup. I don't know why, but this always solves the problems for me.

I've also heard that passing 'acpi=off' to the kernel on bootup will solve the problem, but I haven't tested this myself. So, if you can't bear to loose kudzu on boot, then you might want to give this a try.

Hope that helps.

Jared
 
Old 10-30-2004, 10:38 PM   #5
kylecarrington
LQ Newbie
 
Registered: Oct 2004
Location: canada
Distribution: Fedora Core 2
Posts: 11

Original Poster
Rep: Reputation: 0
Hmmm ok

Seems I have a new problem. Linux disappeared, or grubloader got overwritten in the MBR or something. I reinstalled W98 on my c:\ and now grubloaders gone.

I tried booting Disc 1 and typing "linux rescue" and it found the installation, did some mount thing, told me to type chroot /mnt something-or-other, and I did but it didnt fix it.

How to get grubloader back in there?

Then if i do, how do you, do, what you suggested, like exactly how do you disable something at boot up?

Thanks
Kyle
 
Old 10-30-2004, 11:11 PM   #6
comprookie2000
Gentoo Developer
 
Registered: Feb 2004
Location: Fort Lauderdale FL.
Distribution: Gentoo
Posts: 3,291
Blog Entries: 5

Rep: Reputation: 56
See if this helps; http://www.linuxcompatible.org/thread27844-1.html
 
Old 10-31-2004, 12:06 AM   #7
kylecarrington
LQ Newbie
 
Registered: Oct 2004
Location: canada
Distribution: Fedora Core 2
Posts: 11

Original Poster
Rep: Reputation: 0
Thanks folks!

Managed to get GRUB re-loaded into MBR. See my other thread for solution, thanks to all that helped!

Now...

How do I disable kudzu or set apci=off during boot-up?

Which is the most logical solution?

Linux seems to see my ethernet, calls it what is is (3com XL 309B TPO PCI), on eth0, but.... it does not connect to the net?

also, when I first installed Linux, I made my / and /boot partions of the ext2 file type.... is this correct?

Thanks
Kyle
 
Old 10-31-2004, 12:38 AM   #8
kylecarrington
LQ Newbie
 
Registered: Oct 2004
Location: canada
Distribution: Fedora Core 2
Posts: 11

Original Poster
Rep: Reputation: 0
Fixed 3com 309b TPO problem

Thanks again folks!

I am now replying in Linux! Isn't this a beautiful thing when an idiot like me can get a dual boot system up in an evening LOL

To resolve the eth0 not connected to the net, I chose run Interactive boot, and said "N" to using kudzu, and everything seemed to work
nicely.

I guess I'll try disabling it completely as I do not plan on adding any new hardware.

Thanks!!!!!
Kyle
 
Old 10-31-2004, 01:39 PM   #9
jsutton
Member
 
Registered: Nov 2003
Location: Greenville, SC, USA
Distribution: (K)ubuntu 5.04 / Fedora 4
Posts: 113

Rep: Reputation: 15
To disable it completely on bootup, you can use 'system-config-services.' Just uncheck the box next to kudzu in the services list (and make sure to save before exiting).
 
Old 11-01-2004, 09:43 AM   #10
WilliamsJD
LQ Newbie
 
Registered: Nov 2003
Distribution: Fedora Core 4
Posts: 11

Rep: Reputation: 0
Hello... glad your 3c509 is working better.

Two things for you to be aware of....

1) Even disabling kudzu is not guarenteed to get rid of your problems. We have a large number of 3c905's (same driver) and still can't use them reliably in our FC2 boxes even though we disable kudzu. This is a known problem in the 3c509 module and there is an outstanding Bugzilla issue for it (107389).

https://bugzilla.redhat.com/bugzilla....cgi?id=107389

We don't use the boards in our newly built FC2 boxes because we have had lots of errors, retransmits, funky behavior and slow transmission times. Our few boxes that have 3c905's in them (like some workstation machines) have ongoing networking problems like ill-behaved NFS and failed RCPs and other such obnoxious tendancies. If you can get a non-3com NIC to use for a while you will probably be happier.

The latest grousing about the problem indicates that Fedora Core 3 Test 2 does not have a fix for this problem either. We particularly hate this bug because we have about a dozen really good 3c905 cards that we can't use until it is fixed.

2) The command line (my always-preferred method) way to change the kudzu boot (or in this case, non-boot) behavior is like this:

/sbin/chkconfig --level 345 kudzu off

To display which run-levels kudzu will run at, use:

/sbin/chkconfig --list kudzu

Hope that helps,
Jeff W.
 
Old 11-01-2004, 01:25 PM   #11
kylecarrington
LQ Newbie
 
Registered: Oct 2004
Location: canada
Distribution: Fedora Core 2
Posts: 11

Original Poster
Rep: Reputation: 0
-- level 345 >> with kudzu disabled, or?

Jeff,

Thanks for the pointer!

Do I leave kudzu disabled on boot-up as seen in the system settings/server settings/services? or recheck it to run on boot up, after i make this shell change?

Thanks
Kyle
 
Old 11-01-2004, 02:03 PM   #12
jsutton
Member
 
Registered: Nov 2003
Location: Greenville, SC, USA
Distribution: (K)ubuntu 5.04 / Fedora 4
Posts: 113

Rep: Reputation: 15
Hey kyle,

What jeff posted was just a command-line version of the the same thing that I posted previously (a great thing to know if you're stuck without X and you need to disable/enable a service on boot). So, they accomplish essentially the same task.
 
Old 11-01-2004, 02:55 PM   #13
WilliamsJD
LQ Newbie
 
Registered: Nov 2003
Distribution: Fedora Core 4
Posts: 11

Rep: Reputation: 0
Right, same thing. I would encourage you to leave kudzu disabled until the upgrade that fixes the 3c5xx/3c9xx problem is available and installed on your machine. If you add or change other hardware to your system you can run kudzu manually and then reboot.
 
Old 11-02-2004, 08:42 PM   #14
Ordinary_User
LQ Newbie
 
Registered: Nov 2004
Posts: 2

Rep: Reputation: 0
Quote:
Originally posted by jsutton
To disable it completely on bootup, you can use 'system-config-services.' Just uncheck the box next to kudzu in the services list (and make sure to save before exiting).
Thank you!

Now it works for me too!

 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Cannot ping self ??? eth0 not active ??? Wynand1 Linux - Networking 2 06-29-2006 01:11 AM
interface eth0 is not (yet?) active jorcas SUSE / openSUSE 1 11-22-2004 07:53 PM
firestarter-eth0 not ready (thsi is the one i use for the internet it works) gonus Linux - Security 1 08-22-2004 11:01 AM
eth0 not active on startup rocket84 Linux - Networking 6 07-21-2003 02:09 AM
no www name resolution when eth0 active vance Linux - Networking 8 12-08-2002 06:11 PM


All times are GMT -5. The time now is 06:09 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration