LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 02-04-2008, 10:41 AM   #1
chochip
LQ Newbie
 
Registered: Feb 2008
Posts: 1

Rep: Reputation: 0
302 Error, on a Web Bot


Hi I'm stuck any help would be great. I'm trying to read data from webpages to use in an RSS style, when the page doesn't have a feed.

I can't determine what is the cause of an error. If i run the script in IE I get results but from the linux webserver cron job, I get a 302 location changed. I've tried substituting to the new location address, but that returns the same.

Here's the header:

Status: 302
HTTP/1.1 302 Found
Connection: close
Date: Mon, 01 Jan 2008 12:44:20 GMT
Server: Microsoft-IIS/6.0
X-Powered-By: ASP.NET
X-AspNet-Version: 2.0.50727
Location: /Help/Error/?aspxerrorpath=/pp/Default.aspx
Cache-Control: private
Content-Type: text/html; charset=utf-8
Content-Length: 184

The url is above abbreviated on the domain part.

-----------------------------------------------------------
When I run this file as a user in IE it works fine, but I don't know why? Here's the user output printed by the php script.

-------------------------------------------------------------
HTTP/1.1 200 OK
Connection: close
Date: Wed, 23 Jan 2008 12:34:22 GMT
Server: Microsoft-IIS/6.0
X-Powered-By: ASP.NET
X-AspNet-Version: 2.0.50727
Set-Cookie: ASP.NET_SessionId=kaoz5dnzhkgdnoimqgbhax45; path=/; HttpOnly
Set-Cookie: LiveEnvBasketId=; expires=Fri, 22-Feb-2008 12:34:22 GMT; path=/
Cache-Control: private
Content-Type: text/html; charset=utf-8
Content-Length: 34054
-----------------------------------------------------------

I'm hoping its something simple...

Any suggestions would be grate.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Regarding 302 Error chnlinux Linux - Newbie 2 11-21-2007 05:09 AM
Gentoo Linux error: VFS can not open root device "302" Thaidog Linux - Distributions 0 12-10-2006 09:35 PM
Trying to install etch with ZyXEL G-302 walterbyrd Debian 5 12-03-2006 10:49 PM
error: failed to lstat /tmp/.302.2fa859: ferdog Linux - Newbie 7 07-18-2003 09:14 AM
Apache 2 Error 302 / JSP adcworks Linux - General 1 08-19-2002 10:31 AM


All times are GMT -5. The time now is 09:00 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration