LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 08-13-2006, 11:11 AM   #1
meal3837
LQ Newbie
 
Registered: Aug 2006
Posts: 4

Rep: Reputation: 0
3 fiierent linux installers will boot, but cannot mount the cdrom


I have tried installing devil-linux, ark linux, and Debian on my machine (hp pavilion 6535 . . . don't laugh, it was free). With each distro, I have pretty much the same problem. It will boot the installer just fine, but when it proceeds to mount the CD-ROM, it can't do it. could this have something to do with the i810 chipset? or possibly the ancient samsung cd drive? I'm hoping that there is a way to resolve this without buying new hardware at the moment.
 
Old 08-13-2006, 11:15 AM   #2
MensaWater
LQ Guru
 
Registered: May 2005
Location: Atlanta Georgia USA
Distribution: Redhat (RHEL), CentOS, Fedora, Debian, FreeBSD, HP-UX, Solaris, SCO
Posts: 6,577
Blog Entries: 14

Rep: Reputation: 969Reputation: 969Reputation: 969Reputation: 969Reputation: 969Reputation: 969Reputation: 969Reputation: 969
At boot: try typing "ide=nodma".

The BIOS does the original boot of the CD so Linux doesn't need to know how to find it. However when Linux starts a root in memory it then tries to mount the CD and does need to know how to find it. On some systems you need the above flag so it will know how to mount the drive.

I had it on my Dell PowerEdge 1300 but for some reason not on any other Dell PowerEdge I've loaded. I suspect it has to do with age of the machine as to whether it uses dma for the CD.

Edited - originally mistyped as "cd=nodma" which is incorrect.
 
Old 08-14-2006, 01:09 AM   #3
meal3837
LQ Newbie
 
Registered: Aug 2006
Posts: 4

Original Poster
Rep: Reputation: 0
ok, tried that. still no luck. also tried some flags listed in the boot help screen (noapic nolapic and others). It still won't mount the cdrom.
 
Old 08-15-2006, 01:37 PM   #4
meal3837
LQ Newbie
 
Registered: Aug 2006
Posts: 4

Original Poster
Rep: Reputation: 0
Does anyone else have any suggestions?
 
Old 08-15-2006, 02:39 PM   #5
danga1993
LQ Newbie
 
Registered: Oct 2005
Location: In a house......
Distribution: Debian
Posts: 21

Rep: Reputation: 15
Have you tried to see if a bootable cdrom will work? If it does that should rule out quite a few problems.

You might also want to try and tinker with your bios a little, there might be something in there which might be preventing linux from mounting the cd drive.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
how do i fix my linux to make it auto mount for cdrom. when i boot the machine saw a pink1dog Linux - Software 11 04-13-2005 02:59 PM
Cant boot some linux installers, vtecturbo13 Linux - Hardware 3 03-12-2005 10:24 AM
How to give cdrom access for user & can i mount FAT32 partition atomatically on boot? Ninja_212 *BSD 3 03-09-2005 04:01 PM
vector linux cdrom mount? robotjones Linux - Newbie 6 06-26-2003 12:21 PM
How do I automatically mount my cdrom at boot? Amerist Linux - Software 6 04-14-2002 06:46 AM


All times are GMT -5. The time now is 03:52 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration