LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 05-07-2005, 11:10 AM   #1
evolvedlight
LQ Newbie
 
Registered: Apr 2005
Distribution: slackware
Posts: 6

Rep: Reputation: 0
24bit colour to 16 bit


im trying to emulate ubuntu in virtual pc. it starts up fine, but the colours are messed up, and appatently this is doue to the wrong colour depth. how do i change it to 16 bit colour (and please dont just say "edit the xorg.conf" file, i have no idea HOW to edit it or where it is). I can log into bash fine, using resque mode. Please help!

S
 
Old 05-07-2005, 03:02 PM   #2
Tino27
Member
 
Registered: Aug 2003
Location: Akron, OH
Distribution: SuSE 8.2, Slackware current, OpenBSD 3.5-3.8, Fedora Core 2
Posts: 400

Rep: Reputation: 30
Well, I'm not sure what editing tools you have available on Ubuntu, but really the easiest way to fix your problem IS to edit your xorg.conf file. Before you freak, I'll give you some pointers.

1) You have to be the root user to be able to edit the file. To do this, start up a terminal (the CLI) and type 'su' followed by the root password when asked for it. Your prompt should change from a '$' to a '#'.

2) The file you are looking for is at /etc/X11/xorg.conf. So, once you are root, issue the following command

#cd /etc/X11
(obviously don't type the '#' symbol)

3) Invoke your favorite text editor along with the name of the xorg file. My normal text editor is the pico program. You could also use vi, emacs, or any other program you wish.

#pico xorg.conf

4) Most assuredly the section you want is towards the bottom of the file. Scroll to the bottom. In the section marked 'Section "Screen"' you may see the following:

# DefaultDepth 8
# DefaultDepth 16
DefaultDepth 24
# DefaultDepth 32

In this case, all you need to do is put a '#' in front of the one you wish to not use and remove the '#' from the line you do wish to use. If you have only this

DefaultDepth 24

and no others, then that might mean you only have settings defined for 24-bit color depth. In this case add the desired depth and comment out the old one

DefaultDepth 16
# DefaultDepth 24

And look directly below this section. You should see a 'SubSection "Display"' section that defines the resolutions that can be used with whatever depth has been selected as default. If only one section exists (presumably for the 24-bit section), simply make a copy of that subsection, except on the "Depth" line, put 16 instead of 24.

After that, save your changes and restart X.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
SoundBlaster Live! 24bit vbguru12000 Debian 35 03-24-2005 05:17 PM
SoundBlaster Live! 24bit vbguru12000 Linux - Hardware 4 02-03-2005 01:36 PM
Gnome - changing 24bit to 16 bit eliteskills Linux - Newbie 1 07-29-2004 02:04 AM
why is X 24bit colour? Jestrik Linux - General 9 01-14-2004 08:07 AM
i cant get 1024x768 @ 16 bit colour depth vixy27 Linux - Software 4 12-11-2000 01:07 PM


All times are GMT -5. The time now is 04:46 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration