LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 01-06-2004, 07:27 AM   #1
lozz1978
Member
 
Registered: Jan 2004
Location: Sunny UK
Distribution: Slackware 9.1
Posts: 53

Rep: Reputation: 15
2 versions of iproute ?


Hi all

Not sure how this happend,

I ran "apt-get upgrade" then it started downloading all the latest updates.
as it got to iproute i closed the terminal window by mistake,

Now when i run apt-get install, I get an error saying
2versions of iprroute were found on the system, please run apt-get update to correct fault.

I run apt-get update, and I still get the same error,

any ideas ?


thanks

Last edited by lozz1978; 01-06-2004 at 07:30 AM.
 
Old 01-06-2004, 07:44 AM   #2
XavierP
Moderator
 
Registered: Nov 2002
Location: Kent, England
Distribution: Debian Testing
Posts: 19,192
Blog Entries: 4

Rep: Reputation: 469Reputation: 469Reputation: 469Reputation: 469Reputation: 469
You probably have the broken version sitting alongside the old version. First thing to do is to remove the broken version, apt-get uninstall iproute. It will probably ask you which version you want to get rid of - so choose wisely!

Then try the apt-get upgrade again.
 
Old 01-07-2004, 11:58 AM   #3
lozz1978
Member
 
Registered: Jan 2004
Location: Sunny UK
Distribution: Slackware 9.1
Posts: 53

Original Poster
Rep: Reputation: 15
Quote:
Originally posted by XavierP
You probably have the broken version sitting alongside the old version. First thing to do is to remove the broken version, apt-get uninstall iproute. It will probably ask you which version you want to get rid of - so choose wisely!

Then try the apt-get upgrade again.

Hi there im still having problems with my iproute, its driving me nuts, im contemplating installing red hat again to overcome this problem,

I run apt-get remove iproute and get,
root@localhost loppy1]# apt-get remove iproute
Reading Package Lists... Done
Building Dependency Tree... Done
Package iproute is not installed, so not removed
0 packages upgraded, 0 newly installed, 0 removed and 2 not upgraded.
W: There are multiple versions of "iproute" in your system.

This package won't be cleanly updated, unless you leave
only one version. To leave multiple versions installed,
you may remove that warning by setting the following
option in your configuration file:

RPM::Allow-Duplicated { "^iproute$"; };

To disable these warnings completely set:

RPM::Allow-Duplicated-Warning "false";

W: You may want to run apt-get update to correct these problems


I have run the apt-get update, and this doesnt fix the problem, can anyone help?

Thanks
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
iproute vishamr2000 Linux - Networking 4 08-04-2005 02:40 AM
tables in iproute mikerock Linux - Networking 1 05-12-2005 04:39 AM
new to iproute. please help ? mrpc_cambodia Red Hat 0 07-06-2004 12:20 AM
iproute with 2.6.5 (slack 9.1) Soma Slackware 4 04-20-2004 03:17 AM
how to install iproute KoKi Linux - Networking 5 02-03-2004 04:47 PM


All times are GMT -5. The time now is 12:54 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration