LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 02-25-2005, 05:05 PM   #1
hongman
Member
 
Registered: Feb 2005
Location: UK
Distribution: Knoppix 3.7
Posts: 285

Rep: Reputation: 35
2 small problems


Hello all

Question number 1:

What file is it I have to edit to get root to show up on the logon gui? I know the risks, etc but I want it there.

Question 2:

I have just done a fresh Knoppix install and I cant seem to access the floppy drive. When I click on it, I can hear it trying to access the floppy but it comes up with error file:/mnt/floppy doesnt exist.

I know the FDD works coz I used it about 3 hours ago in XP...

Thanks

Hong
 
Old 02-25-2005, 05:09 PM   #2
Mara
Moderator
 
Registered: Feb 2002
Location: Grenoble
Distribution: Debian
Posts: 9,539

Rep: Reputation: 149Reputation: 149
Q1
It depends on the login manager. Do you run kdm or gdm?

Q2
Check if /mnt/floppy exists in your system. If it exists look if it's readable for you (right click, Properties, Permissions, look what's set for other users). If it all seems correct look into /etc/fstab. Find line with /mnt/floppy and post it.
 
Old 02-25-2005, 09:21 PM   #3
hongman
Member
 
Registered: Feb 2005
Location: UK
Distribution: Knoppix 3.7
Posts: 285

Original Poster
Rep: Reputation: 35
I think I am using kdm?

/mnt/floppy does exist on my system. All the Permissions tas are greyed out and say 'link'.

My etc/fstab is

# /etc/fstab: filesystem table.
#
# filesystem mountpoint type options dump pass
/dev/hdb2 / ext3 defaults,errors=remount-ro 0 1

proc /proc proc defaults 0 0
/dev/fd0 /floppy vfat defaults,user,noauto,showexec,umask=022 0 0
usbdevfs /proc/bus/usb usbdevfs defaults 0 0
sysfs /sys sysfs defaults 0 0
/dev/cdrom /cdrom iso9660 defaults,ro,user,noexec,noauto 0 0
/dev/dvd /dvd iso9660 defaults,ro,user,noexec,noauto 0 0
/dev/cdaudio /cdaudio iso9660 defaults,ro,user,noexec,noauto 0 0
# Added by KNOPPIX
/dev/hdc1 /mnt/hdc1 ntfs noauto,users,exec,ro,umask=000 0 0
# Added by KNOPPIX
/dev/hdd5 /mnt/hdd5 ntfs noauto,users,exec,ro,umask=000 0 0
# Added by KNOPPIX
/dev/hdb1 none swap defaults 0 0
# Added by KNOPPIX
/dev/hdb3 /mnt/hdb3 ext3 noauto,users,exec 0 0



Thanks

Hong
 
Old 02-25-2005, 09:47 PM   #4
tomasch
LQ Newbie
 
Registered: Feb 2005
Posts: 10

Rep: Reputation: 0
Try with a floppy *in* the drive and see if that works when you mount it

T
 
Old 02-26-2005, 08:36 AM   #5
hongman
Member
 
Registered: Feb 2005
Location: UK
Distribution: Knoppix 3.7
Posts: 285

Original Poster
Rep: Reputation: 35
Thanks

hehehe, yes tried that. I can even hear it trying to access the drive...

But still no go

HOng
 
Old 02-26-2005, 02:36 PM   #6
Mara
Moderator
 
Registered: Feb 2002
Location: Grenoble
Distribution: Debian
Posts: 9,539

Rep: Reputation: 149Reputation: 149
Quote:
Originally posted by hongman
I think I am using kdm?
In this case it's easiest to run KDE Control Center, then System Administration, Login Manager. Switch to Users tab. Click on the Administrator mode button, enter root password and then change what you need. When you're at this point you should clearly see it.

Quote:
/mnt/floppy does exist on my system. All the Permissions tas are greyed out and say 'link'.
And it probably points to /floppy

Quote:
/dev/fd0 /floppy vfat defaults,user,noauto,showexec,umask=022 0 0
Run
mount /floppy
as your user (from a terminal etc). The floppy should be now accessible - it's mountable by user. To stop using it run
umount /floppy
If I remember correctly the drive stays locked until you do it.

If you want it to mount automatically, there's a way for sure, but the one I think of is for sure not the easiest one. Maybe someone will come by and post it.
 
Old 02-26-2005, 03:56 PM   #7
hongman
Member
 
Registered: Feb 2005
Location: UK
Distribution: Knoppix 3.7
Posts: 285

Original Poster
Rep: Reputation: 35
Thanks Mara

So is KDM the same as KDE?

Anyways, I got to the bit you said, which I had navigated to before anyhows. But I cant see anything obvious. I was expecting maybe a button named 'Add USer' or something similar? I just get a page that lists details about System ID's, Hidden Users and stuf like that...am i missing the obvious?

I went to terminal and typed mount /floppy and then I stuck a disk in, clicked on the desktop icon and a blank window came up (as if there was nothing on the disk). I created a blank text file and tried to put it on the floppy and it said 'Access Denied'. I then did umount /floppy and repeated the procedure, and the result was the same.

Can Linux read FAT32/16 whatever the native Floppy format is for Windows?

Thanks

Hong
 
Old 02-26-2005, 04:11 PM   #8
Mara
Moderator
 
Registered: Feb 2002
Location: Grenoble
Distribution: Debian
Posts: 9,539

Rep: Reputation: 149Reputation: 149
Quote:
Originally posted by hongman
So is KDM the same as KDE?
Not exactly. It's one of the app comming with KDE. But when you're running KDE there's very high probability you'll be running KDE, too. It looks my assumption was correct.

Quote:
Anyways, I got to the bit you said, which I had navigated to before anyhows. But I cant see anything obvious. I was expecting maybe a button named 'Add USer' or something similar? I just get a page that lists details about System ID's, Hidden Users and stuf like that...am i missing the obvious?
What's important is the Hidden User/Selected Users list. You have root here, right? Select/unselect root (depending in which mode it is at this time). If you have a Hidden User list, make sure root is not checked. If it's Selected Users, make sure it's checked. You switch the modes using Inverse selection.

I hope it was clear this time.

Quote:
I went to terminal and typed mount /floppy and then I stuck a disk in, clicked on the desktop icon and a blank window came up (as if there was nothing on the disk). I created a blank text file and tried to put it on the floppy and it said 'Access Denied'. I then did umount /floppy and repeated the procedure, and the result was the same.
Change the line to
/dev/fd0 /floppy vfat defaults,user,noauto,showexec,umask=0 0 0
Permissions will allow you write the disk this time.

Quote:
Can Linux read FAT32/16 whatever the native Floppy format is for Windows?
Yes, it can read/write it. 'vfat' option in the line above tells it it's a FAT drive. You can also use 'auto' instead (then the filesystem will be detected automatically).
 
Old 02-26-2005, 04:29 PM   #9
hongman
Member
 
Registered: Feb 2005
Location: UK
Distribution: Knoppix 3.7
Posts: 285

Original Poster
Rep: Reputation: 35
Thanks Mara, you've been most helpful!

Sorry about the whole logon thing, I had confused myself with another question I had in mind, which was how to add another user Stupid.

I did
Code:
/dev/fd0 /floppy vfat....
it said bash: /dev/fd0: Permission Denied

I was root....

How hard can this be? I only want 1 excel file from my disk!!

Oh well, suppose its all part of the Linux Experience


HOng
 
Old 02-26-2005, 04:45 PM   #10
hongman
Member
 
Registered: Feb 2005
Location: UK
Distribution: Knoppix 3.7
Posts: 285

Original Poster
Rep: Reputation: 35
Hmm, I thnk there is a trend going on here.
I just burtn a CD off using k3b, and now when I put it into the drive nothing happens. I tried doing mount /cdrom and mount /dev/cdrom and I can here the drive spin up both times, but still when I click on the cdrom icon its blank.

Thanks for the help, I will get there in the end!!

Hong
 
Old 02-27-2005, 04:24 PM   #11
Mara
Moderator
 
Registered: Feb 2002
Location: Grenoble
Distribution: Debian
Posts: 9,539

Rep: Reputation: 149Reputation: 149
Quote:
Originally posted by hongman
I did
Code:
/dev/fd0 /floppy vfat....
it said bash: /dev/fd0: Permission Denied
But it worked before the modification (or pretended to work)?

Quote:
I just burtn a CD off using k3b, and now when I put it into the drive nothing happens. I tried doing mount /cdrom and mount /dev/cdrom and I can here the drive spin up both times, but still when I click on the cdrom icon its blank.
So it looks you should see in the logs what's going on...Look into /var/log/messages and fine time near of one of your mounting attempts. Do you have any floppy/cdrom related messages?
 
Old 02-27-2005, 04:55 PM   #12
hongman
Member
 
Registered: Feb 2005
Location: UK
Distribution: Knoppix 3.7
Posts: 285

Original Poster
Rep: Reputation: 35
Ok, found the solution.

Turns out all this time I was messing around, allI had to do was

Code:
 mount /floppy
and then navigate to /floppy. Voila!

Same with CDROM, as in mount /cdrom and thats it. I changed the desktop shortcut paths to /floppy and /cdrom instead of /mnt/floppy and /mnt/cdrom. All works fine now

Thanks everyone

Hong
 
Old 02-27-2005, 05:01 PM   #13
Mara
Moderator
 
Registered: Feb 2002
Location: Grenoble
Distribution: Debian
Posts: 9,539

Rep: Reputation: 149Reputation: 149

Good to know you've managed. Good luck!
 
Old 02-27-2005, 05:04 PM   #14
hongman
Member
 
Registered: Feb 2005
Location: UK
Distribution: Knoppix 3.7
Posts: 285

Original Poster
Rep: Reputation: 35
Thanks Mara!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
2 small problems paul_linux_user Fedora 0 05-20-2004 04:40 PM
MySQl: small problems WiWa Linux - Software 2 08-02-2003 09:06 AM
small problems with kernel wlfdgcrkz Linux - Software 4 06-06-2003 03:39 PM
3 small problems in 1 small post vzzt! Linux - Software 10 02-27-2003 08:40 PM
Two small problems jimmmac Linux - General 9 12-14-2002 10:36 PM


All times are GMT -5. The time now is 10:19 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration