LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 01-03-2002, 05:00 AM   #1
bewshy
LQ Newbie
 
Registered: Jan 2002
Posts: 1

Rep: Reputation: 0
2 HD's Win98SE and RH7.2 Tried Everything HELP!


Hello. I was wondering if anyone could shed some light onto my problem. I have 2 hd's I have win98 setup on my 20 gig maxtor and I have a 10 gig for RH 7.2 Ive tried using GRUB and lilo and I cant get it to boot into Win98. I have my RH drive as Primary Master and my Win98 HD as Primary Slave. Rh will boot but it wont boot Win98. Now If I remove the RH HD from the IDE chain and put the Win98 hd as Primary Master It will boot. Ive tried everything possible. Even has tried puting one on secondary and the other on primary. Any help would be appreciated.


thanks

EricB
 
Old 01-03-2002, 07:24 AM   #2
Mik
Senior Member
 
Registered: Dec 2001
Location: The Netherlands
Distribution: Ubuntu
Posts: 1,316

Rep: Reputation: 47
That's not a problem with lilo or grub but with Windows 98. Windows 9X will only boot if it's on the first partition on the master-primary drive.
Your best option is to leave windows as the master drive, redhat as secondary and install lilo/grub on the master drive.
 
Old 01-03-2002, 01:21 PM   #3
Scotty2435
Member
 
Registered: Dec 2001
Location: Waco, Texas USA
Distribution: Redhat 7.1
Posts: 232

Rep: Reputation: 30
i used to have this problem. I had to change the jumper settings everytime (annoying)
 
Old 01-03-2002, 04:09 PM   #4
taz.devil
Senior Member
 
Registered: Nov 2001
Location: Wa. State
Distribution: Slackware
Posts: 1,261

Rep: Reputation: 45
Quote:
Originally posted by Mik
That's not a problem with lilo or grub but with Windows 98. Windows 9X will only boot if it's on the first partition on the master-primary drive.
Your best option is to leave windows as the master drive, redhat as secondary and install lilo/grub on the master drive.
Much agreed! Windows is the pickiest piece of OS in the world and always wants to be first. This is the de facto way to go. Just wake me up before you go go...
 
Old 01-04-2002, 01:14 AM   #5
linuxcool
LQ Addict
 
Registered: Jun 2001
Posts: 1,183

Rep: Reputation: 47
bewshy, try this.

If you're using lilo, add these lines to lilo.conf:

map-drive=0x80
to=0x81
map-drive=0x81
to=0x80


Then run /sbin/lilo.

If you're using grub, add these to menu.lst:

map (hd0) (hd1)
map (hd1) (hd0)
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Using 2 HD's with different OS?? fhameed Linux - Hardware 8 09-08-2004 07:34 AM
2 slackware using 2 HD's danielfisica Linux - Newbie 4 05-27-2004 04:42 AM
Two HD's Scratchit Linux - Newbie 5 05-26-2004 11:20 PM
installing RH7.2 or 7.3 fails; RH7.1 & W2k work great river Linux - Software 4 05-24-2002 05:45 PM
Upgrade RH7.1 to RH7.2 with two .iso files t0dd Linux - Software 1 01-31-2002 06:47 PM


All times are GMT -5. The time now is 01:06 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration