LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 04-05-2012, 11:05 PM   #1
jindex
LQ Newbie
 
Registered: Apr 2012
Posts: 2

Rep: Reputation: Disabled
2.6.9 Kernel boot panic, "append correct root= boot option"


Hi guys. The site suggested I post in this forum department first when I tried posting in the kernel section, so I'll try here first. Sorry if it's the wrong section. (new here, but been browsing the site a fair lot for answers to this)

When I try to run my compiled kernel it gives me the following during boot:

VFS: Cannot open root device "LABEL=/" (or hda1 or whatever I try) or unknown block(0,0)
Please append correct "root=" boot option
Kernel panic - not syncing: VFS: unable to mount root fs on unknown block (0,0)

First off I'll just list off the details.
I'm running Red hat Linux 9 as vmware on workstation 8.
My running kernel is 2.4.20-8.
The OS is installed on an IDE harddrive (apparently this matters)
I downloaded the 2.6.9 kernel, patched it with LTT vanilla and relayfs (both for 2.6.9).
Configured kernel with "make gconfig", implemented ext3 compatibility as well as the LTT and Relayfs options (NOT as modules).

Compiled the kernel with "make clean; make bzImage" command.
ran commands "make modules" and "make modules_install".
copied the bzImage to /boot directory and changed name to vmlinuz-2.6.9-ltt .

Configured the bootloader to the following (including current kernel):

# NOTICE: you have a /boot partition. this means that
#all kernel and initrd paths are releative to /boot/, eg
# root (hd0,0)
# kernel /vmlinuz-version ro root=/dev/hdd2
# initrd /initrd-version.img
#boot=/dev/hdd

default=0
timeout=10
splashimage-(hd0,0)/grub/splash.xpm.gz
title Red Had Linux (2.4.20-8)
root (hd0,0)
kernel /vmlinuz-2.4.20-8 ro root=LABEL=/ hdc=ide-scsi
initrd /initrd-2.4.20-8.img


title Red Hat Linux (2.6.9-ltt)
root (hd0,0)
kernel /vmlinuz-2.6.9-ltt ro root=/dev/hda1 hdc=ide-scsi



not using an initrd path 'cause it shouldn't be needed. I've tried figuring out what partitions and devices I'm supposed to use by running grub through the command line, but I just can't figure this out.


Any help would be appreciated.

Last edited by jindex; 04-05-2012 at 11:07 PM. Reason: Spelling errors
 
Old 04-05-2012, 11:25 PM   #2
syg00
LQ Veteran
 
Registered: Aug 2003
Location: Australia
Distribution: Lots ...
Posts: 14,838

Rep: Reputation: 1822Reputation: 1822Reputation: 1822Reputation: 1822Reputation: 1822Reputation: 1822Reputation: 1822Reputation: 1822Reputation: 1822Reputation: 1822Reputation: 1822
Quote:
Originally Posted by jindex View Post
... not using an initrd path 'cause it shouldn't be needed.
You reckon ?.
Seems the kernel disagrees. Either you haven't included the driver for your hard-disk controller, or you haven't build the filesystem in.
Probably.
 
Old 04-05-2012, 11:47 PM   #3
jindex
LQ Newbie
 
Registered: Apr 2012
Posts: 2

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by syg00 View Post
You reckon ?.
Seems the kernel disagrees. Either you haven't included the driver for your hard-disk controller, or you haven't build the filesystem in.
Probably.
Somebody I know got by without an initrd. I can't consult with him about what he did to make it work until Tuesday however.

So looking at the grub do you suppose I've specified the correct devices and partitions? And what do you mean by building the file system in?

Thanks
 
Old 04-06-2012, 12:49 AM   #4
syg00
LQ Veteran
 
Registered: Aug 2003
Location: Australia
Distribution: Lots ...
Posts: 14,838

Rep: Reputation: 1822Reputation: 1822Reputation: 1822Reputation: 1822Reputation: 1822Reputation: 1822Reputation: 1822Reputation: 1822Reputation: 1822Reputation: 1822Reputation: 1822
*Everything* needed to mount the root filesystem has to be available to the kernel when it attempts to do so. That includes the filesystem support. If you plan on not using a separate initrd, you have to ensure none of the required components are built as modules.

If you took a normal RH config and just built the kernel from that without checking this, there is almost no chance it will boot without an initrd.

Edit: forgot the grub query. Yep, you must be pointing at the correct partition. The kernel has been loaded and is running (VFS is a kernel component).

Last edited by syg00; 04-06-2012 at 01:20 AM.
 
Old 04-06-2012, 02:27 AM   #5
ukiuki
Senior Member
 
Registered: May 2010
Location: Planet Earth
Distribution: Debian
Posts: 1,030

Rep: Reputation: 380Reputation: 380Reputation: 380Reputation: 380
Quote:
Originally Posted by jindex View Post
Somebody I know got by without an initrd. ...
If you aren't using initrd what are you using then? InitNG , Upstart or what?

Quote:
Originally Posted by jindex View Post
...I've specified the correct devices and partitions?...
Have you?

Regards
 
Old 04-06-2012, 05:26 AM   #6
syg00
LQ Veteran
 
Registered: Aug 2003
Location: Australia
Distribution: Lots ...
Posts: 14,838

Rep: Reputation: 1822Reputation: 1822Reputation: 1822Reputation: 1822Reputation: 1822Reputation: 1822Reputation: 1822Reputation: 1822Reputation: 1822Reputation: 1822Reputation: 1822
Sorry - see below.

Last edited by syg00; 04-06-2012 at 05:28 AM.
 
Old 04-06-2012, 05:28 AM   #7
syg00
LQ Veteran
 
Registered: Aug 2003
Location: Australia
Distribution: Lots ...
Posts: 14,838

Rep: Reputation: 1822Reputation: 1822Reputation: 1822Reputation: 1822Reputation: 1822Reputation: 1822Reputation: 1822Reputation: 1822Reputation: 1822Reputation: 1822Reputation: 1822
Quote:
Originally Posted by ukiuki View Post
If you aren't using initrd what are you using then? InitNG , Upstart or what?
Totally irrelevant.
The initrd has nothing to do with the init task run after the kernel has finished initializing.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Another Kernel Panic (Please append a correct root= option, not syncing, etc.) Blender3D Linux From Scratch 5 06-13-2010 09:13 PM
Stuck on "GRUB_" Screen - Will boot from Live CD "Boot from first hard disk" option Snowman11 Linux - Newbie 10 02-01-2009 07:52 PM
custom boot cd fails to boot with "Kernel panic - not syncing : vfs" ramachandra_ankireddy Linux From Scratch 1 11-23-2008 06:10 PM
"Kernel panic: VFS: Unable to mount root fs" - Kernel fails to boot linux Freedom Seeker Linux - General 11 11-12-2006 08:48 PM
"root=" option for SATA drives to avoid kernel panic neelay1 Linux - Software 1 05-01-2006 02:18 PM


All times are GMT -5. The time now is 12:36 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration