LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 10-07-2011, 10:44 AM   #1
trinityforce
LQ Newbie
 
Registered: Oct 2011
Posts: 18

Rep: Reputation: Disabled
1TB disk divided into 3 partitions


I am using RHEL5 and I am trying to partition a second 1TB disk into 3 primary partitions using fdisk. I got all 3 created, formated, file system ext3, and then mounted them fine. Added the entries into fstab and rebooted. When I rebooted it came up with a problem with fsck checking these file systems and not mounting them? Do I need to set these up differently?

/dev/sdb1 primary 40GB
/dev/sdb2 primary 60GB
/dev/sdb3 primary remainder of space

I used mkfs.ext3
 
Old 10-07-2011, 11:44 AM   #2
JSkywalker
Member
 
Registered: Aug 2007
Distribution: openSUSE 12.1
Posts: 96

Rep: Reputation: 24
how does your /etc/fstab look like?

yout should have created three additional lines like this (untested, and i'm not sure if they are complete):
/dev/sdb1 /mountpoint1 ext3 defaults 0 0

the first argument (/dev/sdb1) is the name of the disppartition
the second argument (/mountpoint1) is the name of the directory where you want to mount this partition
the third argument (ext3) is the filesystemtype
for the rest of the argument i recomend a look at 'man fstab'
 
Old 10-07-2011, 11:53 AM   #3
snapshot15
LQ Newbie
 
Registered: Aug 2011
Distribution: Mint, Debian, CentOS
Posts: 7

Rep: Reputation: Disabled
Quote:
Originally Posted by JSkywalker View Post
yout should have created three additional lines like this (untested, and i'm not sure if they are complete):
/dev/sdb1 /mountpoint1 ext3 defaults 0 0

the first argument (/dev/sdb1) is the name of the disppartition
the second argument (/mountpoint1) is the name of the directory where you want to mount this partition
the third argument (ext3) is the filesystemtype
for the rest of the argument i recomend a look at 'man fstab'
Here is some great documentation directly correlating to the above post:

http://www.tuxfiles.org/linuxhelp/fstab.html

I think this is a great reference for fstab and mount options.
 
Old 10-07-2011, 12:10 PM   #4
trinityforce
LQ Newbie
 
Registered: Oct 2011
Posts: 18

Original Poster
Rep: Reputation: Disabled
I had the fstab setup per the instructions as

/dev/sdb1 /mountpoint ext3 default 1 2
/dev/sdb2 /mountpoint ext3 default 1 2
/dev/sdb3 /mountpoint ext3 default 1 2
 
Old 10-07-2011, 12:54 PM   #5
snapshot15
LQ Newbie
 
Registered: Aug 2011
Distribution: Mint, Debian, CentOS
Posts: 7

Rep: Reputation: Disabled
Quote:
Originally Posted by trinityforce View Post
I had the fstab setup per the instructions as

/dev/sdb1 /mountpoint ext3 default 1 2
/dev/sdb2 /mountpoint ext3 default 1 2
/dev/sdb3 /mountpoint ext3 default 1 2

I'm a little confused here:

If this is your exact fstab you are mounting each partition on sdb to the mountpoint /mountpoint. Did you create a location called /mountpoint?

I would change default to defaults

Your <dump> column of 1 indicates that you have dump installed and you want each partition backed up. I would recommend changing to 0.

Your <pass> column of 2 will run fsck to check the filesystems at boot with secondary priority after whichever is labeled 1. Change to 0 if you do not want the systems checked by fsck.

EDIT: One last suggestion! I would recommend using each partition's UUID instead of "/dev/sdb1". I do this as a precautionary measure so nothing can get borked reading the information.

Last edited by snapshot15; 10-07-2011 at 12:56 PM.
 
Old 10-07-2011, 12:55 PM   #6
trinityforce
LQ Newbie
 
Registered: Oct 2011
Posts: 18

Original Poster
Rep: Reputation: Disabled
I think the issue was the 1 2 at the end. It was doing a fsck and bombing, just not sure why. When I orginally set the partitions up I mounted them and they seem to be fine. It was just on the reboot that fsck had a problem?
 
Old 10-07-2011, 02:54 PM   #7
kbscores
Member
 
Registered: Oct 2011
Location: USA
Distribution: Red Hat
Posts: 259
Blog Entries: 9

Rep: Reputation: 32
Perhaps stagger your checks. What is error you get when fsck runs? Or does it keep forcing fsck in maint mode? Try w/fsck and dump as 0. See if it mounts like that first. How often does this machine get rebooted?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
created 2 partitions in 1TB extrnal hdd. mazhar07 Linux - Newbie 3 04-01-2011 03:35 AM
can`t see 1Tb SATA disk - slackware 10.2.0 levnrg Slackware 1 06-01-2010 10:55 AM
1tb hard disk partition ekalavya Linux - Newbie 7 05-05-2010 07:38 AM
One partition or many for 1TB disk? Ook Linux - Newbie 9 06-24-2009 09:45 PM
Strange Behavior 1TB Hard Disk Drive Igby Linux - Server 4 05-28-2009 01:31 PM


All times are GMT -5. The time now is 08:40 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration