LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 06-02-2008, 10:22 PM   #16
steve5673
LQ Newbie
 
Registered: May 2008
Posts: 20

Original Poster
Rep: Reputation: 0

Thanks Emerson - I checked the packet manager, searched for fglrx and it was located in the package xserver-xorg-video-ati. I re-installed then replaced "vesa" with fglrx. On start up xserver cashes and says it fails to start. IN the xserver window it says that 'Failed to load module "fglrx" (module does not exist, 0)
 
Old 06-02-2008, 11:48 PM   #17
hbrhodes1s
LQ Newbie
 
Registered: Jun 2008
Posts: 3

Rep: Reputation: 0
Post FC-5 1440x900_60 trouble

Hi there, i am hbrhodes1s & I have been using Fedora since Fedora 3. i have gone back and forth between Windows XP and FC because of the trouble i have had trouble getting both displays working with FC. i have read the posts for this forum and one other post and have not made sense of what is going on. here follows are my goals/ questions, gtf output and my xorg.conf

btw, right now i am using a generically built computer with an AMD Athlon XP 1600+ process, with about 1500mgs of ddr mem, using FC5 with a nVidia geforce2 (?) 6200 card. i have both the xorg-x11-drv-nv.i386 & xorg-x11-drv-nvidia.i386 drivers installed, i also noticed a xorg-x11-drv-nvidia-legacy.i386 which i do not have installed (only need one right?). would also like to enable to option for glide or whatnot (glx?).

0) i would like to get my LG194WT-SF wide monitor to display properly, right now it is only working from about 1280x800 "i think." i say that because the screen resolution states it is such, and I have attempted to tell it to do 1440x1050. Not sure what i have. So i deleted that entry from my xorg.conf and replaced it with "1440x900" to no avail! If all goes well and i get this resolution going (with your help naturally) i might try dual monitors from the same agp card.

1) i really do not know what goes where as i have never messed with these things. i think the modeline entry should go under the monitors vertical refresh rate, or perhaps the Option "vesa." Even though it was mentioned that vesa does not go over "800x600." The original entry was dpms.

2) [gtf 1440 900 60] is:
# 1440x900 @ 60.00 Hz (GTF) hsync: 55.92 kHz; pclk: 106.47 MHz
Modeline "1440x900_60.00" 106.47 1440 1520 1672 1904 900 901 904 932 -HSync +Vsync

3) my xorg.conf file is:

# Xorg configuration created by system-config-display

Section "ServerLayout"
Identifier "single head configuration"
Screen 0 "Screen0" 0 0
InputDevice "Mouse0" "CorePointer"
InputDevice "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"

# Multiple FontPath entries are allowed (they are concatenated together)
# By default, a font server independent of the X server is
# used to render fonts.
FontPath "unix/:7100"
EndSection

Section "Module"
Load "dbe"
Load "extmod"
Load "fbdevhw"
Load "glx"
Load "record"
Load "freetype"
Load "type1"
Load "dri"
EndSection

Section "InputDevice"

# Specify which keyboard LEDs can be user-controlled (eg, with xset(1))
# Option "Xleds" "1 2 3"
# To disable the XKEYBOARD extension, uncomment XkbDisable.
# Option "XkbDisable"
# To customise the XKB settings to suit your keyboard, modify the
# lines below (which are the defaults). For example, for a non-U.S.
# keyboard, you will probably want to use:
# Option "XkbModel" "pc102"
# If you have a US Microsoft Natural keyboard, you can use:
# Option "XkbModel" "microsoft"
#
# Then to change the language, change the Layout setting.
# For example, a german layout can be obtained with:
# Option "XkbLayout" "de"
# or:
# Option "XkbLayout" "de"
# Option "XkbVariant" "nodeadkeys"
#
# If you'd like to switch the positions of your capslock and
# control keys, use:
# Option "XkbOptions" "ctrl:swapcaps"
# Or if you just want both to be control, use:
# Option "XkbOptions" "ctrl:nocaps"
#
Identifier "Keyboard0"
Driver "kbd"
Option "XkbModel" "pc105"
Option "XkbLayout" "us"
EndSection

Section "InputDevice"
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "IMPS/2"
Option "Device" "/dev/input/mice"
Option "ZAxisMapping" "4 5"
Option "Emulate3Buttons" "yes"
EndSection

Section "Monitor"
### Comment all HorizSync and VertSync values to use DDC:
Identifier "Monitor0"
VendorName "Flatron"
ModelName "L194WT-SF"
HorizSync 30.0 - 83.0
VertRefresh 56.0 - 75.0
Option "vesa"
EndSection

Section "Device"
Identifier "Videocard0"
Driver "nv"
VendorName "Videocard vendor"
BoardName "nVidia Corporation GeForce 6200"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Videocard0"
Monitor "Monitor0"
DefaultDepth 24
SubSection "Display"
Viewport 0 0
Depth 24
Modes "1440x900"
EndSubSection
EndSection

Section "DRI"
Group 0
Mode 0666
EndSection

Last edited by hbrhodes1s; 06-03-2008 at 12:05 AM.
 
Old 06-03-2008, 12:08 AM   #18
pixellany
LQ Veteran
 
Registered: Nov 2005
Location: Annapolis, MD
Distribution: Arch/XFCE
Posts: 17,802

Rep: Reputation: 738Reputation: 738Reputation: 738Reputation: 738Reputation: 738Reputation: 738Reputation: 738
Ummmm...how about the radeon driver (not Radeon)? (Remember, case matters...)

To verify what drivers are available, look in:
/usr/lib/xorg/modules/drivers

I have never used the fglrx driver, but that may be an option also---search for it using the package manager (but try radeon first)
 
Old 06-03-2008, 12:14 AM   #19
pixellany
LQ Veteran
 
Registered: Nov 2005
Location: Annapolis, MD
Distribution: Arch/XFCE
Posts: 17,802

Rep: Reputation: 738Reputation: 738Reputation: 738Reputation: 738Reputation: 738Reputation: 738Reputation: 738
Ignoring, for the moment, the new member who just hi-jacked the thread......

Quote:
Thanks Emerson - I checked the packet manager, searched for fglrx and it was located in the package xserver-xorg-video-ati. I re-installed then replaced "vesa" with fglrx. On start up xserver cashes and says it fails to start. IN the xserver window it says that 'Failed to load module "fglrx" (module does not exist, 0)
Please clarify what you did here....Did you actually install fglrx? Check in:
/usr/lib/xorg/modules/drivers
to be sure.

Another tool: look at /var/log/Xorg.0.log---look near the end for error messages (prefix (EE))
 
Old 06-03-2008, 12:17 AM   #20
pixellany
LQ Veteran
 
Registered: Nov 2005
Location: Annapolis, MD
Distribution: Arch/XFCE
Posts: 17,802

Rep: Reputation: 738Reputation: 738Reputation: 738Reputation: 738Reputation: 738Reputation: 738Reputation: 738
hbrhodes1s;

Welcome to LQ. We will help you, but you have just jumped in the middle of a thread that is already confusing enough. In this case, I think it is best to start a new thread. If someone jumps on you for double-posting, blame me.
 
Old 06-03-2008, 12:21 AM   #21
hbrhodes1s
LQ Newbie
 
Registered: Jun 2008
Posts: 3

Rep: Reputation: 0
New guy apologizes

OKAY, i apologize sincerely! i thought it prudent and appropriate to place my post here instead of starting another one, heh. i am embarrassed. i just managed to fix my troubles though not five minutes after i hi-jacked the thread!

first i deleted the xorg-x11-drv-nv.i386 driver.
second i kept the xorg-x11-drv-nvidia.i386 driver.
i changed my xorg.conf file from the Driver "nv" to "nvidia." i thank you all and i apologize to pixellany, all the help in solving this three hour problem (maybe five) was in the threads (and removing the bad driver)!



# Xorg configuration created by system-config-display

Section "ServerLayout"
Identifier "single head configuration"
Screen 0 "Screen0" 0 0
InputDevice "Mouse0" "CorePointer"
InputDevice "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"

# Multiple FontPath entries are allowed (they are concatenated together)
# By default, a font server independent of the X server is
# used to render fonts.
FontPath "unix/:7100"
EndSection

Section "Module"
Load "dbe"
Load "extmod"
Load "fbdevhw"
Load "glx"
Load "record"
Load "freetype"
Load "type1"
Load "dri"
EndSection

Section "InputDevice"

# Specify which keyboard LEDs can be user-controlled (eg, with xset(1))
# Option "Xleds" "1 2 3"
# To disable the XKEYBOARD extension, uncomment XkbDisable.
# Option "XkbDisable"
# To customise the XKB settings to suit your keyboard, modify the
# lines below (which are the defaults). For example, for a non-U.S.
# keyboard, you will probably want to use:
# Option "XkbModel" "pc102"
# If you have a US Microsoft Natural keyboard, you can use:
# Option "XkbModel" "microsoft"
#
# Then to change the language, change the Layout setting.
# For example, a german layout can be obtained with:
# Option "XkbLayout" "de"
# or:
# Option "XkbLayout" "de"
# Option "XkbVariant" "nodeadkeys"
#
# If you'd like to switch the positions of your capslock and
# control keys, use:
# Option "XkbOptions" "ctrl:swapcaps"
# Or if you just want both to be control, use:
# Option "XkbOptions" "ctrl:nocaps"
#
Identifier "Keyboard0"
Driver "kbd"
Option "XkbModel" "pc105"
Option "XkbLayout" "us"
EndSection

Section "InputDevice"
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "IMPS/2"
Option "Device" "/dev/input/mice"
Option "ZAxisMapping" "4 5"
Option "Emulate3Buttons" "yes"
EndSection

Section "Monitor"
### Comment all HorizSync and VertSync values to use DDC:
Identifier "Monitor0"
VendorName "Flatron"
ModelName "L194WT-SF"
HorizSync 30.0 - 83.0
VertRefresh 56.0 - 75.0
Option "vesa"
EndSection

Section "Device"
Identifier "Videocard0"
Driver "nvidia"
VendorName "nVidia Corporation"
BoardName "GeForce 6200"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Videocard0"
Monitor "Monitor0"
DefaultDepth 24
SubSection "Display"
Viewport 0 0
Depth 32
Modes "1440x900"
EndSubSection
EndSection

Section "DRI"
Group 0
Mode 0666
EndSection
 
Old 06-03-2008, 12:30 AM   #22
pixellany
LQ Veteran
 
Registered: Nov 2005
Location: Annapolis, MD
Distribution: Arch/XFCE
Posts: 17,802

Rep: Reputation: 738Reputation: 738Reputation: 738Reputation: 738Reputation: 738Reputation: 738Reputation: 738
hb;
Please don't spend a lot of energy apologizing....the point is only to help you get help.

One more request: Don't post huge long files--almost always there is only a small portion that is relevant.

And please don't apologize again.......



NOW...how is steve doing????
 
Old 06-03-2008, 12:37 AM   #23
steve5673
LQ Newbie
 
Registered: May 2008
Posts: 20

Original Poster
Rep: Reputation: 0
sorry - back to basics again - How do I look in the "/usr/lib/xorg/modules/drivers" as i get the message ": is a directory" which I knew, but couldn't find a way in.
 
Old 06-03-2008, 12:50 AM   #24
pixellany
LQ Veteran
 
Registered: Nov 2005
Location: Annapolis, MD
Distribution: Arch/XFCE
Posts: 17,802

Rep: Reputation: 738Reputation: 738Reputation: 738Reputation: 738Reputation: 738Reputation: 738Reputation: 738
steve;

It is really gratifying to see you sticking with things......

It is clear that terminal commands are somewhat alien to you. I suggest you dabble a bit with a few basics:
cd (change directory)
ls (list contents of current directory)
ls -l (long listing)
ls /etc (list the contents of the directory named "/etc")
cp (copy files or directories)
mv (rename files or directories)
more (display the contents of a file--one page at a time)

For details on any of these, enter "man" + the name of the command---eg "man cd" If you get something about BASH builtins, then enter "man bash".

For the basic commands, look also at "info coreutils"

One more thing to note: you can access files and directories with either absolute or relative addressing. If you are in your home directory, you can read a file in /etc, by typing "more /etc/filename" OR you can cd to /etc and then enter "more filename".
To see where you are: "pwd"
To go home: "cd ~" or just "cd"
 
Old 06-03-2008, 06:44 AM   #25
steve5673
LQ Newbie
 
Registered: May 2008
Posts: 20

Original Poster
Rep: Reputation: 0
looking into /usr/lib/xorg/modules/drivers, I can see "ati_drv.so"; "radeon_drv.so"; but no "fglrx". I thought I did install or re-install from the GUI.
 
Old 06-03-2008, 09:11 AM   #26
pixellany
LQ Veteran
 
Registered: Nov 2005
Location: Annapolis, MD
Distribution: Arch/XFCE
Posts: 17,802

Rep: Reputation: 738Reputation: 738Reputation: 738Reputation: 738Reputation: 738Reputation: 738Reputation: 738
Quote:
Originally Posted by steve5673 View Post
looking into /usr/lib/xorg/modules/drivers, I can see "ati_drv.so"; "radeon_drv.so"; but no "fglrx". I thought I did install or re-install from the GUI.
You would need to install using the package manager--eg Synaptic, Adept, or whatever is on your system. In a terminal, you can use apt-get if you know the exact name of the package.

How about "radeon"?? Have you tried that?
 
Old 06-03-2008, 09:26 AM   #27
Emerson
LQ Guru
 
Registered: Nov 2004
Location: Saint Amant, Acadiana
Distribution: Gentoo ~arch
Posts: 5,872

Rep: Reputation: Disabled
IMO specifying ati or radeon both result in loading the OSS driver. Also, I'm not sure how well OSS driver 2D functions work for your chip, this is why I suggested you try fglrx.
This table may help to understand the current driver situation: http://www.gentoo.org/doc/en/ati-faq.xml
Also here is Ubuntu installation guide, Debian is not that different: http://wiki.cchtml.com/index.php/Ubu...allation_Guide

Edit: For Debian: http://wiki.cchtml.com/index.php/Debian

Last edited by Emerson; 06-03-2008 at 09:31 AM.
 
Old 06-03-2008, 01:19 PM   #28
steve5673
LQ Newbie
 
Registered: May 2008
Posts: 20

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by pixellany View Post
You would need to install using the package manager--eg Synaptic, Adept, or whatever is on your system. In a terminal, you can use apt-get if you know the exact name of the package.

How about "radeon"?? Have you tried that?
Yes tried 'radeon' but xserver fails to start, stating that the driver is not present.

Tried also to use apt-get update, then apt-get install fglrx-driver but comes back stating "Couldn't find package fglrx-driver"
 
Old 06-03-2008, 01:22 PM   #29
steve5673
LQ Newbie
 
Registered: May 2008
Posts: 20

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by Emerson View Post
IMO specifying ati or radeon both result in loading the OSS driver. Also, I'm not sure how well OSS driver 2D functions work for your chip, this is why I suggested you try fglrx.
This table may help to understand the current driver situation: http://www.gentoo.org/doc/en/ati-faq.xml
Also here is Ubuntu installation guide, Debian is not that different: http://wiki.cchtml.com/index.php/Ubu...allation_Guide

Edit: For Debian: http://wiki.cchtml.com/index.php/Debian
Tried using the links but always seems to fail to get the fglrx-driver and install.
so at the moment I can't seem to get the fglrx down loaded and installed.
 
Old 06-03-2008, 04:28 PM   #30
pixellany
LQ Veteran
 
Registered: Nov 2005
Location: Annapolis, MD
Distribution: Arch/XFCE
Posts: 17,802

Rep: Reputation: 738Reputation: 738Reputation: 738Reputation: 738Reputation: 738Reputation: 738Reputation: 738
I can't help at the moment with fglrx, but you should be able to get going with radeon. (Since you verified that it is on your system.)

Please post the relevant portion of xorg.conf.

Quote:
Tried using the links but always seems to fail to get the fglrx-driver and install.
You'll need to tell people exactly what you did and exactly what happened.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
1440 x 900 in Framebuffer swampdog2002 Slackware 2 06-07-2007 10:55 AM
Need to get 1440 x 900 dpsource Linux - Hardware 12 11-24-2006 02:43 AM
debian 1440*900 (16:9 screen) elwoodblues Linux - Laptop and Netbook 6 10-11-2005 04:33 PM
brother 1440 geekdug Linux - Hardware 2 03-10-2003 09:51 AM


All times are GMT -5. The time now is 12:17 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration