LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 05-31-2008, 11:27 PM   #1
steve5673
LQ Newbie
 
Registered: May 2008
Posts: 20

Rep: Reputation: 0
1440 x 900 resolution


I have played around with Debian for a short while, but I’m a total newbie ‘under the hood’.
I have just installed Etch, via a live CD and want to change the screen resolution to 1440x900 to fit my wide screen monitor. I have a ATI Radeon HD 2400 Pro video card.
Help from the very beginning to do this would be very much appreciated as I want to learn as much as possible. THX
 
Old 06-01-2008, 09:22 AM   #2
pixellany
LQ Veteran
 
Registered: Nov 2005
Location: Annapolis, MD
Distribution: Arch/XFCE
Posts: 17,802

Rep: Reputation: 738Reputation: 738Reputation: 738Reputation: 738Reputation: 738Reputation: 738Reputation: 738
Welcome to LQ!!

You will need to edit /etc/X11/xorg.conf to include the resolution for your monitor. Since it is an LCD, I would put in only one resolution. Also, set the vertical refresh to something like 50-70 or even 55-65.

Here is a sample of how the key sections might wind up:

Code:
Section "Monitor"

    Identifier "monitor1"
    VendorName "Whatever"  #optional entry
    ModelName "Whatever"   #also optional
    HorizSync 24-92
    VertRefresh 50-70
EndSection
.
.
.
Section "Screen"
    Identifier "screen1"
    Device "device1"
    Monitor "monitor1"
    DefaultColorDepth 24

    Subsection "Display"
        Depth 24
        Modes "1440x900"
    EndSubsection
EndSection
 
Old 06-01-2008, 09:25 AM   #3
pixellany
LQ Veteran
 
Registered: Nov 2005
Location: Annapolis, MD
Distribution: Arch/XFCE
Posts: 17,802

Rep: Reputation: 738Reputation: 738Reputation: 738Reputation: 738Reputation: 738Reputation: 738Reputation: 738
PS...

Check in that same file to see what driver is specified for the video card. The common options are "ati" and "radeon". You'll probably want radeon.
 
Old 06-01-2008, 09:36 AM   #4
steve5673
LQ Newbie
 
Registered: May 2008
Posts: 20

Original Poster
Rep: Reputation: 0
1440 x 900 resolution

I tried running dpkg-reconfigure xserver-xorg leaving everything at default except adding 1440x900 option on the resolution set-up screen then saving. But back on the desk top the 1440x900 is not an option in the pull down menu.
 
Old 06-01-2008, 09:45 AM   #5
pixellany
LQ Veteran
 
Registered: Nov 2005
Location: Annapolis, MD
Distribution: Arch/XFCE
Posts: 17,802

Rep: Reputation: 738Reputation: 738Reputation: 738Reputation: 738Reputation: 738Reputation: 738Reputation: 738
OK--what driver are you using?

The other thing to try is a modeline. Here's what gtf generates for your case (edited per an article I once read):

Code:
[mherring@localhost play]$ gtf 1440 900 60
  
  Modeline "1440x900"  106.47  1440 1520 1672 1904  900 901 904 932  -HSync +Vsync
This goes in the "Monitor" section.
 
Old 06-01-2008, 10:11 AM   #6
steve5673
LQ Newbie
 
Registered: May 2008
Posts: 20

Original Poster
Rep: Reputation: 0
Pixellany - sorry to be a pain but your way too fast for me, I'm still wet behind the ears on this.
How do I get into the areas to mentioned, via the root terminal on the desktop? Take it slow.
I did incidentally try editing the name of the video card to exactly what was on the box, but the screen went strange and it would allow me me to log on, so I had to re-edit xorg.conf via the terminal screen.
 
Old 06-01-2008, 10:19 AM   #7
pixellany
LQ Veteran
 
Registered: Nov 2005
Location: Annapolis, MD
Distribution: Arch/XFCE
Posts: 17,802

Rep: Reputation: 738Reputation: 738Reputation: 738Reputation: 738Reputation: 738Reputation: 738Reputation: 738
Don't bother with the name of the card---what we need is the driver being used. You are looking for something like this:

Code:
Section "Device"
    Identifier "device1"
    VendorName "ATI Technologies Inc."   #optional#
    BoardName "ATI Radeon"               #optional#
    Driver "radeon"
EndSection

To edit that file, you need "root" privileges. The most straightforward method:
open a terminal
enter "su", and then your root password.
enter <editor> /etc/X11/xorg.conf (replace <editor> with your choice--I like nano, but you can also use one of the GUI editors such as gedit, kedit, etc. The purists use VIM or EMACS.)
 
Old 06-01-2008, 10:33 AM   #8
steve5673
LQ Newbie
 
Registered: May 2008
Posts: 20

Original Poster
Rep: Reputation: 0
OK - got to the nano editor, screen is blank, how do I bring up the video information to edit as you mention.
 
Old 06-01-2008, 10:41 AM   #9
pixellany
LQ Veteran
 
Registered: Nov 2005
Location: Annapolis, MD
Distribution: Arch/XFCE
Posts: 17,802

Rep: Reputation: 738Reputation: 738Reputation: 738Reputation: 738Reputation: 738Reputation: 738Reputation: 738
In the terminal window, enter "nano /etc/X11/xorg.conf". You can also use ctrl-R within nano to read the file.

To be on the safe side, first make a copy of the file using:
cp /etc/X11/xorg.conf xorg.bak

Note: I've used absolute paths in all these examples. To save keystrokes, first do "cd /etc/X11". Then---eg---you can do "nano xorg.conf"
 
Old 06-01-2008, 12:46 PM   #10
steve5673
LQ Newbie
 
Registered: May 2008
Posts: 20

Original Poster
Rep: Reputation: 0
OK - I have the terminal window open, with 'GNU nano 2.0.2' 'File: /etc/x11/xorg.conf' 'modified' on the top line. If I ctrl R the cursor moves to the bottom of the window i believe waiting for me to enter a file name. Not sure what to do next.
Apart from the top and bottom lines on the terminal window there is no file contents displayed
 
Old 06-02-2008, 06:47 AM   #11
steve5673
LQ Newbie
 
Registered: May 2008
Posts: 20

Original Poster
Rep: Reputation: 0
Huge difference between "x11" and "X11".
Checked the display section of the file and "1440 x 900" is listed under the
depth 24; and depth 24 is default color. Any other ideas?
 
Old 06-02-2008, 08:08 AM   #12
pixellany
LQ Veteran
 
Registered: Nov 2005
Location: Annapolis, MD
Distribution: Arch/XFCE
Posts: 17,802

Rep: Reputation: 738Reputation: 738Reputation: 738Reputation: 738Reputation: 738Reputation: 738Reputation: 738
Quote:
Originally Posted by steve5673 View Post
Huge difference between "x11" and "X11".
Checked the display section of the file and "1440 x 900" is listed under the
depth 24; and depth 24 is default color. Any other ideas?
Glad to see that you got nano working.....

I have asked you several questions and given suggestions. For example:

What driver is specified for the video card?
Try a modeline

For us to help you with this, you need to respond to everything that is posted.
 
Old 06-02-2008, 05:59 PM   #13
steve5673
LQ Newbie
 
Registered: May 2008
Posts: 20

Original Poster
Rep: Reputation: 0
OK - the driver listed under "Device" is "vesa". I tried changing it to both ati and Radeon and both time xserver cashed on boot up and I could only work in terminal mode. Changed back to "vesa" and OK.
Also added the "modeline" line in the "Monitor" section as you suggested, but seemed to have no affect whatsoever on the display.
Any of the words case sensitive?
 
Old 06-02-2008, 09:37 PM   #14
steve5673
LQ Newbie
 
Registered: May 2008
Posts: 20

Original Poster
Rep: Reputation: 0
additionally, I tried changing the Subsection "Display" to just "1440x900" & Depth 24 as you suggested at the beginning. However this causes the screen to look OK but I can only get to the log in screen, enter username and password, then the screen goes black for a few seconds then the log in screen appears again. So I can't get past the log screen. Changed back to have all resolutions and all ok, except for not being able to get the 1440x900 resolution.
 
Old 06-02-2008, 09:49 PM   #15
Emerson
LQ Guru
 
Registered: Nov 2004
Location: Saint Amant, Acadiana
Distribution: Gentoo ~arch
Posts: 5,872

Rep: Reputation: Disabled
OK, some clarification. Driver "vesa" does not go over 800x600, it is a generic driver. Your ATI card does obviously not work with open-source ATI driver. You need to specify fglrx as video driver, this is closed-source proprietary ATI driver. You probably need to install it first.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
1440 x 900 in Framebuffer swampdog2002 Slackware 2 06-07-2007 10:55 AM
Need to get 1440 x 900 dpsource Linux - Hardware 12 11-24-2006 02:43 AM
debian 1440*900 (16:9 screen) elwoodblues Linux - Laptop and Netbook 6 10-11-2005 04:33 PM
brother 1440 geekdug Linux - Hardware 2 03-10-2003 09:51 AM


All times are GMT -5. The time now is 07:08 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration