LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 05-19-2005, 07:08 PM   #1
Gary13579
LQ Newbie
 
Registered: May 2005
Posts: 8

Rep: Reputation: 0
1024x768 screen res fedora core 3


Okay, before I start, I must say I am a Linux newb. I just barely got the installer working alone, and now I have had a few problems.
I got most of them figured out, except for one. I only see 2 screen resolutions (640x480 and 800x600). I searched around first, and found many fixes. I am not sure how to do what they said, so if you could explain it a bit further, I would really appreciate it

I am really glad to get out of Windows, but I may have to go back if I can't get this worked out (800x600 screen res is un-useable for me).
 
Old 05-19-2005, 08:00 PM   #2
jabfinger
Member
 
Registered: Jan 2004
Location: USA, Pa
Distribution: Gentoo, Fedora Core 3, Mepis, Vector
Posts: 83

Rep: Reputation: 15
If you have not tried already type "system-config-display" in a terminal as root. Here you should be able to set up yuur display.

If you have and it did not work, post your /etc/X11/xorg.conf file and we can try to edit it manualy.
 
Old 05-19-2005, 08:10 PM   #3
Gary13579
LQ Newbie
 
Registered: May 2005
Posts: 8

Original Poster
Rep: Reputation: 0
Alright, I typed that into a terminal.
Quote:
[gary@localhost ~]$ system-config-display
Trying with card: ATI Mach64
I wasn't logged into the root account, but I did have to type in the password.
After that it borught up the Display Settings window, without the option of 1024x768.
The moniter type is Unknown (it is a old Packard Bell moniter ), and the video card is ATI Mach64


Edit: Here is the xorg.conf

Code:
# XFree86 4 configuration created by pyxf86config

Section "ServerLayout"
	Identifier     "Default Layout"
	Screen      0  "Screen0" 0 0
	InputDevice    "Mouse0" "CorePointer"
	InputDevice    "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"

# RgbPath is the location of the RGB database.  Note, this is the name of the 
# file minus the extension (like ".txt" or ".db").  There is normally
# no need to change the default.
# Multiple FontPath entries are allowed (they are concatenated together)
# By default, Red Hat 6.0 and later now use a font server independent of
# the X server to render fonts.
	RgbPath      "/usr/X11R6/lib/X11/rgb"
	FontPath     "unix/:7100"
EndSection

Section "Module"
	Load  "dbe"
	Load  "extmod"
	Load  "fbdevhw"
	Load  "glx"
	Load  "record"
	Load  "freetype"
	Load  "type1"
	Load  "dri"
EndSection

Section "InputDevice"

# Specify which keyboard LEDs can be user-controlled (eg, with xset(1))
#	Option	"Xleds"		"1 2 3"
# To disable the XKEYBOARD extension, uncomment XkbDisable.
#	Option	"XkbDisable"
# To customise the XKB settings to suit your keyboard, modify the
# lines below (which are the defaults).  For example, for a non-U.S.
# keyboard, you will probably want to use:
#	Option	"XkbModel"	"pc102"
# If you have a US Microsoft Natural keyboard, you can use:
#	Option	"XkbModel"	"microsoft"
#
# Then to change the language, change the Layout setting.
# For example, a german layout can be obtained with:
#	Option	"XkbLayout"	"de"
# or:
#	Option	"XkbLayout"	"de"
#	Option	"XkbVariant"	"nodeadkeys"
#
# If you'd like to switch the positions of your capslock and
# control keys, use:
#	Option	"XkbOptions"	"ctrl:swapcaps"
# Or if you just want both to be control, use:
#	Option	"XkbOptions"	"ctrl:nocaps"
#
	Identifier  "Keyboard0"
	Driver      "kbd"
	Option	    "XkbModel" "pc105"
	Option	    "XkbLayout" "us"
EndSection

Section "InputDevice"
	Identifier  "Mouse0"
	Driver      "mouse"
	Option	    "Protocol" "IMPS/2"
	Option	    "Device" "/dev/input/mice"
	Option	    "ZAxisMapping" "4 5"
	Option	    "Emulate3Buttons" "yes"
EndSection

Section "Monitor"
	Identifier   "Monitor0"
	VendorName   "Monitor Vendor"
	ModelName    "Unknown monitor"
	HorizSync    31.5 - 37.9
	VertRefresh  50.0 - 70.0
	Option	    "dpms"
EndSection

Section "Device"
	Identifier  "Videocard0"
	Driver      "ati"
	VendorName  "Videocard vendor"
	BoardName   "ATI Mach64"
EndSection

Section "Screen"
	Identifier "Screen0"
	Device     "Videocard0"
	Monitor    "Monitor0"
	DefaultDepth     24
	SubSection "Display"
		Viewport   0 0
		Depth     16
		Modes    "800x600" "640x480"
	EndSubSection
	SubSection "Display"
		Viewport   0 0
		Depth     24
		Modes    "800x600" "640x480"
	EndSubSection
EndSection

Section "DRI"
	Group        0
	Mode         0666
EndSection

Last edited by Gary13579; 05-19-2005 at 08:12 PM.
 
Old 05-19-2005, 08:29 PM   #4
jabfinger
Member
 
Registered: Jan 2004
Location: USA, Pa
Distribution: Gentoo, Fedora Core 3, Mepis, Vector
Posts: 83

Rep: Reputation: 15
Down at the bottom of your xorg.conf you will see a section called
Section "Screen"

You might try to edit the "Modes" line to include 1024x768 or whatever you need like this.
Log out then back in and you will hopefully see the new resolution modes.



Section "Screen"
Identifier "Screen0"
Device "Videocard0"
Monitor "Monitor0"
DefaultDepth 24
SubSection "Display"
Viewport 0 0
Depth 16
Modes "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Viewport 0 0
Depth 24
Modes "1024x768" "800x600" "640x480"
EndSubSection
 
Old 05-19-2005, 08:50 PM   #5
Gary13579
LQ Newbie
 
Registered: May 2005
Posts: 8

Original Poster
Rep: Reputation: 0
Okay, I logged into the root user and changed the file like you said. Then I logged out and back into my user account, and it still does not have the 1024x768 option ...
 
Old 05-19-2005, 09:37 PM   #6
jabfinger
Member
 
Registered: Jan 2004
Location: USA, Pa
Distribution: Gentoo, Fedora Core 3, Mepis, Vector
Posts: 83

Rep: Reputation: 15
Let me backtrack to the "system-config-display". You say that it is a packard bell. In the hardware section monitor type configuration there is a bunch of Packard Bell types. You have probably checked here to find your monitor. If you cant find it you could try picking from the Generic CRT Display types.

The only other thing that I can see that may or may not be set correctly is your HorizSync and VertRefresh. Are they set according to your monitor. I know that I have a different monitor but Mine are HorizSync 31.0 - 96.0 VertRefresh 55.0 - 160.0.

Code:
Section "Monitor"
	Identifier   "Monitor0"
	VendorName   "Monitor Vendor"
	ModelName    "Unknown monitor"
	HorizSync    31.5 - 37.9
	VertRefresh  50.0 - 70.0
	Option	    "dpms"

I hope this helps.
 
Old 05-20-2005, 12:26 AM   #7
mcgrew
Member
 
Registered: May 2005
Location: West Virginia, US
Distribution: Gentoo
Posts: 56

Rep: Reputation: 21
Next time do a little searching

You'll find the answer in this thread
 
Old 05-20-2005, 05:14 PM   #8
Gary13579
LQ Newbie
 
Registered: May 2005
Posts: 8

Original Poster
Rep: Reputation: 0
I tried a few of them, but I am not sure what my moniter is.
If you want, I can take a picutre of the back, and maybe someone could help me figure out what it is...
 
Old 05-20-2005, 11:00 PM   #9
jabfinger
Member
 
Registered: Jan 2004
Location: USA, Pa
Distribution: Gentoo, Fedora Core 3, Mepis, Vector
Posts: 83

Rep: Reputation: 15
Yes gary13579 post as much info about your monitor as you have.
 
Old 05-21-2005, 01:27 AM   #10
mcgrew
Member
 
Registered: May 2005
Location: West Virginia, US
Distribution: Gentoo
Posts: 56

Rep: Reputation: 21
To be honest it doesn't usually matter what kind of monitor you have. Just choose Generic Monitor for the highest resolution you know it will support. Don't worry if you choose one too low, it won't hurt anything.
 
Old 05-27-2005, 08:51 PM   #11
Gary13579
LQ Newbie
 
Registered: May 2005
Posts: 8

Original Poster
Rep: Reputation: 0
Umm... I screwed up :S
I choose the setting above 1024x768, and now when I start up Fedora I get bars moving accross my screen, at an angle. I can barely make out what it says, but diffenetly not enough to change it back to what it should be.

Is there any way to change this back?
 
Old 05-28-2005, 10:13 AM   #12
jabfinger
Member
 
Registered: Jan 2004
Location: USA, Pa
Distribution: Gentoo, Fedora Core 3, Mepis, Vector
Posts: 83

Rep: Reputation: 15
you could try Ctrl-Alt-F2 to get to a console. then edit /etc/xorg.conf with "vi" or whatever editor you choose then reboot or restart X.
 
Old 05-28-2005, 05:53 PM   #13
Gary13579
LQ Newbie
 
Registered: May 2005
Posts: 8

Original Poster
Rep: Reputation: 0
Can I get what exactly to type into the console?
Just
vi /etc/xorg.conf
?
 
Old 05-28-2005, 10:45 PM   #14
jabfinger
Member
 
Registered: Jan 2004
Location: USA, Pa
Distribution: Gentoo, Fedora Core 3, Mepis, Vector
Posts: 83

Rep: Reputation: 15
You say when you start up fedora you get the bars accross the screen so I assume you can not even read the login screen so do a "Ctrl-Alt-F2" then:

1. "root"
2. "root's password"
3. "vi /etc/X11/xorg.conf" (the xorg.conf file should appear)

4 a) Important. with the xorg.conf file being viewed in vi you
would begin editing it by typing "i" (for insert).
b) You then find the lines in the file that have anything over 1024x768
it looks like your resolutions are in the "Section screens"
c) Delete only the higher resolutions from the file.
d) Press the "Esc" key
e) press "shift" and ":" keys simultaneously
f) type "wq" then "Enter"

5. The new /etc/X11/xorg.conf will be written and you will be back at the prompt.

(note) You can try "Ctrl-Alt-F7" to bring you back to the GUI log in.
or you can reboot.

6. reboot the computer "shutdown -r now"

Hope this helps
 
Old 05-30-2005, 05:04 PM   #15
Gary13579
LQ Newbie
 
Registered: May 2005
Posts: 8

Original Poster
Rep: Reputation: 0
Great, thanks
I had everything working but wasn't sure on how to save it.

1024x768 isn't working, still..
In Windows, this is the exact mode I am using: 1024x768 High Color (16 bit) 43 Hertz

I know that is pretty bad, but that is almost the only 1024x768 that my moniter can support. Is there any way to get this in Fedora?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
So why can't I get Debian (2.6.x kernel) to go any higher than 1024x768 res.? dhatcher Debian 15 07-22-2005 01:27 PM
Fedora Core 3 with ati mobile 9000 only 800x600 res?? adrian16am Linux - Hardware 0 04-15-2005 12:56 AM
changing res in fedora core 3? furtivefelon Linux - Newbie 6 02-26-2005 08:45 AM
Fedora Core 3 login screen! SpiderIRE Linux - Software 1 01-28-2005 06:44 PM
Getting a 1024x768 res?? Clumsy Linux - Newbie 8 03-12-2002 02:30 PM


All times are GMT -5. The time now is 11:39 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration