LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 10-02-2005, 11:11 PM   #16
Volcano
Member
 
Registered: Sep 2005
Posts: 172

Original Poster
Rep: Reputation: 15

>Well I guess you need to go through your scripts and find out what exactly is starting webservd.

i did not make any scripts my-self. it was the webserver doing itself . its starting automatically as soon as system stats up.
 
Old 10-02-2005, 11:13 PM   #17
Volcano
Member
 
Registered: Sep 2005
Posts: 172

Original Poster
Rep: Reputation: 15
hrere is the all files inside /etc/rc.d/init.d folder



anacron firstboot isdn network portmap single winbind
apmd functions kdcrotate nfs random snmpd xfs
atd gpm keytable nfslock rawdevices snmptrapd xinetd
autofs halt killall nscd rhnsd sshd ypbind
crond iptables kudzu ntpd saslauthd syslog
cups irda netfs pcmcia sendmail webserver01

 
Old 10-02-2005, 11:15 PM   #18
Volcano
Member
 
Registered: Sep 2005
Posts: 172

Original Poster
Rep: Reputation: 15
here is the scripts inside webserver01


#!/bin/sh
#------------------------------------------------------------------------------
# Generated for the Sun ONE Web Server 6.1
#
# Author: Sun Microsystems, Inc. (2003)
#------------------------------------------------------------------------------

# Source function library.
. /etc/rc.d/init.d/functions

SCRIPT_NAME=webserver01
S1WS_HOME=/opt/SUNWwbsvr
S1WS_VERSION="6.1"

# See how we were called.
case "$1" in
start)
echo "Sun ONE Web Server $S1WS_VERSION starting ($S1WS_HOME)"
for each_server in $S1WS_HOME/https-*
do
if [ -d $each_server ]; then
echo -n " `basename $each_server`: "
$each_server/start && success || failure $1
echo
fi
done
touch /var/lock/subsys/$SCRIPT_NAME > /dev/null 2>&1
;;
stop)
echo "Sun ONE Web Server $S1WS_VERSION stopping ($S1WS_HOME)"
for each_server in $S1WS_HOME/https-*
do
reversed_list="$each_server $reversed_list"
done
for each_server in $reversed_list
do
if [ -d $each_server ]; then
echo -n " `basename $each_server`: "
$each_server/stop 2>&1 && success || failure $1
echo
fi
done
rm -f /var/lock/subsys/$SCRIPT_NAME > /dev/null 2>&1
;;
restart)
$0 stop || return=$rc_failed
$0 start || return=$rc_failed
;;
*)
echo "Usage: $0 {start|stop|restart}"
exit 1
esac

exit 0
 
Old 10-02-2005, 11:16 PM   #19
Volcano
Member
 
Registered: Sep 2005
Posts: 172

Original Poster
Rep: Reputation: 15
SHOULD I DELETE THIS SCRIPT FROM THE SYSTEM ? will it be harmful ?
 
Old 10-02-2005, 11:22 PM   #20
Volcano
Member
 
Registered: Sep 2005
Posts: 172

Original Poster
Rep: Reputation: 15
any response please.
 
Old 10-02-2005, 11:28 PM   #21
btmiller
Senior Member
 
Registered: May 2004
Location: In the DC 'burbs
Distribution: Arch, Scientific Linux, Debian, Ubuntu
Posts: 4,284

Rep: Reputation: 371Reputation: 371Reputation: 371Reputation: 371
How about "/etc/rc.d/init.d/webserver01 stop" (no quotes) followed by "chkconfig webserver01 off".

Oh, and constantly bumping your own post is annoying and makes people less likely to want to help you. Posters here tend to be busy folks who can't necessarily help you immediately.
 
Old 10-02-2005, 11:56 PM   #22
Volcano
Member
 
Registered: Sep 2005
Posts: 172

Original Poster
Rep: Reputation: 15
Quote:
How about "/etc/rc.d/init.d/webserver01 stop" (no quotes) followed by "chkconfig webserver01 off".
many , you are a e geneious . this works immediately. this command has worked.

here is the output from the shell


# /etc/rc.d/init.d/webserver01 stop
Sun ONE Web Server 6.1 stopping (/opt/SUNWwbsvr)
https-mach104: server has been shutdown
[ OK ]
https-admserv: server has been shutdown
[ OK ]


yahooooooooo......its done.



BTW, is this permanently stopped ?? or again it will start automaticall as soon as i start my system again ? what do you think ?....i am not shutting down system right now though.
 
Old 10-03-2005, 12:35 AM   #23
JimBass
Senior Member
 
Registered: Oct 2003
Location: New York City
Distribution: Debian Sid 2.6.32
Posts: 2,100

Rep: Reputation: 49
It is not permanently stopped, you just shut it off for your current session. You should try the second part of the suggested command, where you were wisely told to try
Quote:
followed by "chkconfig webserver01 off".
by btmiller. Try that, and see what it does. Also, if you are actually using this machine, please upgrade to a distro from the 21st century. RedHat 9 is ancient, unsupported junk. It is like finding a newspaper from 6 years ago. Kind of interesting to look at, but of no practical use at all. How everyone and their grandmother installed (and continues to install) that distro is beyond me. I did it at one point as well, it was my first linux. If you like redhat, try fedora core 4. If you don't like it, there are hundreds of other choices, all of them current releases.

Peace,
JimBass
 
Old 10-03-2005, 12:57 AM   #24
Volcano
Member
 
Registered: Sep 2005
Posts: 172

Original Poster
Rep: Reputation: 15
followed by "chkconfig webserver01 off".

i did this sir...but NO success.

here is the output from the shell
# chkconfig webserver01 off
service webserver01 does not support chkconfig

that means it has not been disabled yet ?
 
Old 10-04-2005, 03:27 AM   #25
Volcano
Member
 
Registered: Sep 2005
Posts: 172

Original Poster
Rep: Reputation: 15
anybody please suggest something .

any linux guru ?
 
Old 10-04-2005, 04:06 AM   #26
Volcano
Member
 
Registered: Sep 2005
Posts: 172

Original Poster
Rep: Reputation: 15
Angry

nobody knows .

plese tell me if you want some more information
 
Old 10-05-2005, 02:56 PM   #27
sundialsvcs
LQ Guru
 
Registered: Feb 2004
Location: SE Tennessee, USA
Distribution: Gentoo, LFS
Posts: 8,148
Blog Entries: 4

Rep: Reputation: 2716Reputation: 2716Reputation: 2716Reputation: 2716Reputation: 2716Reputation: 2716Reputation: 2716Reputation: 2716Reputation: 2716Reputation: 2716Reputation: 2716
There are three places where a daemon like this might be started:
  1. Directly in /etc/inittab.
  2. Via a symbolic-link starting with the letter "S" somewhere in, say, /etc/rc.d/rc5.d.
  3. By means of the xinetd daemon, say with a file in /etc/xinetd.d.
If a process is continuously pegging the system at 100% busy, then that program is probably looping (malfunctioning). It usually puts some kind of message in a file in the /var/log directory when it does so.
 
Old 10-05-2005, 10:58 PM   #28
Volcano
Member
 
Registered: Sep 2005
Posts: 172

Original Poster
Rep: Reputation: 15
ok, but how do i fix it ? webserver is starting as soon as system starts up. the webserver is perfectly alright and it is functioning well.

ALL I need is to stop it running from the system start up.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
X Using 100% CPU windisch Linux - Software 2 09-29-2005 11:35 AM
cpu nearly always at 100% xround Linux - Hardware 6 09-17-2004 05:51 AM
CPU on 100% very often Satriani Linux - General 25 12-23-2003 03:41 PM
100 % CPU usage ???? rolandi Linux - Newbie 1 10-07-2003 11:52 PM
Cpu @ 100% kpzani Linux - General 4 03-20-2003 12:46 PM


All times are GMT -5. The time now is 07:48 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration