LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 10-01-2005, 05:03 AM   #1
Volcano
Member
 
Registered: Sep 2005
Posts: 172

Rep: Reputation: 15
100 % Cpu


when i open my System Monitor GUI , i see

CPU used 100 % in the System monitor tab.

in the process monitor tab , i find no process to consume more CPU. why this happens ?

How can i recover from this ?
here is a result what i found when i run the top command in the shell.

Code:
15:28:54  up  5:22,  2 users,  load average: 1.03, 1.06, 1.01
63 processes: 61 sleeping, 2 running, 0 zombie, 0 stopped
CPU states:  43.8% user  56.1% system   0.0% nice   0.0% iowait   0.0% idle
Mem:   253560k av,  249184k used,    4376k free,       0k shrd,   31752k buff
                    177452k actv,   11448k in_d,    3944k in_c
Swap:  522072k av,    5908k used,  516164k free                   84748k cached
                                                                                
  PID USER     PRI  NI  SIZE  RSS SHARE STAT %CPU %MEM   TIME CPU COMMAND
 3280 root      24   0 14812  12M   264 S    91.6  5.0 321:00   0 webservd
 4037 root      14  -1  142M  13M  1832 S <   4.1  5.4   0:11   0 X
 4113 root      15   0  7784 7780  5304 R     4.1  3.0   0:00   0 gnome-termina
    1 root      15   0    92   72    40 S     0.0  0.0   0:03   0 init
    2 root      15   0     0    0     0 SW    0.0  0.0   0:00   0 keventd
    3 root      15   0     0    0     0 SW    0.0  0.0   0:00   0 kapmd
    4 root      34  19     0    0     0 SWN   0.0  0.0   0:00   0 ksoftirqd_CPU
    9 root      25   0     0    0     0 SW    0.0  0.0   0:00   0 bdflush
    5 root      15   0     0    0     0 SW    0.0  0.0   0:00   0 kswapd
    6 root      15   0     0    0     0 SW    0.0  0.0   0:00   0 kscand/DMA
    7 root      15   0     0    0     0 SW    0.0  0.0   0:00   0 kscand/Normal
    8 root      15   0     0    0     0 SW    0.0  0.0   0:00   0 kscand/HighMe
   10 root      15   0     0    0     0 SW    0.0  0.0   0:00   0 kupdated
   11 root      23   0     0    0     0 SW    0.0  0.0   0:00   0 mdrecoveryd
   15 root      15   0     0    0     0 SW    0.0  0.0   0:00   0 kjournald
   73 root      25   0     0    0     0 SW    0.0  0.0   0:00   0 khubd

why CPU used is shown to be 100% in the System Monitor GUI ?

i also in the process listing tab of the System Monitor no process is consuming much cpu except the gnome sustem monitor . it takes 6% only. then how top command is giving me such a big CPU usage statistics ? and how the System monitor GUI also shows CPU usage is 100 %.


everything here is a mistery .


Does all linux system consumes 100 % CPU usage . it is almost constant !!
 
Old 10-01-2005, 05:04 AM   #2
Volcano
Member
 
Registered: Sep 2005
Posts: 172

Original Poster
Rep: Reputation: 15
i am on RED HAT 9
 
Old 10-01-2005, 05:06 AM   #3
Volcano
Member
 
Registered: Sep 2005
Posts: 172

Original Poster
Rep: Reputation: 15
do all of you get 100 % CPU in your System ? does it stay to be 100 % all he time. but ine is like this.

how dio i recover from this problem ?
 
Old 10-01-2005, 05:25 AM   #4
Haiyadragon
Member
 
Registered: Sep 2003
Location: Gorredijk, Netherlands
Distribution: Arch Linux
Posts: 400

Rep: Reputation: 30
Well, as you can see, webservd seems to be the bad guy. I don't know what it's for but killing it will fix the problem. Try "killall webservd", or if that doesn't work "killall -KILL webservd".

Linux systems most certainly don't use 100% cpu. Mine's at 10% average. X is using most of it.
 
Old 10-01-2005, 06:12 AM   #5
syg00
LQ Veteran
 
Registered: Aug 2003
Location: Australia
Distribution: Lots ...
Posts: 15,641

Rep: Reputation: 2091Reputation: 2091Reputation: 2091Reputation: 2091Reputation: 2091Reputation: 2091Reputation: 2091Reputation: 2091Reputation: 2091Reputation: 2091Reputation: 2091
Re: 100 % Cpu

Quote:
Originally posted by Volcano
why CPU used is shown to be 100% in the System Monitor GUI ?
Well the first 3 lines give 91.6+4.1+4.1 => 99.8 CPU%
Bit of rounding error, plus your session would make it mighty close to 100%. Gotta agree, webservd (presumably a webserver daemon) looks like the culprit.
 
Old 10-02-2005, 06:28 AM   #6
Volcano
Member
 
Registered: Sep 2005
Posts: 172

Original Poster
Rep: Reputation: 15
Quote:
Well, as you can see, webservd seems to be the bad guy. I don't know what it's for but killing it will fix the problem.
Hi, ohh..yes, i remember the webservd NOW. its webserver Sun One i installed . You know, at the installation time, the webserver asked like this.....

Do you want the webserver to start when System Starts up ? Y/N

i blindly typed " Y".

Now, now as soon as i log on everytime the webserver gets started automatically !! ...i do not have to run the startup.bat file (of webserver ) even. i see, so, the webserver is taking a lot of CPU . right ?

will you please tell me how can i disable starting of webserver as soon as system starts up ? i want to start the webserver manually using startup.bat . i do the starting up of webserver manually ...do you think , it might take less CPU ? i dont know, but may be i could go for a try.

so question to you is :

How do i disable the auto-start of the webserver i installed ?

the name of the webserver is Sun One 6.1
 
Old 10-02-2005, 07:13 AM   #7
Volcano
Member
 
Registered: Sep 2005
Posts: 172

Original Poster
Rep: Reputation: 15
Quote:
Well, as you can see, webservd seems to be the bad guy. I don't know what it's for but killing it will fix the problem.
Hi, ohh..yes, i remember the webservd NOW. its webserver Sun One i installed . You know, at the installation time, the webserver asked like this.....

Do you want the webserver to start when System Starts up ? Y/N

i blindly typed " Y".

Now, now as soon as i log on everytime the webserver gets started automatically !! ...i do not have to run the startup.bat file (of webserver ) even. i see, so, the webserver is taking a lot of CPU . right ?

will you please tell me how can i disable starting of webserver as soon as system starts up ? i want to start the webserver manually using startup.bat . i do the starting up of webserver manually ...do you think , it might take less CPU ? i dont know, but may be i could go for a try.

so question to you is :

How do i disable the auto-start of the webserver i installed ?

the name of the webserver is Sun One 6.1
 
Old 10-02-2005, 08:38 PM   #8
Volcano
Member
 
Registered: Sep 2005
Posts: 172

Original Poster
Rep: Reputation: 15
deep silence..
 
Old 10-02-2005, 08:44 PM   #9
bulliver
Senior Member
 
Registered: Nov 2002
Location: Edmonton AB, Canada
Distribution: Gentoo x86_64; Gentoo PPC; FreeBSD; OS X 10.9.4
Posts: 3,760
Blog Entries: 4

Rep: Reputation: 78
# chkconfig --level 345 webservd off

See:
http://www.redhat.com/docs/manuals/l...chkconfig.html
 
Old 10-02-2005, 10:58 PM   #10
Volcano
Member
 
Registered: Sep 2005
Posts: 172

Original Poster
Rep: Reputation: 15

# chkconfig --list
kudzu 0:off 1:off 2:off 3:on 4:on 5:on 6:off
syslog 0:off 1:off 2:on 3:on 4:on 5:on 6:off
netfs 0:off 1:off 2:off 3:on 4:on 5:on 6:off
network 0:off 1:off 2:on 3:on 4:on 5:on 6:off
random 0:off 1:off 2:on 3:on 4:on 5:on 6:off
rawdevices 0:off 1:off 2:off 3:on 4:on 5:on 6:off
pcmcia 0:off 1:off 2:on 3:on 4:on 5:on 6:off
saslauthd 0:off 1:off 2:off 3:off 4:off 5:off 6:off
keytable 0:off 1:on 2:on 3:on 4:on 5:on 6:off
apmd 0:off 1:off 2:on 3:on 4:on 5:on 6:off
atd 0:off 1:off 2:off 3:on 4:on 5:on 6:off
gpm 0:off 1:off 2:on 3:on 4:on 5:on 6:off
autofs 0:off 1:off 2:off 3:on 4:on 5:on 6:off
iptables 0:off 1:off 2:on 3:on 4:on 5:on 6:off
irda 0:off 1:off 2:off 3:off 4:off 5:off 6:off
isdn 0:off 1:off 2:on 3:on 4:on 5:on 6:off
sshd 0:off 1:off 2:on 3:on 4:on 5:on 6:off
portmap 0:off 1:off 2:off 3:on 4:on 5:on 6:off
nfs 0:off 1:off 2:off 3:off 4:off 5:off 6:off
nfslock 0:off 1:off 2:off 3:on 4:on 5:on 6:off
sendmail 0:off 1:off 2:on 3:on 4:on 5:on 6:off
rhnsd 0:off 1:off 2:off 3:on 4:on 5:on 6:off
crond 0:off 1:off 2:on 3:on 4:on 5:on 6:off
anacron 0:off 1:off 2:on 3:on 4:on 5:on 6:off
winbind 0:off 1:off 2:off 3:off 4:off 5:off 6:off
xfs 0:off 1:off 2:on 3:on 4:on 5:on 6:off
xinetd 0:off 1:off 2:off 3:on 4:on 5:on 6:off
cups 0:off 1:off 2:on 3:on 4:on 5:on 6:off
ntpd 0:off 1:off 2:off 3:off 4:off 5:off 6:off
firstboot 0:off 1:off 2:off 3:off 4:off 5:off 6:off
snmpd 0:off 1:off 2:off 3:off 4:off 5:off 6:off
snmptrapd 0:off 1:off 2:off 3:off 4:off 5:off 6:off
xinetd based services:
chargen-udp: off
rsync: off
chargen: off
daytime-udp: off
daytime: off
echo-udp: off
echo: off
services: off
servers: off
time-udp: off
time: off
cups-lpd: off
sgi_fam: on




and also

when i run your command

# chkconfig --level 345 webservd off
error reading information on service webservd: No such file or directory

what do i do now ?
 
Old 10-02-2005, 10:59 PM   #11
Volcano
Member
 
Registered: Sep 2005
Posts: 172

Original Poster
Rep: Reputation: 15
Unhappy

its NOT disabling
 
Old 10-02-2005, 11:05 PM   #12
syg00
LQ Veteran
 
Registered: Aug 2003
Location: Australia
Distribution: Lots ...
Posts: 15,641

Rep: Reputation: 2091Reputation: 2091Reputation: 2091Reputation: 2091Reputation: 2091Reputation: 2091Reputation: 2091Reputation: 2091Reputation: 2091Reputation: 2091Reputation: 2091
Try (I'm guessing here);
Code:
/etc/rc.d/init.d/webservd stop
maybe try webserv as well if that doesn't do it.
 
Old 10-02-2005, 11:06 PM   #13
bulliver
Senior Member
 
Registered: Nov 2002
Location: Edmonton AB, Canada
Distribution: Gentoo x86_64; Gentoo PPC; FreeBSD; OS X 10.9.4
Posts: 3,760
Blog Entries: 4

Rep: Reputation: 78
Well I guess you need to go through your scripts and find out what exactly is starting webservd.
 
Old 10-02-2005, 11:06 PM   #14
Volcano
Member
 
Registered: Sep 2005
Posts: 172

Original Poster
Rep: Reputation: 15
here is one more information i am sharing .
you know when i started my System , i got the mesages lots of "OK" and after some time xinetd started
and then i got a message my webserver ready to accept the request on port 80.

By the way,i want to disable it. the above command you provided did not work. please suggest me what should i do now ?
 
Old 10-02-2005, 11:09 PM   #15
Volcano
Member
 
Registered: Sep 2005
Posts: 172

Original Poster
Rep: Reputation: 15
/etc/rc.d/init.d/webservd stop

here is the result

# /etc/rc.d/init.d/webservd stop
bash: /etc/rc.d/init.d/webservd: No such file or directory
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
X Using 100% CPU windisch Linux - Software 2 09-29-2005 11:35 AM
cpu nearly always at 100% xround Linux - Hardware 6 09-17-2004 05:51 AM
CPU on 100% very often Satriani Linux - General 25 12-23-2003 03:41 PM
100 % CPU usage ???? rolandi Linux - Newbie 1 10-07-2003 11:52 PM
Cpu @ 100% kpzani Linux - General 4 03-20-2003 12:46 PM


All times are GMT -5. The time now is 04:25 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration