LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 01-21-2010, 10:29 PM   #1
acharyaa
LQ Newbie
 
Registered: Jan 2010
Posts: 5

Rep: Reputation: 0
'make' command still not working on cygwin


Based on previous forum discussions, I tried to install cygwin with 'make' installed from develop during installation. I can even see 'make.exe' in bin folder, but still while running the make command, it still shows error.

$make
make depend
make: /bin/csh: Command not found.
make: *** [all] Error 127

I was confused in one other part. Should I put the bin folder in some specific location or just wherever it is placed during cygwin installation? I was running VIC model, do I need to place the bin folder inside VIC source code folder.

Thanks
Sham
 
Old 01-22-2010, 01:02 AM   #2
Elemecca
Member
 
Registered: Nov 2008
Location: San Francisco, CA
Distribution: Gentoo, CentOS
Posts: 71

Rep: Reputation: 22
Your make installation is just fine. The particular make file you're building requires csh (the C shell). It should be in the installer under Shells.
 
1 members found this post helpful.
Old 01-22-2010, 01:42 PM   #3
acharyaa
LQ Newbie
 
Registered: Jan 2010
Posts: 5

Original Poster
Rep: Reputation: 0
Thanks Elemecca. Initially I just tried to install csh from Shell, it didn't work again with the same errors..however, I tried to install all components for that Shell, and I am able to run the model with make command. At least I passed this step..Thanks a lot. I appreciate it.

Sham
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
make command is not found in cygwin udayakumarsv General 3 07-16-2012 07:00 AM
Have you ever used cygwin, i've met a problem with the command stat from cygwin andy820303 Linux - Newbie 0 03-11-2009 03:37 AM
'make' command not working in redhat 9 sparrott Linux - Newbie 1 03-30-2006 02:49 PM
New Kernel-make command not working ashley67 Linux - Newbie 6 11-30-2004 11:15 PM
Make command not working? (NEWBIE) Willew Linux - Software 2 10-29-2003 09:29 PM


All times are GMT -5. The time now is 12:13 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration