LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 08-13-2014, 06:04 AM   #1
jojanmpaul
Member
 
Registered: Sep 2012
Location: Bangalore
Posts: 80

Rep: Reputation: Disabled
`OPENSSL_1.0.1_EC' not found (required by php)


Hello,

I am getting the following error,

php -v
php: /usr/lib64/libcrypto.so.10: version `OPENSSL_1.0.1_EC' not found (required by php)

openssl version -a
OpenSSL 1.0.1e-fips 11 Feb 2013
built on: Mon Jun 2 14:51:28 EDT 2014

rpm -qa | grep php
php55w-5.5.14-1.w6.x86_64
php55w-gd-5.5.14-1.w6.x86_64
php55w-pdo-5.5.14-1.w6.x86_64
php55w-odbc-5.5.14-1.w6.x86_64
php55w-soap-5.5.14-1.w6.x86_64
php55w-opcache-5.5.14-1.w6.x86_64
php55w-cli-5.5.14-1.w6.x86_64
php55w-bcmath-5.5.14-1.w6.x86_64
php55w-mbstring-5.5.14-1.w6.x86_64
php55w-mysql-5.5.14-1.w6.x86_64
php55w-pear-1.9.4-7.w6.noarch
php55w-pecl-xdebug-2.2.5-1.w6.x86_64
php55w-xmlrpc-5.5.14-1.w6.x86_64
php55w-mcrypt-5.5.14-1.w6.x86_64
php55w-pecl-apcu-devel-4.0.6-1.w6.x86_64
php55w-common-5.5.14-1.w6.x86_64
php55w-dba-5.5.14-1.w6.x86_64
php55w-devel-5.5.14-1.w6.x86_64
php55w-imap-5.5.14-1.w6.x86_64
php55w-pecl-memcache-3.0.8-2.w6.x86_64
php55w-xml-5.5.14-1.w6.x86_64
php55w-pecl-apcu-4.0.6-1.w6.x86_64

Please let me know how to fix the above issue.
 
Old 08-13-2014, 06:22 AM   #2
jojanmpaul
Member
 
Registered: Sep 2012
Location: Bangalore
Posts: 80

Original Poster
Rep: Reputation: Disabled
rpm -qa | grep openssl
openssl10-libs-1.0.1c-10.ius.el6.x86_64
openssl-1.0.1e-16.el6_5.14.i686

After removing all php packages am getting,

/usr/bin/php: /usr/lib64/libcrypto.so.10: version `OPENSSL_1.0.1_EC' not found (required by /usr/bin/php)

Last edited by jojanmpaul; 08-27-2014 at 01:36 AM.
 
Old 09-02-2014, 12:39 AM   #3
jojanmpaul
Member
 
Registered: Sep 2012
Location: Bangalore
Posts: 80

Original Poster
Rep: Reputation: Disabled
Solved by re installing the php modules and ssl
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
'GCC_4.2.0' not found; which is required by an .so file. jtAQI Linux - Newbie 2 01-21-2009 10:02 AM
glib 2.4.3 not found, required for -bash MmmGuinness Slackware 3 08-30-2006 06:05 PM
Slackware Can't login GLIBC_2.3.4 not found (required by,,,,,) youngie Linux - Newbie 3 12-19-2005 04:23 AM
** ERROR **: PyGTK (2, 6, 0) required, but (2, 4, 1) found alfNtexas Linux - Software 2 09-14-2005 03:24 PM
powernowd: required sysfs objects not found TLV Debian 0 08-21-2004 09:15 AM


All times are GMT -5. The time now is 02:25 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration