LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 11-08-2004, 07:02 AM   #1
Khazar
LQ Newbie
 
Registered: Nov 2004
Location: Netherlands
Distribution: SuSe 9.0
Posts: 10

Rep: Reputation: 0
[SuSe 9.0] Can't connect to the internet


Lo, im new here and at linux too.

The prob is: I don't know how to config my internet connecting.

I have a dual boot machine with XP and Suse 9.0.. I can see my network, for example i can browse on my other pc in it's shared docs, but i cant use the internet, while i can when i load XP. Also, from linux i can see my router @ 192.1268.1.1. It's just.. can't even visit google lol

At the hardware / network card settings, ive set it up with int. IP as 192.168.1.9 as i also did in XP.

But.. I dont know what to do with this information.

Do you guys know what i should do to get online?

Thx in advance, Khazar
 
Old 11-08-2004, 07:11 AM   #2
scuzzman
Senior Member
 
Registered: May 2004
Location: Hilliard, Ohio, USA
Distribution: Slackware, Kubuntu
Posts: 1,851

Rep: Reputation: 47
First off: can you ping?
If not, try it by both ip address and hostname
Try these and tell us if either of them gets 4 "Reply"'s
Code:
ping -c 4 linuxquestions.org
ping -c 4 64.179.4.149
<EDIT>
If the IP works, but not the host, there's a good chance your ISP's DNS addresses need to be put in /etc/resolv.conf
</EDIT>

Last edited by scuzzman; 11-08-2004 at 07:36 AM.
 
Old 11-08-2004, 07:11 AM   #3
Hiper
Member
 
Registered: Aug 2003
Location: Portugal
Distribution: Slackware 10.0
Posts: 100

Rep: Reputation: 15
If it's a manually configured IP, i think you just need to say somewhere that 192.1268.1.1 is also your gateway and nameserver
I'm not sure how you do this in suse, but it should be easy

Last edited by Hiper; 11-08-2004 at 07:15 AM.
 
Old 11-08-2004, 07:16 AM   #4
Khazar
LQ Newbie
 
Registered: Nov 2004
Location: Netherlands
Distribution: SuSe 9.0
Posts: 10

Original Poster
Rep: Reputation: 0
Quote:
Originally posted by scuzzman
First off: can you ping?
If not, try it by both ip address and hostname
Try these and tell us if either of them gets 4 "Reply"'s
Code:
ping -c 4 linuxquestions.org
ping -c 4 64.179.4.149
I did the command and i got 4 replies indeed.. all in 140-150 ms.. 0%packet loss
 
Old 11-08-2004, 07:37 AM   #5
scuzzman
Senior Member
 
Registered: May 2004
Location: Hilliard, Ohio, USA
Distribution: Slackware, Kubuntu
Posts: 1,851

Rep: Reputation: 47
From which? The hostname or the IP or both?
 
Old 11-08-2004, 07:39 AM   #6
Khazar
LQ Newbie
 
Registered: Nov 2004
Location: Netherlands
Distribution: SuSe 9.0
Posts: 10

Original Poster
Rep: Reputation: 0
The IP, the hostname didnt work, it said unknown host name or smthin..

I can ping sites, and i can also approch other pc's in my network, its just the internet that isnt working (obviously the settings are wrong somewhere, but i dont know where i can set it up properly.
 
Old 11-08-2004, 07:40 AM   #7
scuzzman
Senior Member
 
Registered: May 2004
Location: Hilliard, Ohio, USA
Distribution: Slackware, Kubuntu
Posts: 1,851

Rep: Reputation: 47
Quote:
Originally posted by scuzzman

<EDIT>
If the IP works, but not the host, there's a good chance your ISP's DNS addresses need to be put in /etc/resolv.conf
</EDIT>
 
Old 11-08-2004, 07:48 AM   #8
Khazar
LQ Newbie
 
Registered: Nov 2004
Location: Netherlands
Distribution: SuSe 9.0
Posts: 10

Original Poster
Rep: Reputation: 0
When i go in konqueror to that folder etc.. ic the file resolv.conf.. when i click it i get to see this:

Code:
nameserver 192.168.1.1
search local
Nothing else.

I know the DNS codes, but how do i put them in this file?
 
Old 11-08-2004, 07:50 AM   #9
scuzzman
Senior Member
 
Registered: May 2004
Location: Hilliard, Ohio, USA
Distribution: Slackware, Kubuntu
Posts: 1,851

Rep: Reputation: 47
Code:
nameserver x.x.x.x
nameserver x.x.x.x
Replace x.x.x.x with your ISP's DNS server's IP Addresses and remove the last line.
 
Old 11-08-2004, 07:55 AM   #10
Khazar
LQ Newbie
 
Registered: Nov 2004
Location: Netherlands
Distribution: SuSe 9.0
Posts: 10

Original Poster
Rep: Reputation: 0
Ok that's np, it just says i dont have permission to overwrite/save to that file.. so i gotta login as root, but how?
 
Old 11-08-2004, 08:25 AM   #11
scuzzman
Senior Member
 
Registered: May 2004
Location: Hilliard, Ohio, USA
Distribution: Slackware, Kubuntu
Posts: 1,851

Rep: Reputation: 47
got to a terminal
type this:
Code:
su -c "gedit /etc/resolv.conf"
That will launch GEdit in root mode so you can edit it
 
Old 11-08-2004, 08:33 AM   #12
Khazar
LQ Newbie
 
Registered: Nov 2004
Location: Netherlands
Distribution: SuSe 9.0
Posts: 10

Original Poster
Rep: Reputation: 0
What is a terminal and where can i find it?

I think u mean the konsole, so i typed it in the konsole, it said (after filling in passw.):

Code:
bash: line 1: gedit: command not found
 
Old 11-08-2004, 08:35 AM   #13
scuzzman
Senior Member
 
Registered: May 2004
Location: Hilliard, Ohio, USA
Distribution: Slackware, Kubuntu
Posts: 1,851

Rep: Reputation: 47
Where it asks for "Password:" type your root password
try replacing "gedit" with "pico" or "kwrite", or other text editors
 
Old 11-08-2004, 08:37 AM   #14
scuzzman
Senior Member
 
Registered: May 2004
Location: Hilliard, Ohio, USA
Distribution: Slackware, Kubuntu
Posts: 1,851

Rep: Reputation: 47
su = Switch User
It's what you use to invoke root
su -c = run a command as root
the command is contained within the " and "
so:
su -c "kwrite /etc/resolv.conf"
means run "kwrite /etc/resolv.conf" as root
 
Old 11-08-2004, 08:53 AM   #15
jschiwal
LQ Guru
 
Registered: Aug 2001
Location: Fargo, ND
Distribution: SuSE AMD64
Posts: 15,733

Rep: Reputation: 671Reputation: 671Reputation: 671Reputation: 671Reputation: 671Reputation: 671
You can use the 'su' command to change to the root user when in the shell.

If the router is a cable/dsl router, it may have a web setup interface that you can use to get the ISP's DNS numbers. Point the brower to 192.168.1.1 . For linksys, leave the username blank the first time. I think the initial password it 'admin'

Or you could set up the computer to use DHCP, temporarily, restart the network (rcnetwork restart), and use the ifconfig command to display the DNS numbers.
And yes, the gateway IP should be 192.168.1.1
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Cannot connect to internet with suse 9.2 randon SUSE / openSUSE 2 08-08-2005 12:10 PM
Cannot connect to internet with Suse 9.2 HULLU Linux - Networking 5 11-19-2004 11:26 AM
Can't connect to the Internet thru SuSE neelank Linux - Newbie 7 10-24-2004 08:37 AM
why can't suse 9.1 connect to the internet jcluney Linux - Networking 10 08-16-2004 09:56 AM
Can't connect to internet with SUSE 9.1 Yumemiru Linux - Networking 3 07-24-2004 03:48 PM


All times are GMT -5. The time now is 12:40 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration