LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 02-09-2010, 01:42 PM   #1
glenn69
Member
 
Registered: Jul 2003
Location: Chicagoland
Distribution: ArchLinux
Posts: 261

Rep: Reputation: 32
[SOLVED] Two NIC, only one shows up??


I have a new Debian system installed in a machine. The computer contains 2 NICs. Both were recognized during installation, however eth0 was designated as the primary card.

After installation, however, only eth0 shows up when I type ifconfig. ifup eth1 results in "ignoring unknown interface eth1=eth1"

How do I use the second NIC?

Thanks

Last edited by glenn69; 02-09-2010 at 02:32 PM.
 
Old 02-09-2010, 02:02 PM   #2
nicedream
Member
 
Registered: Feb 2010
Distribution: Arch Linux
Posts: 68

Rep: Reputation: 19
Does the second interface show up when you run 'ifconfig -a'?
 
Old 02-09-2010, 02:05 PM   #3
glenn69
Member
 
Registered: Jul 2003
Location: Chicagoland
Distribution: ArchLinux
Posts: 261

Original Poster
Rep: Reputation: 32
Quote:
Does the second interface show up when you run 'ifconfig -a'?
Yes it does show up

Last edited by glenn69; 02-09-2010 at 02:13 PM.
 
Old 02-09-2010, 02:16 PM   #4
nicedream
Member
 
Registered: Feb 2010
Distribution: Arch Linux
Posts: 68

Rep: Reputation: 19
What does your /etc/network/interfaces file look like?
 
Old 02-09-2010, 02:27 PM   #5
glenn69
Member
 
Registered: Jul 2003
Location: Chicagoland
Distribution: ArchLinux
Posts: 261

Original Poster
Rep: Reputation: 32
/etc/network/interfaces

auto lo
iface lo inet loopback

allow-hotplug eth0
iface eth0 inet dhcp

iface eth1 inet dhcp
 
Old 02-09-2010, 02:31 PM   #6
glenn69
Member
 
Registered: Jul 2003
Location: Chicagoland
Distribution: ArchLinux
Posts: 261

Original Poster
Rep: Reputation: 32
Fixed :

I added

auto eth1 and restarted networking

Thanks
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
prtconf -pv shows nic as a Bridge device ? Fredsnet Solaris / OpenSolaris 6 12-24-2010 03:39 PM
WEBCAM: Stickam shows black screen when Cheese shows cam 449 Linux - Software 16 08-04-2009 04:23 AM
free -m shows 2GB used but gnome-system-monitor shows 1GB anjanesh Linux - General 1 03-04-2009 05:49 AM
Eth0 shows up as nic port 2 - network schnanigans Thaidog Linux - Networking 5 02-29-2008 01:01 PM
iptables - I added a second nic and cannot ssh to it. Log shows a potential problem. ForumKid Linux - Security 12 01-18-2002 10:13 AM


All times are GMT -5. The time now is 06:13 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration