LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (http://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   [Slackware 10.2] "Upgrading" packages gtk+, glib, atk, pango (http://www.linuxquestions.org/questions/linux-newbie-8/%5Bslackware-10-2%5D-upgrading-packages-gtk-glib-atk-pango-457899/)

stevesk 06-24-2006 01:11 PM

[Slackware 10.2] "Upgrading" packages gtk+, glib, atk, pango
 
Hey people! I have a Slackware 10.2 and I thought about "upgrading" GTK+ and all its reqs. packages: atk, pango, glib. The reason is because I've heard that there will be a new release (11.0) soon, but I don't want to change for these one yet. So, why not making the main packages updated? Well, I did the following things:

1. Downloaded the packages.
2. Got out of X.
3. Logged as root.
4. Used "pkgtool" to uninstall Gtk+, pango, glib, and atk.
5. bunzip2ed/untared the packages.
6. Installed glib:

./configure
make
make install

7. Tried to install atk. When I did ./configure, surprise: it said I needed glib and it didn't find this in my system.

8. I tried to reinstall glib a thousand times, but it didn't work.

Now the question: What the (...) did I do wrong? Why it keeps saying that there is no glib if I installed in successfully from the source? Is there anything to do with LIBs PATH? If yes, how to solve it?

Thanks!

truthfatal 06-24-2006 01:52 PM

after you instaled glib, did you run ldconfig?

stevesk 06-24-2006 02:31 PM

Hmmmmm I didn't know about this command (NB), but i tryed to run ldconfig as root in '/' and in both source dirs. of glib and atk after installing the first one. It keeps showing the error message, so I think it didn't work.

truthfatal 06-24-2006 07:57 PM

What is the error message?

stevesk 06-26-2006 04:27 PM

Hello, sorry for the delay. The error message is:

checking for g77... g77
checking whether we are using the GNU Fortran 77 compiler... yes
checking whether g77 accepts -g... yes
checking the maximum length of command line arguments... 32768
checking command to parse /usr/bin/nm -B output from gcc object... ok
checking for objdir... .libs
checking for ar... ar
checking for ranlib... ranlib
checking for strip... strip
checking if gcc static flag works... yes
checking if gcc supports -fno-rtti -fno-exceptions... no
checking for gcc option to produce PIC... -fPIC
checking if gcc PIC flag -fPIC works... yes
checking if gcc supports -c -o file.o... yes
checking whether the gcc linker (/usr/i486-slackware-linux/bin/ld) supports shared libraries... yes
checking whether -lc should be explicitly linked in... no
checking dynamic linker characteristics... GNU/Linux ld.so
checking how to hardcode library paths into programs... immediate
checking whether stripping libraries is possible... yes
checking if libtool supports shared libraries... yes
checking whether to build shared libraries... yes
checking whether to build static libraries... no
configure: creating libtool
appending configuration tag "CXX" to libtool
checking for ld used by g++... /usr/i486-slackware-linux/bin/ld
checking if the linker (/usr/i486-slackware-linux/bin/ld) is GNU ld... yes
checking whether the g++ linker (/usr/i486-slackware-linux/bin/ld) supports shared libraries... yes
checking for g++ option to produce PIC... -fPIC
checking if g++ PIC flag -fPIC works... yes
checking if g++ supports -c -o file.o... yes
checking whether the g++ linker (/usr/i486-slackware-linux/bin/ld) supports shared libraries... yes
checking dynamic linker characteristics... GNU/Linux ld.so
checking how to hardcode library paths into programs... immediate
checking whether stripping libraries is possible... yes
appending configuration tag "F77" to libtool
checking if libtool supports shared libraries... yes
checking whether to build shared libraries... yes
checking whether to build static libraries... no
checking for g77 option to produce PIC... -fPIC
checking if g77 PIC flag -fPIC works... yes
checking if g77 supports -c -o file.o... yes
checking whether the g77 linker (/usr/i486-slackware-linux/bin/ld) supports shared libraries... yes
checking dynamic linker characteristics... GNU/Linux ld.so
checking how to hardcode library paths into programs... immediate
checking whether stripping libraries is possible... yes
checking for some Win32 platform... no
checking for native Win32 platform... no
checking for aclocal flags...
checking for pkg-config... /usr/bin/pkg-config
checking for GLIB - version >= 2.5.7... no
*** Could not run GLIB test program, checking why...
*** The test program failed to compile or link. See the file config.log for the
*** exact error that occured. This usually means GLIB is incorrectly installed.
checking for pkg-config... (cached) /usr/bin/pkg-config
checking for GLIB - version >= 2.0.0... no
*** Could not run GLIB test program, checking why...
*** The test program failed to compile or link. See the file config.log for the
*** exact error that occured. This usually means GLIB is incorrectly installed.
configure: error:
*** GLIB 2.0.0 or better is required. The latest version of
*** GLIB is always available from ftp://ftp.gtk.org/. If GLIB is installed
*** but not in the same location as pkg-config add the location of the file
*** glib-2.0.pc to the environment variable PKG_CONFIG_PATH.
root@matrix:/home/packages/Libs/Gtk/atk-1.10.3#

stevesk 06-29-2006 02:13 PM

Hey, anyone here?

berbae 06-29-2006 04:27 PM

Hi stevesk
The output of the atk configure command gives you some clues:
Did you look in the config.log file to see the exact error that occurred ?
Did you search the glib-2.0.pc file and did you check the environment variable PKG_CONFIG_PATH ?
We cannot do that for you, neither guess what occurred.

stevesk 06-30-2006 01:28 PM

Hey people! Sorry for the delay...as config.log is too big to post here, please check:

http://www.angelfire.com/planet/net....pt/config1.log

ANy help would be welcome...I suspect the problem is on glib installation, but I am not 100% sure.

berbae 06-30-2006 05:02 PM

The problem is here:
Quote:

configure:20124: checking for GLIB - version >= 2.5.7
configure:20273: result: no
configure:20306: gcc -o conftest -g -O2 -Wall conftest.c >&5
conftest.c:27:18: glib.h: No such file or directory
it doesn't find the header file 'glib.h'
You must find where the glib header files were installed, and tell the place(s) to the configure script.
In the config.log file you have:
Quote:

GLIB_CFLAGS=''
GLIB_GENMARSHAL=''
GLIB_LIBS=''
GLIB_MKENUMS=''
GLIB_PACKAGES='gobject-2.0 '
GLIB_REQUIRED_VERSION='2.0.0'
In my 'config.log' file I have:
Quote:

GLIB_CFLAGS='-I/opt/kde3.5.3/include/glib-2.0 -I/opt/kde3.5.3/lib/glib-2.0/include'
GLIB_GENMARSHAL='glib-genmarshal'
GLIB_LIBS='-L/opt/kde3.5.3/lib -lgobject-2.0 -lgmodule-2.0 -ldl -lglib-2.0 '
GLIB_MKENUMS='glib-mkenums'
GLIB_PACKAGES='gobject-2.0 gmodule-no-export-2.0'
GLIB_REQUIRED_VERSION='2.5.7'
Before launching the configure script I created 2 environment variables:
Code:

export GLIB_CFLAGS='-I/opt/kde3.5.3/include/glib-2.0 -I/opt/kde3.5.3/lib/glib-2.0/include'
export GLIB_LIBS='-L/opt/kde3.5.3/lib -lgobject-2.0 -lgmodule-2.0 -ldl -lglib-2.0'

You should change '/opt/kde3.5.3' with the places where the glib header files and libraries were installed.

Edit: To confirm that the configure script uses the GLIB_CFLAGS and GLIB_LIBS variables, here is the 'checking for GLIB' in my config.log file:
Quote:

configure:20121: checking for GLIB - version >= 2.5.7
configure:20240: gcc -o conftest -g -O2 -Wall -I/opt/kde3.5.3/include/glib-2.0 -I/opt/kde3.5.3/lib/glib-2.0/include conftest.c -L/opt/kde3.5.3/lib -lglib-2.0 >&5
configure:20243: $? = 0
configure:20245: ./conftest
configure:20248: $? = 0
configure:20266: result: yes (version 2.10.3)

stevesk 07-02-2006 06:09 PM

Thanks for the help berbae! I did another thing to finally solve this stuff, but I thank you anyway :)

What I could observe is that glib was being installed in /usr/local/ and not in /usr . And, for a reason that a linux nb still don't know, it was not being found by atk configure. So I found the option --prefix= and used it. Always when I run configure of atk, gtk, glib, pango and cairo I used:

./configure --prefix=/usr

And so it worked! :)


All times are GMT -5. The time now is 09:52 PM.