LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 09-23-2003, 12:35 PM   #1
bjwesselink
LQ Newbie
 
Registered: Aug 2003
Distribution: Red Hat 9.0
Posts: 5

Rep: Reputation: 0
Unhappy [SAMBA] No start-up


Ok, I installed Linux Red Hat 9.0 BLANK, with only KDE and developers tools (gcc etc etc). I now try to build my own server. Starting with Samba. I downloaded the file, installed it into /usr/local/samba/, wrote a smb.conf file and tested it, it worked! I got login, read and write form my Win2k Pro workstation. But..

Starting up Samba as Daemon keeps failing. RH9 uses Xinetd, so i wrote two files,
------netbios-ssn:-----
service netbios-ssn
{
socket_type = stream
protocol = tcp
wait = no
user = root
server = /usr/local/samba/bin/smbd
disable = no
}
------netbios-ns:-----
service netbios-ns
{
socket_type = dgram
protocol = udp
wait = yes
user = root
server = /usr/local/samba/bin/nmbd
disable = no
}
and dumped them in the /etc/xinit.d/ dir. So they should start up now. They don't but when i look at the services window in KDE, xinetd is up and running, but netbios-ssn and -ns say "you have to enable xinetd to run". What the hell is wrong and how do i get samba to automaticly startup?
 
Old 09-23-2003, 08:12 PM   #2
jdruin
Member
 
Registered: Jul 2003
Location: Louisville aka Derby City
Distribution: WinXP SP2 and SP3, W2K Server, Ubuntu
Posts: 313

Rep: Reputation: 30
Since you have redhat 9, please run:

ntsysv

as root. Scroll down until you see "smb" and check it off using the space bar. Use the tab key to move the cursor and hit "OKAY". This will set up the xinetd correctly for running at start up.

If you are getting a "file not found" error, try:

find / -name ntsysv

to get the whole path. Then run from the whole path, example:

/usr/sbin/ntsysv

Good luck.
 
Old 09-24-2003, 02:12 AM   #3
bjwesselink
LQ Newbie
 
Registered: Aug 2003
Distribution: Red Hat 9.0
Posts: 5

Original Poster
Rep: Reputation: 0
?

That's doesnt work, but isn't that logical, because now i prevent it from starting up and only disable = on will be changed in the two samba startup files
 
Old 09-24-2003, 05:30 PM   #4
jdruin
Member
 
Registered: Jul 2003
Location: Louisville aka Derby City
Distribution: WinXP SP2 and SP3, W2K Server, Ubuntu
Posts: 313

Rep: Reputation: 30
I am sorry. I do not understand your response. One thing I forgot to mention is you have to restart xinetd:

/etc/rc.d/init.d/xinetd restart
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
when i try to start samba pdc's smb service nmbd failed to start . sandeepchau123 Linux - Newbie 2 10-20-2007 01:59 PM
how do i start samba Alexander.s Linux - Newbie 3 01-13-2005 06:08 PM
Installed the wrong SAMBA packages.Now samba doesn't start Terrence Hinds Linux - Networking 3 10-11-2004 03:40 AM
Samba does not start! kleptophobiac Linux - Software 1 09-27-2003 09:23 AM
when i restart SAMBA,it says:stop samba failed,start SAMBA OK! whepin Linux - Networking 3 12-26-2001 05:54 AM


All times are GMT -5. The time now is 05:49 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration