LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 09-25-2006, 08:54 AM   #1
lachesis
Member
 
Registered: May 2004
Posts: 46

Rep: Reputation: 15
[FC5 - gcc install] error:no acceptable cc found in $PATH


Hi

I done a fresh install of FC5, and am just getting to use it now. I tried to first get Samba installed but it complained about gcc paths, so I downloaded gcc-4.0.2 and am trying to get it installed and it gives tme the following message:

Quote:
[root@localhost gcc]# /root/gcc-4.0.2/./configure
loading cache ./config.cache
checking host system type... i686-pc-linux-gnuoldld
checking target system type... i686-pc-linux-gnuoldld
checking build system type... i686-pc-linux-gnuoldld
checking for a BSD compatible install... /usr/bin/install -c
checking whether ln works... yes
checking whether ln -s works... yes
checking for gcc... no
checking for cc... no
configure: error: no acceptable cc found in $PATH
Being totally new, what is wrong with this, I accepted most defaults on installation mode, and how would I resolve it?

Thanks
 
Old 09-25-2006, 09:02 AM   #2
Nylex
LQ Addict
 
Registered: Jul 2003
Location: London, UK
Distribution: Slackware
Posts: 7,464

Rep: Reputation: Disabled
You need a C compiler installed to build stuff (written in C) from source. Why don't you just install the pre-built packages for gcc and Samba?
 
Old 09-25-2006, 09:06 AM   #3
lachesis
Member
 
Registered: May 2004
Posts: 46

Original Poster
Rep: Reputation: 15
Thanks

I know that they are compilers etc. but when I try to start the package manager in Fedora it just says that:

Quote:
Error:

Unable to retrieve software information
Or do you mean get hold of the rpm fileS?
 
Old 09-25-2006, 09:10 AM   #4
Nylex
LQ Addict
 
Registered: Jul 2003
Location: London, UK
Distribution: Slackware
Posts: 7,464

Rep: Reputation: Disabled
If you get the RPMs, be aware that you'll need to get the dependencies yourself and install those as well.

I'm not sure how to fix that error message, as I don't use Fedora. Do a search for that text on LQ and with Google and see if you find anything helpful. Otherwise, someone who uses Fedora will be able to help you .
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
configure: error: no acceptable ld found in $PATH rover Linux - Newbie 2 12-04-2009 07:35 AM
Configure: error: no acceptable cc found in $PATH chemicalvamp Linux - Software 6 02-21-2006 03:08 PM
error : no acceptable C compiler found in $PATH tzonga1 Linux - Software 1 03-02-2005 10:01 PM
error: no acceptable C compiler found in $PATH Tracianddwayne Linux - Newbie 1 12-23-2004 04:18 PM
configure: error: no acceptable cc found in $PATH nistelrooy Mandriva 3 10-07-2003 02:37 PM


All times are GMT -5. The time now is 01:16 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration