LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 12-14-2008, 12:16 PM   #1
xeross
Member
 
Registered: Apr 2008
Posts: 48

Rep: Reputation: 15
[Deb4]rc.local not executed at system start


Hey,

Whenever i reboot my system i have to restart my custom compiled apache and apache manually. While i have the same commands(With full paths) in the /etc/rc.local but it looks like they aren't getting executed.
How would i fix this.

Thank for your time, Xeross

Also, i know i should be using packages and i already switched to a mysql package and will also do so with apache but not atm.
 
Old 12-14-2008, 05:01 PM   #2
norobro
Member
 
Registered: Feb 2006
Distribution: Debian Sid
Posts: 517

Rep: Reputation: 177Reputation: 177
If you have bootlogd enabled any errors or warnings will show up in "/var/log/boot"

My normal boot log ( empty /etc/rc.local ):
Code:
Sun Dec 14 09:39:59 2008: Running local boot scripts (/etc/rc.local).
Boot log with a warning:
Code:
Sun Dec 14 14:42:33 2008: Running local boot scripts (/etc/rc.local)[Sun Dec 14 14:42:36 2008] [warn] NameVirtualHost *:80 has no VirtualHosts
 
Old 12-15-2008, 07:37 AM   #3
xeross
Member
 
Registered: Apr 2008
Posts: 48

Original Poster
Rep: Reputation: 15
How would i enable it.

Code:
GNU nano 2.0.2                File: /var/log/boot

(Nothing has been logged yet.)
 
Old 12-15-2008, 10:00 AM   #4
norobro
Member
 
Registered: Feb 2006
Distribution: Debian Sid
Posts: 517

Rep: Reputation: 177Reputation: 177
rc.local and bootlogd are part of the "initscripts" package. If you have it installed, you can enable bootlogging by changing the line "BOOTLOGD_ENABLE=NO" in "/etc/default/bootlogd".

Again, if you have "initscripts" installed, there should be links in your rc[2-5].d directories to run rc.local. On my system they are:
Code:
@S99rc.local
and they point to "/etc/init.d/rc.local". If you don't have them, you can either add the links manually or you can download the "sysv-rc-conf" run-level configuration tool.
 
Old 12-15-2008, 10:17 AM   #5
xeross
Member
 
Registered: Apr 2008
Posts: 48

Original Poster
Rep: Reputation: 15
S99rc.local exists but it looks like it doesn't get fired.
Bootlogd enabled, i will see if everything works when i have to reboot it
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
how VI reads from a file ,what flow of system calls gets executed devkpict Linux - Kernel 3 12-04-2007 08:54 AM
Deb4 wrong MD5 checksums on DVD#3 (i386) Sparky Debian 22 09-18-2007 02:49 PM
rc.local isn't executed at boot time elvijs Slackware 3 06-24-2007 07:48 AM
poepn or system function call executed by a background process kshkid Programming 1 08-24-2006 04:04 AM
Cannot ping local system when pinging system is set for static IP SkipHuffman Linux - Networking 4 08-22-2005 12:56 PM


All times are GMT -5. The time now is 02:41 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration