LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 09-27-2012, 05:00 PM   #1
ulkoma
Member
 
Registered: Feb 2012
Distribution: CentOS
Posts: 69

Rep: Reputation: Disabled
[CetOS server] Multiple problems


Hi
I have a CentOS 6.3 server that I am trying to use as a seedbox (a server with a torrent client)

I'd like to access the server via VNC and install a torrent client,here are the issues that I keep facing

-yum groupinstall "X Window System"
-yum groupinstall "Desktop" "Desktop Platform" "Fonts"

Problem#1: DNS disappears from
Code:
/etc/resolv.conf
also it disappears from the ifcfg file


Solution: I re-add the DNS in the ifcfg file

Explanation wanted

then
-yum install tigervnc-server
~~add new user, configure the vnc server, connect to the server via VNC

Problem#2: terminal, CLI does not work with the new user! it gives an error

Temporary Solution: I use Putty and the root account to execute commands

Explanation and a real solution wanted

then

-cd /etc/yum.repos.d/
-wget http://geekery.altervista.org/geekery-el6-i686.repo
-yum install transmission

Problem#3: transmission does not show up in the applications menu! no GUI?

Solution: none

Explanation and solution wanted

Regards

Last edited by ulkoma; 09-27-2012 at 06:22 PM.
 
Old 09-27-2012, 05:22 PM   #2
suicidaleggroll
LQ Guru
 
Registered: Nov 2010
Location: Colorado
Distribution: OpenSUSE, CentOS
Posts: 5,492

Rep: Reputation: 2096Reputation: 2096Reputation: 2096Reputation: 2096Reputation: 2096Reputation: 2096Reputation: 2096Reputation: 2096Reputation: 2096Reputation: 2096Reputation: 2096
#1 - NetworkManager could be the problem. NM causes NOTHING but problems for me, literally the first thing I do when I set up a CentOS system is "yum remove NetworkManager". Once it's gone, you can config the network manually with ifcfg files, ifup, ifdown, /etc/resolv.conf, etc.

#2 - What error do you get when you try to SSH in?

#3 - I've never used transmission, but just because it's not in the menu doesn't mean it doesn't exist or doesn't have a GUI, the installer just might not have put a shortcut to it in the applications menu.
 
Old 09-27-2012, 07:04 PM   #3
ulkoma
Member
 
Registered: Feb 2012
Distribution: CentOS
Posts: 69

Original Poster
Rep: Reputation: Disabled
#1 yes it's NM I guess, lots of Google results suggested that

#2 not when I SSH but when I try to run the terminal after I access the server via VNC
I get a red line on the top of the window which says "There was an error creating the child process for this terminal"
http://i49.tinypic.com/25styjs.png

#3 when I install firefox the shortcut goes there automatically, when I installed transmission before it created the shortcut automatically
either the new version does not or something is wrong with my system, anyway can you suggest any solution? especially that I dont even have a
terminal to invoke the program using its name due to problem #2

Regards
 
Old 09-28-2012, 08:17 AM   #4
TobiSGD
Moderator
 
Registered: Dec 2009
Location: Germany
Distribution: Whatever fits the task best
Posts: 17,133
Blog Entries: 2

Rep: Reputation: 4836Reputation: 4836Reputation: 4836Reputation: 4836Reputation: 4836Reputation: 4836Reputation: 4836Reputation: 4836Reputation: 4836Reputation: 4836Reputation: 4836
The real solution to your problem would be to ditch the X environment, the desktop and VNC, then just use Transmission's web-interface. Works fine here on my file-server without any kind of GUI.
 
Old 09-28-2012, 08:49 PM   #5
ulkoma
Member
 
Registered: Feb 2012
Distribution: CentOS
Posts: 69

Original Poster
Rep: Reputation: Disabled
Thanks for your lovely suggestion however this isn't the point, I already managed to get around the problem by installing an other torrent client , I hate transmission's WebUI however its an other solution like you suggested
What I need here is an explanation: why does the terminal crashes? what did I do wrong? this is not my first sever from the same web hosting company and its always the same problem! Also what happened to transmission's GUI?
I use Linux cause there is an explanation for everything, if such issues happened with my MSWindows based server I wouldnt ever bother starting a topic about it cause the answer always is "it's just like that, because Gates said so, take it or leave it"
Regards
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
how to transfer multiple file to multiple server using public and private key sampadray81 Linux - Newbie 5 02-27-2012 12:31 PM
Some commands not running in primary nameserver using cetos 5.6 SarahGurung Linux - Newbie 16 10-17-2011 06:56 AM
qt4 designer not starting on Cetos 5 tomtom1 Linux - Software 2 06-22-2011 01:40 AM
CetOS xen, " xend: command not found" slashtoe Linux - Newbie 2 06-01-2009 06:03 PM
Samba problems... multiple connections to a server .... ccool Linux - Networking 0 06-03-2003 03:47 PM


All times are GMT -5. The time now is 10:53 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration