LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 02-14-2016, 01:44 PM   #1
asoboleski
LQ Newbie
 
Registered: May 2012
Posts: 16

Rep: Reputation: Disabled
[Arch Linux] Audio not recognized by ALSA


I'm having some issues with audio in Arch Linux(4.4.1-2). I'm using ALSA at the moment but my sound card isn't being recognized. I have two devices listed for sound cards in Alsa. My webcam and my headset. My onboard sound through Intel isn't listed and neither is HDMI sound from my graphics card.

Both devices register in lspci -v.

Code:
00:1b.0 Audio device: Intel Corporation C610/X99 series chipset HD audio Controller (rev 05)
subsystem eVga.com. Corp. Device 1039
Flags: fast devsel, NUMA node 0
Memory at fb230000 (64-bit non-prefetchable) [disabled] [size=16k]
Capabilities: <access denied>
Kernel modules: snd_hda_intel


01:00.1 Audio Device: NVIDIA Corporation GM204 High Definition Audio Controller (rev a1)
Subsystem: eVga.com. Corp. Device 2983
Physical Slot: 4
Flags: bus master, fast devsel, latency 0, NUMA node 0
Memory at fb080000 (32-bit, non-prefetchable) [size=16k]
Capabilities: <access denied>
Kernel Modules: snd_hda_intel
I should mention that I've had this issue before. About an hour ago I disabled Azalia in UEFI/BIOS. My intel card and hdmi card were both registering before disabling Azalia. After disabling Azalia, they were gone, and after reenabling azalia, they were still gone. I should note that before I disabled azalia I still could not find a way to get audio to default to HDMI or onboard sound.

Can anybody give me a hand?
 
Old 02-14-2016, 02:02 PM   #2
asoboleski
LQ Newbie
 
Registered: May 2012
Posts: 16

Original Poster
Rep: Reputation: Disabled
Update:

Using the following /etc/asound.conf setup I was able to get my Corsair headset to put out some audio. But my onboard and/or NVIDIA GPU sound is still not showing up.
Code:
pcm.!default {
    type hw
    card 1
}

ctl.!default {
    type hw           
    card 1
}
The results of cat /proc/asound/cards and cat/asound/modules output my webcam and headset and no snd_hda_intel devices.
 
Old 02-14-2016, 07:43 PM   #3
Shadow_7
Senior Member
 
Registered: Feb 2003
Distribution: debian
Posts: 3,018
Blog Entries: 1

Rep: Reputation: 639Reputation: 639Reputation: 639Reputation: 639Reputation: 639Reputation: 639
for ~/.asoundrc
Code:
defaults.ctl.card 1
defaults.pcm.card 1
where 1 is the index number in /proc/asound/cards. Also make sure that the user is in the audio group. Otherwise use pavucontrol to manage pulseaudio and select your default card. Card 0 is by default, the default. Also note that the index number can change between boots. Just stuff to be aware of if you have to override distro defaults.
 
Old 02-15-2016, 06:11 AM   #4
asoboleski
LQ Newbie
 
Registered: May 2012
Posts: 16

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by Shadow_7 View Post
for ~/.asoundrc
Code:
defaults.ctl.card 1
defaults.pcm.card 1
where 1 is the index number in /proc/asound/cards. Also make sure that the user is in the audio group. Otherwise use pavucontrol to manage pulseaudio and select your default card. Card 0 is by default, the default. Also note that the index number can change between boots. Just stuff to be aware of if you have to override distro defaults.
I'm not home to test this but it doesn't seem that this is a solution to my issue at first glance. I'm pretty new to Linux still especially the world of audio. I will make sure my user is added to the audio group but my current issue is that my motherboard onboard sound is not listed in my cards and neither is my graphics card. My monitor is hooked up by HDMI so either option would work but I need my speakers to output sound. My gaming headset is rather useless for Linux apart from being the only working sound right now.
 
Old 02-15-2016, 09:14 PM   #5
Shadow_7
Senior Member
 
Registered: Feb 2003
Distribution: debian
Posts: 3,018
Blog Entries: 1

Rep: Reputation: 639Reputation: 639Reputation: 639Reputation: 639Reputation: 639Reputation: 639
Quote:
Originally Posted by asoboleski View Post
I'm not home to test this but it doesn't seem that this is a solution to my issue at first glance.
This is the simplest alsa-only way to override the default soundcard. If you use jackd, or other daemons, or pulseaudio it probably wont work. But if you keep it simple, you can't really go wrong. Outside of index shifting between boots. Although mostly an issue if you have multiple cards that use the same driver. Various ways to configure things depending on what you use and how you use it.
 
Old 02-16-2016, 01:19 PM   #6
asoboleski
LQ Newbie
 
Registered: May 2012
Posts: 16

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by Shadow_7 View Post
This is the simplest alsa-only way to override the default soundcard. If you use jackd, or other daemons, or pulseaudio it probably wont work. But if you keep it simple, you can't really go wrong.
That's part of my issue, I can change the sound cards fine. I switched the default from my webcam, which doesn't even have speakers, to my headset which plays really loudly. But my issue is that my motherboard sound and my graphics card HDMI sound is not showing up - at all -. Whatever drivers are running it are not loading or are not registering these devicesn. They're not listed when I check asound/cards.
 
Old 02-16-2016, 02:23 PM   #7
Higgsboson
Member
 
Registered: Dec 2014
Location: UK
Distribution: Debian 8 Cinnamon/Xfce/gnome classic Debian live usb
Posts: 508

Rep: Reputation: 49
On thing I did was to install the pulseaudio pgm.
On Debian the cmd is 'apt-get install pavucontrol'.
Once you open pulseaudio (e.g. input 'pavucontrol' on the terminal after installing the pgm) go to the configuration tab and change the 'Built in audio' field to accept an input which gives you sound.
Usually, I play a youtube video and then change the pavucontrol input settings until I hear sound.
 
Old 02-17-2016, 07:44 AM   #8
Shadow_7
Senior Member
 
Registered: Feb 2003
Distribution: debian
Posts: 3,018
Blog Entries: 1

Rep: Reputation: 639Reputation: 639Reputation: 639Reputation: 639Reputation: 639Reputation: 639
My HDMI out is kind of hidden and doesn't show up in /proc/asound/cards. But it is there under /proc/asound/card0/pcm3p/info. So I would need to output to hw:0,3 for the HDMI audio. In theory anyway, never actually used it.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
SD card not recognized on Linux 3.12.6-1-ARCH. s.verma Linux - Hardware 15 10-17-2015 07:35 AM
Linux AUDIO ALSA bergarth Linux - Newbie 1 08-07-2014 09:03 AM
No audio on ArchBang/Arch Linux Altiris Linux - Newbie 1 10-07-2013 06:05 PM
[arch linux ] Pulse audio,ATI Technologies Inc RV710/730 no card detected artur13 Linux - Newbie 3 01-19-2011 02:21 PM
audio device fails to open on arch linux, even after alsa config sether Linux - Hardware 1 10-07-2004 12:43 AM


All times are GMT -5. The time now is 05:55 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration