LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 09-12-2005, 06:58 AM   #1
Akhran
Member
 
Registered: Aug 2005
Distribution: Debian 'lenny'
Posts: 208

Rep: Reputation: 30
[Apache2] Localhost can connect to HTTPS, but not clients in the LAN


I've installed the apache 2 and webmin debian package. On the server, I can access webmin at https://127.0.0.1:10000. However, when I tried to access the server at https://Some_Server_IP:10000, I get a 'access denied' error message.

Would appreciate some pointers on how to troubleshoot this problem.

Thanks !
 
Old 09-12-2005, 09:09 AM   #2
pats
Member
 
Registered: Jul 2005
Distribution: Debian Sarge/Etch, (K)Ubuntu, FC6, AIX5.3, VMWare ESXServer
Posts: 159

Rep: Reputation: 30
sounds very much like a firewall issue to me. possibly could be something to do with the webserver itself not allowing connections to that port
 
Old 09-12-2005, 01:10 PM   #3
Akhran
Member
 
Registered: Aug 2005
Distribution: Debian 'lenny'
Posts: 208

Original Poster
Rep: Reputation: 30
The only packages I have installed are those that comes with the minimal installation of the netinstall CD, apache 2 and webmin. Is there a build-in firewall in the minimal installation of Debian?

Thanks!


Quote:
Originally posted by pats
sounds very much like a firewall issue to me. possibly could be something to do with the webserver itself not allowing connections to that port
 
Old 09-12-2005, 05:13 PM   #4
pats
Member
 
Registered: Jul 2005
Distribution: Debian Sarge/Etch, (K)Ubuntu, FC6, AIX5.3, VMWare ESXServer
Posts: 159

Rep: Reputation: 30
i odn't know for debian but i would try port scanning your server to see if the server is listening on port 1000 or what ever your using.

also i would check the webserver config files to check that its not set to only allow https from localhost
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Apache2 debian sarge: browser can't connect to the localhost blueheart Linux - Software 5 07-15-2005 11:12 AM
apache2 + https on suse 9.2 linux svanati Suse/Novell 0 02-22-2005 01:47 PM
[apache2] could not connect to host localhost LordFrancis Linux - Networking 1 09-30-2004 02:37 PM
Apache2, SSL, HTTPS... KneeLess Debian 3 09-02-2004 09:44 PM
can't connect to linux box on lan, or ping localhost banschu Linux - Networking 2 09-01-2004 10:16 PM


All times are GMT -5. The time now is 03:51 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration