LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 11-09-2011, 01:33 PM   #1
anjumanu321
Member
 
Registered: May 2011
Location: Hyderabad, India
Distribution: RedHat 6,Centos,Debian Squeeze
Posts: 49

Rep: Reputation: Disabled
*** ERROR: PERL module Apache::DBI is not installed !


Hello,

I am configuring OCS Server using the following two documentations:

http://wiki.centos.org/HowTos/OCSNG
http://www.howtoforge.com/how-to-ins...-on-centos-5.5

Getting below error during installaton:

""Checking for DBI PERL module...
Found that PERL module DBI is available.
Checking for Apache:BI PERL module...
*** ERROR: PERL module Apache:BI is not installed !
Checking for DBD::mysql PERL module...
Found that PERL module DBD::mysql is available.
Checking for Compress::Zlib PERL module...
Found that PERL module Compress::Zlib is available.
Checking for XML::Simple PERL module...
Found that PERL module XML::Simple is available.
Checking for Net::IP PERL module...
Found that PERL module Net::IP is available.
*** ERROR: There is one or more required PERL modules missing on your computer !
Please, install missing PERL modules first.""

i have googled for the solution unsuccessfully.
please help me in installing the missing perl module.

thanks in advance..

--
Anil Anji
 
Old 11-09-2011, 01:40 PM   #2
smallpond
Senior Member
 
Registered: Feb 2011
Location: Massachusetts, USA
Distribution: CentOS 6 (pre-systemd)
Posts: 2,667

Rep: Reputation: 710Reputation: 710Reputation: 710Reputation: 710Reputation: 710Reputation: 710Reputation: 710
code tags would be helpful in your post.

Like so:
Code:
yum install perl-Apache-DBI

Last edited by smallpond; 11-09-2011 at 01:44 PM. Reason: corrected name
 
Old 11-09-2011, 01:43 PM   #3
angel115
Member
 
Registered: Jul 2005
Location: France / Ireland
Distribution: Debian mainly, and Ubuntu
Posts: 532

Rep: Reputation: 78
well, you didn't find anything in google???

I search this "how to install a perl module using cpan"

And here is what is the first result:
Installing Perl modules from CPAN
"http://perl.about.com/od/packagesmod...t/perlcpan.htm"

Well, I hope that will help,

Angel.
 
Old 11-09-2011, 01:46 PM   #4
anjumanu321
Member
 
Registered: May 2011
Location: Hyderabad, India
Distribution: RedHat 6,Centos,Debian Squeeze
Posts: 49

Original Poster
Rep: Reputation: Disabled
Code:

yum install perl-Apache-DBI //

Getting the following error:

Error: Package: perl-Apache-DBI-1.09-1.el5.noarch (epel)
Requires: perl(:MODULE_COMPAT_5.8.8)
You could try using --skip-broken to work around the problem
You could try running: rpm -Va --nofiles --nodigest
 
Old 11-09-2011, 01:49 PM   #5
anjumanu321
Member
 
Registered: May 2011
Location: Hyderabad, India
Distribution: RedHat 6,Centos,Debian Squeeze
Posts: 49

Original Poster
Rep: Reputation: Disabled
Installing Perl modules from CPAN
"http://perl.about.com/od/packagesmod...t/perlcpan.htm" //

thanks for the suggestion, but i have already tried using CPAN and getting the following error message.

Can't locate CPAN.pm in @INC (@INC contains: /usr/local/lib/perl5 /usr/local/share/perl5 /usr/lib/perl5/vendor_perl /usr/share/perl5/vendor_perl /usr/lib/perl5 /usr/share/perl5 .).
BEGIN failed--compilation aborted.
 
Old 11-09-2011, 01:52 PM   #6
angel115
Member
 
Registered: Jul 2005
Location: France / Ireland
Distribution: Debian mainly, and Ubuntu
Posts: 532

Rep: Reputation: 78
Quote:
*** ERROR: There is one or more required PERL modules missing on your computer !
Please, install missing PERL modules first.
So why don't you try to do what it say and install all your missing perl module?

Ex:
Code:
# perl -MCPAN -e 'install Apache::DBI'

Last edited by angel115; 11-09-2011 at 01:55 PM.
 
Old 11-09-2011, 01:55 PM   #7
anjumanu321
Member
 
Registered: May 2011
Location: Hyderabad, India
Distribution: RedHat 6,Centos,Debian Squeeze
Posts: 49

Original Poster
Rep: Reputation: Disabled
# perl -MCPAN -e 'install Apache:BI' //

yes i have tried this code, but still getting the same error message.
 
Old 11-09-2011, 01:57 PM   #8
angel115
Member
 
Registered: Jul 2005
Location: France / Ireland
Distribution: Debian mainly, and Ubuntu
Posts: 532

Rep: Reputation: 78
This should fix it then:
Code:
yum install perl-CPAN
 
Old 11-09-2011, 02:10 PM   #9
anjumanu321
Member
 
Registered: May 2011
Location: Hyderabad, India
Distribution: RedHat 6,Centos,Debian Squeeze
Posts: 49

Original Poster
Rep: Reputation: Disabled
yum install perl-CPAN //


done with installing the missing module, thanks a lot for the help
 
Old 04-23-2015, 04:40 PM   #10
dhaselhorst
LQ Newbie
 
Registered: Apr 2015
Posts: 1

Rep: Reputation: Disabled
installing perl-Apache-DBI

I know this post is a bit old, but the information is still valid. Do yourself a favor and instead of installing CPAN and related Perl modules, install the "extras" repository as those RPM packages are already built and available.

First, add the EPEL repository and follow the prompts
# yum install epel-release

Now install those needed packages (as well as a few others needed for OCS)
# yum install perl-Apache-DBI perl-XML-Entities perl-Apache2-SOAP

Cheers, D.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Has anyone been able to get the DBI drivers installed for perl and MySQL? arpanetguru Slackware 1 02-06-2011 09:49 PM
perl dbi:mysql shows error syntax error dbi:mysql ?? haxpak Linux - Server 4 02-27-2009 12:09 AM
perl dbi module error "error at dbi:" dbi-> connect statement mysql haxpak Linux - Newbie 1 02-25-2009 09:22 AM
Error using DBI with Perl bostonantifan Ubuntu 0 11-11-2007 02:47 PM
Perl module Bundle::DBI doesn't install nonades Programming 1 04-21-2007 08:11 AM


All times are GMT -5. The time now is 05:31 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration