LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 06-25-2008, 09:59 AM   #1
Sanford Stein
Member
 
Registered: Jun 2008
Location: Evanston, Illinois
Distribution: RHEL 6.4
Posts: 126

Rep: Reputation: 17
'mail' command not working in cyrus environment


I am setting up a new server running RHEL 5.1. I installed and configured cyrus-imapd and confirmed that it is creating mailboxes properly. But 'mail' does not work: no error messages are generated but the mail message does not reach the user.

Here is what appears in maillog:

Jun 25 09:56:18 olive lmtpunix[5624]: accepted connection
Jun 25 09:56:18 olive lmtpunix[5624]: lmtp connection preauth'd as postman
Jun 25 09:56:18 olive lmtpunix[5624]: couldn't create stage directory: /var/spool/imap/stage./: File exists
Jun 25 09:56:18 olive lmtpunix[5624]: IOERROR: creating message file /var/spool/imap/stage./5624-1214402178-0: File exists
Jun 25 09:56:18 olive master[8030]: about to exec /usr/lib/cyrus-imapd/lmtpd
Jun 25 09:56:18 olive lmtpunix[5624]: IOERROR: fstating sieve script /var/lib/imap/sieve/t/testuser/defaultbc: No such file or directory
Jun 25 09:56:18 olive lmtpunix[5624]: duplicate_check: <200806251356.m5PDuH4K008025@olive.cybertools.biz> user.testuser 0
Jun 25 09:56:18 olive lmtpunix[5624]: FATAL: Internal error: assertion failed: append.c: 479: stage != NULL && stage->parts[0] != '\0'
Jun 25 09:56:18 olive lmtpunix[8030]: executed
Jun 25 09:56:18 olive master[5095]: process 5624 exited, status 75
Jun 25 09:56:18 olive master[5095]: service lmtpunix pid 5624 in BUSY state: terminated abnormally
Jun 25 09:56:18 olive sendmail[8028]: m5PDuHju008026: to=<testuser@olive.cybertools.biz>, delay=00:00:01, xdelay=00:00:00, mailer=cyrus, pri=120367, dsn=4.0.0, stat=Deferred: cyrus mailer (/usr/lib/cyrus-imapd/deliver) exited with EX_TEMPFAIL

The cyrus/sendmail setup instructions I am using are for RHEL 4. Should something be done differently in RHEL 5?

Your assistance is greatly appreciated.

Sanford Stein
CyberTools Inc.
 
Old 06-25-2008, 11:18 AM   #2
Sanford Stein
Member
 
Registered: Jun 2008
Location: Evanston, Illinois
Distribution: RHEL 6.4
Posts: 126

Original Poster
Rep: Reputation: 17
Update

I deleted /var/spool/imap/stage. and now am able to send messages to local users. But I still cannot send mail to outside domains such as yahoo.com. Any idea how to fix this?

Thanks,
SS
 
Old 05-01-2013, 11:08 AM   #3
casperpache
LQ Newbie
 
Registered: Oct 2009
Location: Aberystwyth
Distribution: Redhat 5
Posts: 22

Rep: Reputation: 0
Ive had a similar problem and im unsure what to do.

Im getting this error:-
May 1 09:45:01 gaalpltapp00c9 sendmail[16380]: r41Dj1dP016380: from=iwadmin, size=539, class=0, nrcpts=1, msgid=<201305011345.r41Dj1dP016380@gaalpltapp00c9.linux.us.ams1907.com>, relay=iwadmin@localhost
May 1 09:45:02 gaalpltapp00c9 sendmail[16386]: r41Dj1di016386: from=<iwadmin@gaalpltapp00c9.linux.us.ams1907.com>, size=875, class=0, nrcpts=1, msgid=<201305011345.r41Dj1dP016380@gaalpltapp00c9.linux.us.ams1907.com>, proto=ESMTP, daemon=MTA, relay=localhost.localdomain [127.0.0.1]
May 1 09:45:02 gaalpltapp00c9 sendmail[16380]: r41Dj1dP016380: to=iwadmin, ctladdr=iwadmin (12072/104), delay=00:00:01, xdelay=00:00:01, mailer=relay, pri=30539, relay=[127.0.0.1] [127.0.0.1], dsn=2.0.0, stat=Sent (r41Dj1di016386 Message accepted for delivery)
May 1 09:45:02 gaalpltapp00c9 deliver[16389]: connect(/var/lib/imap/socket/lmtp) failed: Connection refused
May 1 09:45:02 gaalpltapp00c9 sendmail[16388]: r41Dj1di016386: to=<iwadmin@gaalpltapp00c9.linux.us.ams1907.com>, delay=00:00:00, xdelay=00:00:00, mailer=cyrus, pri=120875, dsn=4.0.0, stat=Deferred: cyrus mailer (/usr/lib64/cyrus-imapd/deliver) exited with EX_TEMPFAIL
May 1 09:48:01 gaalpltapp00c9 sendmail[24555]: r41Dm1dH024555: from=iwadmin, size=539, class=0, nrcpts=1, msgid=<201305011348.r41Dm1dH024555@gaalpltapp00c9.linux.us.ams1907.com>, relay=iwadmin@localhost
May 1 09:48:01 gaalpltapp00c9 sendmail[24561]: r41Dm1le024561: from=<iwadmin@gaalpltapp00c9.linux.us.ams1907.com>, size=875, class=0, nrcpts=1, msgid=<201305011348.r41Dm1dH024555@gaalpltapp00c9.linux.us.ams1907.com>, proto=ESMTP, daemon=MTA, relay=localhost.localdomain [127.0.0.1]
May 1 09:48:01 gaalpltapp00c9 sendmail[24555]: r41Dm1dH024555: to=iwadmin, ctladdr=iwadmin (12072/104), delay=00:00:00, xdelay=00:00:00, mailer=relay, pri=30539, relay=[127.0.0.1] [127.0.0.1], dsn=2.0.0, stat=Sent (r41Dm1le024561 Message accepted for delivery)
May 1 09:48:01 gaalpltapp00c9 deliver[24564]: connect(/var/lib/imap/socket/lmtp) failed: Connection refused
May 1 09:48:01 gaalpltapp00c9 sendmail[24563]: r41Dm1le024561: to=<iwadmin@gaalpltapp00c9.linux.us.ams1907.com>, delay=00:00:00, xdelay=00:00:00, mailer=cyrus, pri=120875, dsn=4.0.0, stat=Deferred: cyrus mailer (/usr/lib64/cyrus-imapd/deliver) exited with EX_TEMPFAIL




I noticed it mentions cyrus and i spotted that the cyrus-imapd service was not running.

After starting this i still get errors but different.
Ive highlighted the part i think is the problem.

May 1 11:01:02 gaalpltapp00c9 master[28466]: process 5224 exited, status 0
May 1 11:01:02 gaalpltapp00c9 master[28466]: process 6947 exited, status 0
May 1 11:01:02 gaalpltapp00c9 master[7869]: about to exec /usr/lib64/cyrus-imapd/lmtpd
May 1 11:01:02 gaalpltapp00c9 lmtpunix[7869]: executed
May 1 11:03:01 gaalpltapp00c9 sendmail[10468]: r41F314s010468: from=iwadmin, size=539, class=0, nrcpts=1, msgid=<201305011503.r41F314s010468@gaalpltapp00c9.linux.us.ams1907.com>, relay=iwadmin@localhost
May 1 11:03:01 gaalpltapp00c9 sendmail[10474]: r41F31Nv010474: from=<iwadmin@gaalpltapp00c9.linux.us.ams1907.com>, size=875, class=0, nrcpts=1, msgid=<201305011503.r41F314s010468@gaalpltapp00c9.linux.us.ams1907.com>, proto=ESMTP, daemon=MTA, relay=localhost.localdomain [127.0.0.1]
May 1 11:03:01 gaalpltapp00c9 sendmail[10468]: r41F314s010468: to=iwadmin, ctladdr=iwadmin (12072/104), delay=00:00:00, xdelay=00:00:00, mailer=relay, pri=30539, relay=[127.0.0.1] [127.0.0.1], dsn=2.0.0, stat=Sent (r41F31Nv010474 Message accepted for delivery)
May 1 11:03:01 gaalpltapp00c9 lmtpunix[7869]: accepted connection
May 1 11:03:01 gaalpltapp00c9 lmtpunix[7869]: lmtp connection preauth'd as postman
May 1 11:03:01 gaalpltapp00c9 master[10478]: about to exec /usr/lib64/cyrus-imapd/lmtpd
May 1 11:03:01 gaalpltapp00c9 lmtpunix[7869]: verify_user(user.iwadmin) failed: Mailbox does not exist
May 1 11:03:01 gaalpltapp00c9 sendmail[10476]: r41F31Nv010474: to=<iwadmin@gaalpltapp00c9.linux.us.ams1907.com>, delay=00:00:00, xdelay=00:00:00, mailer=cyrus, pri=120875, dsn=5.6.0, stat=Data format error
May 1 11:03:01 gaalpltapp00c9 sendmail[10476]: r41F31Nv010474: r41F31Nv010476: DSN: Data format error
May 1 11:03:01 gaalpltapp00c9 lmtpunix[10478]: executed
May 1 11:03:01 gaalpltapp00c9 lmtpunix[7869]: accepted connection
May 1 11:03:01 gaalpltapp00c9 lmtpunix[7869]: lmtp connection preauth'd as postman
May 1 11:03:01 gaalpltapp00c9 lmtpunix[7869]: verify_user(user.iwadmin) failed: Mailbox does not exist
May 1 11:03:01 gaalpltapp00c9 sendmail[10476]: r41F31Nv010476: to=<iwadmin@gaalpltapp00c9.linux.us.ams1907.com>, delay=00:00:00, xdelay=00:00:00, mailer=cyrus, pri=32158, dsn=5.6.0, stat=Data format error
May 1 11:03:01 gaalpltapp00c9 sendmail[10476]: r41F31Nv010476: r41F31Nw010476: return to sender: Data format error
May 1 11:03:01 gaalpltapp00c9 lmtpunix[10478]: accepted connection


Any ideas please?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
mail command not working soroccoheaven Linux - Server 3 10-07-2010 06:38 AM
Access mail via cyrus IMAP celeron Linux - Server 3 11-14-2007 02:53 AM
Mail -s command not working appropriately dphe Linux - Software 3 01-09-2007 01:13 AM
Postfix/Cyrus Not delivering mail nitsujw Linux - Software 1 07-17-2005 07:16 PM
Problem with mail delivery procmail>cyrus imap (using sendmail,procmail,cyrus,imap) bwana Linux - Software 2 03-24-2005 08:01 PM


All times are GMT -5. The time now is 06:06 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration