LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 10-20-2005, 06:12 PM   #1
beeblequix
Member
 
Registered: Oct 2005
Location: Tierra Firma, Earth
Distribution: Debian of course...
Posts: 196

Rep: Reputation: 30
'init 3' , 'init 5' -- is this only RedHat Related?


or do I also (on my DEBIAN system) have to do this when I'm updating video drivers? (ati on k7)

 
Old 10-20-2005, 07:00 PM   #2
dracolich
Senior Member
 
Registered: Jul 2005
Distribution: Slackware
Posts: 1,178

Rep: Reputation: 47
What exactly are you haveing to do when updating the driver? The init levels are common to almost all distros: 3 being multiuser console-login and 5 being multiuser graphic-login.
 
Old 10-20-2005, 07:15 PM   #3
jschiwal
LQ Guru
 
Registered: Aug 2001
Location: Fargo, ND
Distribution: SuSE AMD64
Posts: 15,733

Rep: Reputation: 670Reputation: 670Reputation: 670Reputation: 670Reputation: 670Reputation: 670
Mandrake, SuSE, and Redhat use Level 3 for multiuser user with networking, and Level 5 for X11. I believe that slackware is different. A debian system may also be different.

But don't dispare. Simply read the comments in the "/etc/inittab" file. You could also read the man page:
man inittab. ( Yes, some of the configuration files like inittab and fstab have their own manpages.

Last edited by jschiwal; 10-20-2005 at 07:19 PM.
 
Old 10-20-2005, 08:40 PM   #4
JimBass
Senior Member
 
Registered: Oct 2003
Location: New York City
Distribution: Debian Sid 2.6.32
Posts: 2,100

Rep: Reputation: 49
Debian defaults to 2, but if you installed gdm, kdm, xdm it will change it's default to 5. The 5th line down in /etc/inittab is the one you want to change. Make it 2 or 3, and then you'll be in business.

Code:
# /etc/inittab: init(8) configuration.
# $Id: inittab,v 1.91 2002/01/25 13:35:21 miquels Exp $

# The default runlevel.
id:2:initdefault:
Peace,
JimBass
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Redhat linux9.0:System hangs,if gives init 3 or init 4 Sailaja Reddy Linux - Newbie 4 09-16-2004 04:19 AM
Kernal Panic: No init found. Try passing init= option to kernel raees Linux - General 12 03-19-2004 12:10 AM
error: No init found. Try passing the init= option to the Kernel neylitalo Linux - Laptop and Netbook 3 01-22-2004 10:34 PM
kernel panic, init related, found cause, but cant fix...help :) sirpelidor Linux - Software 7 12-24-2003 08:28 PM
error "Kernel panic: No init found. Try passing init= option Anauj0101 Linux - Newbie 3 05-06-2003 11:18 PM


All times are GMT -5. The time now is 01:16 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration