LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 11-23-2008, 10:11 AM   #1
stephencummings
LQ Newbie
 
Registered: Feb 2007
Posts: 4

Rep: Reputation: 0
'forwarders'


I am using SUSE Linux Server 10.
After setting up DNS to handle forwarders, I issue the command

rcnamed start

I get the following warming message:

Starting name server BIND /etc/named.d/forwarders.conf :6:'forwarders' redefined near 'forwarders'

The loopback is 127.0.0.1
The reverse arp is 0.0.127

The line that the warning message is on, is blank. So I pulled all blank lines in the .conf file and the warning message moved up to the next line. However, there is nothing wrong with the line itself. Here is the actual syntax in the named.conf

forwarders { 192.168.1.254; };

Can anyone first tell me, what is wrong and then, why the command(s) that I am using is not working.
 
Old 11-23-2008, 11:26 AM   #2
bathory
LQ Guru
 
Registered: Jun 2004
Location: Piraeus
Distribution: Slackware
Posts: 11,598

Rep: Reputation: 1532Reputation: 1532Reputation: 1532Reputation: 1532Reputation: 1532Reputation: 1532Reputation: 1532Reputation: 1532Reputation: 1532Reputation: 1532Reputation: 1532
I think that you have another "forwarders" in you named.conf. Remove it, or comment out the line that includes forwarders.conf and restart bind.
 
Old 11-23-2008, 11:51 AM   #3
stephencummings
LQ Newbie
 
Registered: Feb 2007
Posts: 4

Original Poster
Rep: Reputation: 0
Forwarders

I have researched the .conf file for that very reason and have not found any other instance of the forwarders command there.

Also, when I comment the forwarders line out, the rcnamed.conf file starts without incident. However, no forwarding takes places. I have exhausted all of my know how and have asked in other places. Any other suggestions?

Most appreciated
 
Old 11-23-2008, 01:28 PM   #4
bathory
LQ Guru
 
Registered: Jun 2004
Location: Piraeus
Distribution: Slackware
Posts: 11,598

Rep: Reputation: 1532Reputation: 1532Reputation: 1532Reputation: 1532Reputation: 1532Reputation: 1532Reputation: 1532Reputation: 1532Reputation: 1532Reputation: 1532Reputation: 1532
You can keep the forwarders line commented out and add the forwarders in the "options" part of named.conf to see what happens.
Perhaps you can understand better this, because I don't use Suse, so I cannot know how Yast configures dns.
 
Old 11-27-2008, 07:54 AM   #5
stephencummings
LQ Newbie
 
Registered: Feb 2007
Posts: 4

Original Poster
Rep: Reputation: 0
Forwarders

I found the problem to my issue with forwarders. Would like to share my results.

After reviewing the named.conf more thoroughly, that was already supplied and configured with SUSE Linux Enterprise 10, the forward first was after the forwarders command. This is how I reconfigured the named.conf.

forwarder first;
forwarders { 192.168.1.1; 172.16.1.1; };


now it works fine.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
location of email forwarders on cpanel server mjh Linux - Server 3 02-01-2012 08:50 AM
DNS forwarders not working lapthorn Linux - Networking 4 06-21-2008 02:19 PM
Getting PPP to set the forwarders for named sgmeunier Linux - Networking 4 11-23-2006 06:32 AM
BIND 9.2.3 doesn't accept ACL's in forwarders statement? Edaph Linux - Networking 1 05-15-2004 10:02 PM
DNS forwarders and A-Records fquinteros Linux - Networking 1 08-23-2003 06:12 AM


All times are GMT -5. The time now is 02:13 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration