LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices

Reply
 
Search this Thread
Old 10-03-2006, 05:12 PM   #1
Farrukh Fida
Member
 
Registered: Jun 2006
Location: Dubai
Distribution: Cent OS
Posts: 34

Rep: Reputation: 15
Angry Yahoo messenger with no proxy behind Squid


Please help.

I've configure Squid and Firewall on same machine. eth0 is my internet interface and eth1 is my Local network interface. Problem is that when I try to connect yahoo messenger with No proxies then it never sign In. And when I define my proxy it never support voice Video chat.

iptables -t nat -A PREROUTING -i eth1 -p tcp --dport 80 -j REDIRECT --to-port 8080

Is that problem due to I redirect only port 80 traffic to 8080?
Will it solve when I use following configuration?

iptables -t nat -A PREROUTING -i eth1 -p tcp --dport 80,5050,11999,5000,5001,5100 -j REDIRECT --to-port 8080

If it is okay then what setting I will use for my messenger proxy or No proxy.

Please help me.

as soon as possible
 
Old 10-03-2006, 10:33 PM   #2
Farrukh Fida
Member
 
Registered: Jun 2006
Location: Dubai
Distribution: Cent OS
Posts: 34

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by Farrukh Fida
Please help.

I've configure Squid and Firewall on same machine. eth0 is my internet interface and eth1 is my Local network interface. Problem is that when I try to connect yahoo messenger with No proxies then it never sign In. And when I define my proxy it never support voice Video chat.

iptables -t nat -A PREROUTING -i eth1 -p tcp --dport 80 -j REDIRECT --to-port 8080

Is that problem due to I redirect only port 80 traffic to 8080?
Will it solve when I use following configuration?

iptables -t nat -A PREROUTING -i eth1 -p tcp --dport 80,5050,11999,5000,5001,5100 -j REDIRECT --to-port 8080

If it is okay then what setting I will use for my messenger proxy or No proxy.

Please help me.

as soon as possible
Please help me I am trapped, I've to done this but here I need the help of you GURUs.
THANKS
 
Old 10-06-2006, 12:37 AM   #3
zamri
Member
 
Registered: May 2004
Location: Malaysia
Distribution: Mandrake,Slackware,RedHat
Posts: 157

Rep: Reputation: 30
Hi Farrukh,

try this:
Code:
iptables -t nat -A POSTROUTING -i eth1 -p tcp -m multiport --dport 5050,11999,5000,5001,5100 -j SNAT --to-source xxx.xxx.xxx.xxx
Pls note that the connection is NAT'ed via ports as above.
 
Old 10-06-2006, 01:37 AM   #4
Farrukh Fida
Member
 
Registered: Jun 2006
Location: Dubai
Distribution: Cent OS
Posts: 34

Original Poster
Rep: Reputation: 15
Dear zamri,

what address I should use for SNAT in masquerading it sets auto matically my internet nic address in my case is 192.168.0.6.

Should I use this or not?

Thanks for your reply its a new hope when I lose all my hope..
Thanks once again...and waiting for your response.
 
Old 10-06-2006, 02:03 AM   #5
hhvv
Member
 
Registered: May 2006
Location: India
Distribution: RHEL,CentOS,BSD,Ubuntu
Posts: 59
Blog Entries: 1

Rep: Reputation: 15
try this

Hi Farukh,

iptables -A FORWARD -i eth1 -p tcp -m multiport --dports 5050,11999,5000,5001,5100 -j ACCEPT
 
Old 10-06-2006, 02:12 AM   #6
Farrukh Fida
Member
 
Registered: Jun 2006
Location: Dubai
Distribution: Cent OS
Posts: 34

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by hhvv
Hi Farukh,

iptables -A FORWARD -i eth1 -p tcp -m multiport --dports 5050,11999,5000,5001,5100 -j ACCEPT
Dear I've used above(your code) configuration yesterday but no success.
 
Old 10-06-2006, 02:32 AM   #7
hhvv
Member
 
Registered: May 2006
Location: India
Distribution: RHEL,CentOS,BSD,Ubuntu
Posts: 59
Blog Entries: 1

Rep: Reputation: 15
Okay

Farukh ,
Can you describe ur N/W structure and also provide the /etc/sysconfig/iptables file
 
Old 10-06-2006, 02:33 AM   #8
hhvv
Member
 
Registered: May 2006
Location: India
Distribution: RHEL,CentOS,BSD,Ubuntu
Posts: 59
Blog Entries: 1

Rep: Reputation: 15
Ports 1024:65535

try this one also
-A INPUT -s 0.0.0.0/0 -p tcp --dport 1024:65535 -j ACCEPT
-A INPUT -s 0.0.0.0/0 -p udp --dport 1024:65535 -j ACCEPT
 
Old 10-06-2006, 03:07 AM   #9
Farrukh Fida
Member
 
Registered: Jun 2006
Location: Dubai
Distribution: Cent OS
Posts: 34

Original Poster
Rep: Reputation: 15
My problem is that I want to enable voice chat in yahoo, when i try to connect my client behind squid to yahoo messenger with following options.

1) No porxies------------->never connect(no error shown only trying for a while and then no result)

2)firewall with no proxy------------------->connected but voice chat is not enable(no option for voice chat)

3)use proxies---------------------->connected but again voice chat is not enable(no option for voice)

4)No network detection----------->again failed to connect(no fate)

I've squid and firewall running on same machine
eth1 is my LAN side and eth0 is my Internet NIC.
configurations are

iptables -t nat -A PREROUTING -i eth1 -p tcp --dport 80 \
-j REDIRECT --to-port 8080
iptables -A INPUT -j ACCEPT -m state \
--state NEW,ESTABLISHED,RELATED -i eth1 -p tcp \
--dport 8080
iptables -A OUTPUT -j ACCEPT -m state \
--state NEW,ESTABLISHED,RELATED -o eth0 -p tcp \
--dport 80
iptables -A INPUT -j ACCEPT -m state \
--state ESTABLISHED,RELATED -i eth0 -p tcp \
--sport 80
iptables -A OUTPUT -j ACCEPT -m state \
--state ESTABLISHED,RELATED -o eth1 -p tcp \
--sport 80

and in the end I am using MASQUERADING which solve my msn problem but yahoo problem still presists.


eth1 = is my LAN ip = 192.168.11.0
eht0 = is my Internet = 192.168.0.6

plz guide me thanks

Regards,
FArrukh
 
Old 10-06-2006, 03:09 AM   #10
Farrukh Fida
Member
 
Registered: Jun 2006
Location: Dubai
Distribution: Cent OS
Posts: 34

Original Poster
Rep: Reputation: 15
all these command I've written in /etc/rc.local
like
/sbin/iptables -A

plz help me

Regards,
Farrukh.
 
Old 10-06-2006, 10:32 AM   #11
hhvv
Member
 
Registered: May 2006
Location: India
Distribution: RHEL,CentOS,BSD,Ubuntu
Posts: 59
Blog Entries: 1

Rep: Reputation: 15
Have youtried this

try this one also
-A INPUT -s 0.0.0.0/0 -p tcp -i eth0 --dport 1024:65535 -j ACCEPT
-A INPUT -s 0.0.0.0/0 -p udp -i eth0 --dport 1024:65535 -j ACCEPT
 
Old 10-07-2006, 01:43 AM   #12
Farrukh Fida
Member
 
Registered: Jun 2006
Location: Dubai
Distribution: Cent OS
Posts: 34

Original Poster
Rep: Reputation: 15
Dear still no fate is Zamri idea is good ?
he sent
iptables -t nat -A POSTROUTING -i eth1 -p tcp -m multiport --dport 5050,11999,5000,5001,5100 -j SNAT --to-source xxx.xxx.xxx.xxx (192.168.0.6) in my case?
plz guide me
thanks for taking care of me
regards,
Farrukh
 
Old 10-08-2006, 04:22 AM   #13
hhvv
Member
 
Registered: May 2006
Location: India
Distribution: RHEL,CentOS,BSD,Ubuntu
Posts: 59
Blog Entries: 1

Rep: Reputation: 15
Unhappy Pls append these

-A INPUT -s 0.0.0.0/0 -p tcp -i eth0 --dport 1024:65535 -j ACCEPT
-A INPUT -s 0.0.0.0/0 -p udp -i eth0 --dport 1024:65535 -j ACCEPT
-A FORWARD -p tcp -m state --state NEW,RELATED,ESTABLISHED -j ACCEPT
 
Old 10-08-2006, 09:42 AM   #14
Farrukh Fida
Member
 
Registered: Jun 2006
Location: Dubai
Distribution: Cent OS
Posts: 34

Original Poster
Rep: Reputation: 15
Thanks for this but still no luck. I don't know where is the problem... Masquerading is also working well because if I never Masquerade then i am unable to connect MSN messenger...
What to do I try many many method but no luck....

Well thanks for your help if U have any idea then plz update me I am looking forward for ur response

Thanks,
Farrukh
 
  


Reply

Tags
behind, editing, messenger, proxy, squid, yahoo


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
using squid -blocking yahoo messenger gadekishore Linux - Software 3 08-04-2010 02:41 AM
msn messenger is not working with proxy squid Manjula.S Linux - Hardware 2 03-28-2007 08:06 AM
about squid and yahoo messenger kiranbhupathi Linux - Networking 1 07-18-2006 03:40 AM
Squid and Yahoo messenger- problem ikillu Linux - Networking 3 07-14-2005 08:50 PM
Accessing Yahoo Messenger through proxy Server thetechie_reck Linux - Networking 0 07-09-2004 01:48 AM


All times are GMT -5. The time now is 09:10 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration