LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices

Reply
 
Search this Thread
Old 08-21-2004, 02:34 PM   #1
hooprat
LQ Newbie
 
Registered: Aug 2004
Location: Thousand Oaks, CA
Distribution: Suse 9.1 Pro
Posts: 8

Rep: Reputation: 0
xwindows to Suse 9.1 Pro, isnt working


I have multiple unix/linux boxes in place in a local net.

I have a Suse 9.1 Pro Linux box w/monitor... run other UX/Linux boxes headless.

Recently changed out RH9 box to Suse 9.1 Pro. Used RH9 w/montior to operate two headless unix/linux boxes.

Since Suse 9.1... can't get xwindows on UX/Linux box(es) to chat w/Suse 9.1.

Process today:

boot both HP/UX 11.11 and Suse 9.1

login to Suse 9.1
telnet & login to HP/UX 11.11 or RH Linux box (either one).

from telnet window:
export DISPLAY=suse91:0.0 from either HP/UX or RH Linux
xclock &

Result:
Error: Can't open display: suse91:0.0

Believe the problem is Suse 9.1 firewall... but a cursory review of the firewall status from Contol Ctr, indicates that the firewall is 'not enabled'.

X-windows is fine on Suse91. Locally xeyes/xclock operate as expected.

Any ideas?

Please advise.

TIA!
<MV>
 
Old 08-21-2004, 02:59 PM   #2
david_ross
Moderator
 
Registered: Mar 2003
Location: Scotland
Distribution: Slackware, RedHat, Debian
Posts: 12,047

Rep: Reputation: 64
You can check your firewall ruels with:
iptables -nL

Everything should be set to ACCEPT without any other rules between. You may also want to try running:
xhost +

On the suse box to allow other boxes to connect.

I assume you have entries in the hosts file of the clients that point "suse91" to the ip address of the suse box?
 
Old 08-21-2004, 03:12 PM   #3
hooprat
LQ Newbie
 
Registered: Aug 2004
Location: Thousand Oaks, CA
Distribution: Suse 9.1 Pro
Posts: 8

Original Poster
Rep: Reputation: 0
david_ross:
Thanks for the quick response....

Yes.... 'xhost +' is manually entered at the suse91 system.
hoopcoach =suse91
manuel@hoopcoach:~> xhost +
access control disabled, clients can connect from any host

I've included the iptables response below:
hoopcoach =suse91

hoopcoach:~ # /usr/sbin/iptables -nL
Chain INPUT (policy ACCEPT)
target prot opt source destination

Chain FORWARD (policy ACCEPT)
target prot opt source destination

Chain OUTPUT (policy ACCEPT)
target prot opt source destination

Thanks again!
<HoopRat>
 
Old 08-21-2004, 03:18 PM   #4
david_ross
Moderator
 
Registered: Mar 2003
Location: Scotland
Distribution: Slackware, RedHat, Debian
Posts: 12,047

Rep: Reputation: 64
What about this?
Quote:
Originally posted by david_ross
I assume you have entries in the hosts file of the clients that point "suse91" to the ip address of the suse box?
Try using the ip address given from "ifconfig eth0" on the suse box in the export command rather than "suse91".
 
Old 08-21-2004, 04:22 PM   #5
hooprat
LQ Newbie
 
Registered: Aug 2004
Location: Thousand Oaks, CA
Distribution: Suse 9.1 Pro
Posts: 8

Original Poster
Rep: Reputation: 0
david_ross:

Thanks again for the idea and the quick response.

I've listed the ifconfig from the Suse box:
manuel@hoopcoach:~> /sbin/ifconfig
eth0 Link encap:Ethernet HWaddr 00:E0:29:68:1E:FD
inet addr:10.20.40.20 Bcast:10.20.40.255 Mask:255.255.255.0
inet6 addr: fe80::2e0:29ff:fe68:1efd/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:14624 errors:0 dropped:0 overruns:0 frame:0
TX packets:23133 errors:0 dropped:0 overruns:0 carrier:0
collisions:337 txqueuelen:1000
RX bytes:21240572 (20.2 Mb) TX bytes:1547957 (1.4 Mb)
Interrupt:9 Base address:0xf00

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:86 errors:0 dropped:0 overruns:0 frame:0
TX packets:86 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:5364 (5.2 Kb) TX bytes:5364 (5.2 Kb)

Here is the ifconfig from the linux box I'm testing w/today.
[root@de100cEE1923 /root]$ uname -a
Linux de100cEE1923.lan 2.4.7-17emso #36 Tue Oct 9 15:09:28 PDT 2001 i686 unknown
[root@de100cEE1923 /root]$ ifconfig
eth0 Link encap:Ethernet HWaddr 00:01:0A:11:4A:85
inet addr:10.20.40.25 Bcast:10.20.40.255 Mask:255.255.255.0
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:140511 errors:0 dropped:0 overruns:0 frame:0
TX packets:87927 errors:0 dropped:0 overruns:0 carrier:0
collisions:1851 txqueuelen:100
Interrupt:11 Base address:0xd000

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:434 errors:0 dropped:0 overruns:0 frame:0
TX packets:434 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0

Here is the new display setting as you suggested:
[root@de100cEE1923 /root]$ echo $DISPLAY
10.20.40.20:0

Result: (Looks like the same)
[root@de100cEE1923 /root]$ xclock &
[1] 4352
[root@de100cEE1923 /root]$ Error: Can't open display: 10.20.40.20:0

There is a delay between the receipt of the command (xclock) and the result. About 2 minutes. I'm playing w/firewall settings as I write.

Thanks again!
<HoopRat>
 
Old 08-21-2004, 04:36 PM   #6
david_ross
Moderator
 
Registered: Mar 2003
Location: Scotland
Distribution: Slackware, RedHat, Debian
Posts: 12,047

Rep: Reputation: 64
Your firewall is set to accept all connections so I doubt that is your problem.

Check that your X server is listening to port 6000 on the suse box:
netstat -nlp

Maybe is using an alternate display number/port
 
Old 08-21-2004, 04:57 PM   #7
hooprat
LQ Newbie
 
Registered: Aug 2004
Location: Thousand Oaks, CA
Distribution: Suse 9.1 Pro
Posts: 8

Original Poster
Rep: Reputation: 0
david_ross:
Again... thx for the feedback:

entered command.... see below:
(This is Suse9.1 Box)
manuel@hoopcoach:~> netstat -nip
Kernel Interface table
Iface MTU Met RX-OK RX-ERR RX-DRP RX-OVR TX-OK TX-ERR TX-DRP TX-OVR Flg
eth0 1500 0 23814 0 0 0 37631 0 0 0 BMRU
lo 16436 0 74 0 0 0 74 0 0 0 LRU

PS have disabled/shutdown FW.... no change! Yikes!
 
Old 08-22-2004, 03:45 AM   #8
david_ross
Moderator
 
Registered: Mar 2003
Location: Scotland
Distribution: Slackware, RedHat, Debian
Posts: 12,047

Rep: Reputation: 64
NLP rather than NIP in lower case

-i shows the interfaces
-l shows the listening sockets
 
Old 08-23-2004, 01:40 PM   #9
hooprat
LQ Newbie
 
Registered: Aug 2004
Location: Thousand Oaks, CA
Distribution: Suse 9.1 Pro
Posts: 8

Original Poster
Rep: Reputation: 0
david_ross:

Sorry about the typo!

Please see the new result:
manuel@hoopcoach:~> netstat -nlp
(Not all processes could be identified, non-owned process info
will not be shown, you would have to be root to see it all.)
Active Internet connections (only servers)
Proto Recv-Q Send-Q Local Address Foreign Address State PID/Program name
tcp 0 0 0.0.0.0:111 0.0.0.0:* LISTEN -
tcp 0 0 0.0.0.0:631 0.0.0.0:* LISTEN -
tcp 0 0 127.0.0.1:25 0.0.0.0:* LISTEN -
tcp 0 0 :::5800 :::* LISTEN 5663/kdeinit: kded
tcp 0 0 :::5900 :::* LISTEN 5663/kdeinit: kded
tcp 0 0 :::22 :::* LISTEN -
tcp 0 0 ::1:25 :::* LISTEN -
udp 0 0 0.0.0.0:111 0.0.0.0:* -
udp 0 0 0.0.0.0:631 0.0.0.0:* -
Active UNIX domain sockets (only servers)
Proto RefCnt Flags Type State I-Node PID/Program name Path
unix 2 [ ACC ] STREAM LISTENING 7302 5631/kdeinit: Runni /tmp/ksocket-manuel/kdeinit__0
unix 2 [ ACC ] STREAM LISTENING 5720 - /var/run/.nscd_socket
unix 2 [ ACC ] STREAM LISTENING 7540 5705/artsd /tmp/mcop-manuel/hoopcoach_hooprat_org-1649-412a1104
unix 2 [ ACC ] STREAM LISTENING 7304 5631/kdeinit: Runni /tmp/ksocket-manuel/kdeinit-:0
unix 2 [ ACC ] STREAM LISTENING 5885 - /tmp/.X11-unix/X0
unix 2 [ ACC ] STREAM LISTENING 6032 - public/cleanup
unix 2 [ ACC ] STREAM LISTENING 7882 5736/xmms /tmp/xmms_manuel.0
unix 2 [ ACC ] STREAM LISTENING 4076 - /var/run/.resmgr_socket
unix 2 [ ACC ] STREAM LISTENING 6039 - private/rewrite
unix 2 [ ACC ] STREAM LISTENING 6043 - private/bounce
unix 2 [ ACC ] STREAM LISTENING 7312 5634/kdeinit: dcops /tmp/.ICE-unix/dcop5634-1093275900
unix 2 [ ACC ] STREAM LISTENING 6047 - private/defer
unix 2 [ ACC ] STREAM LISTENING 6051 - private/trace
unix 2 [ ACC ] STREAM LISTENING 6055 - private/verify
unix 2 [ ACC ] STREAM LISTENING 6059 - public/flush
unix 2 [ ACC ] STREAM LISTENING 6063 - private/proxymap
unix 2 [ ACC ] STREAM LISTENING 6067 - private/smtp
unix 2 [ ACC ] STREAM LISTENING 6071 - private/relay
unix 2 [ ACC ] STREAM LISTENING 6075 - public/showq
unix 2 [ ACC ] STREAM LISTENING 6079 - private/error
unix 2 [ ACC ] STREAM LISTENING 6083 - private/local
unix 2 [ ACC ] STREAM LISTENING 6087 - private/virtual
unix 2 [ ACC ] STREAM LISTENING 6091 - private/lmtp
unix 2 [ ACC ] STREAM LISTENING 6095 - private/anvil
unix 2 [ ACC ] STREAM LISTENING 6099 - private/maildrop
unix 2 [ ACC ] STREAM LISTENING 6103 - private/cyrus
unix 2 [ ACC ] STREAM LISTENING 6107 - private/uucp
unix 2 [ ACC ] STREAM LISTENING 7354 5651/kdeinit: klaun /tmp/ksocket-manuel/klauncher5lIWYb.slave-socket
unix 2 [ ACC ] STREAM LISTENING 6111 - private/ifmail
unix 2 [ ACC ] STREAM LISTENING 7628 5710/kdeinit: ksmse /tmp/.ICE-unix/5710
unix 2 [ ACC ] STREAM LISTENING 7267 5605/ssh-agent /tmp/ssh-XNOJCu5570/agent.5570
unix 2 [ ACC ] STREAM LISTENING 6115 - private/bsmtp
unix 2 [ ACC ] STREAM LISTENING 6119 - private/vscan
unix 2 [ ACC ] STREAM LISTENING 6123 - private/procmail
unix 2 [ ACC ] STREAM LISTENING 4682 - /var/run/powersave_socket

Hope this helps.

Thanks again!
<MV>
 
Old 08-23-2004, 01:47 PM   #10
hooprat
LQ Newbie
 
Registered: Aug 2004
Location: Thousand Oaks, CA
Distribution: Suse 9.1 Pro
Posts: 8

Original Poster
Rep: Reputation: 0
Noticed this from /etc/services:
# Randall Atkinson <rja@inet.org>
# x11 6000-6063/tcp X Window System
# x11 6000-6063/udp X Window System

looks like I'm commented.

<MV>
 
Old 08-23-2004, 02:33 PM   #11
hooprat
LQ Newbie
 
Registered: Aug 2004
Location: Thousand Oaks, CA
Distribution: Suse 9.1 Pro
Posts: 8

Original Poster
Rep: Reputation: 0
Found this URL:
http://lists.suse.com/archives/suse-...-Jul/2101.html

Followed instructions... and can now operate as before.

Thanks for your help!

<MV>
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
YaST isnt working DickH Suse/Novell 19 06-12-2006 12:22 AM
Multi-OS is that why it isnt working??? CiscoNinja Linux - Newbie 8 10-01-2005 07:05 PM
isnt yum preconfigured in red hat pro 9? boxerboy Red Hat 4 09-28-2005 09:44 AM
Sound Isnt Working LinuxNoob1234 Linux - Newbie 8 05-07-2005 12:51 AM
Network isnt working right roger.k Linux - Newbie 2 08-11-2004 06:33 PM


All times are GMT -5. The time now is 06:48 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration