LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices

Reply
 
Search this Thread
Old 04-14-2005, 12:32 AM   #1
overheadcam
LQ Newbie
 
Registered: Apr 2005
Posts: 4

Rep: Reputation: 0
wpa_supplicant and ipw2100 problems in SUSE 9.2


So far I've been able to figure out how to get SUSE 9.2 up and running with all my hardware, (thanks to the search function on these forums) but this one is stumping me. Really stumping me. I've been using my Latitude D800 with no problems with an Intel Pro Wireless 2100 using WEP. Since WEP is so easily crackable now, I upgraded to a router that supports WPA. I've used YaST to add wpa_supplicant and set my PSK (so I don't screw up anything) but for some reason I cannot connect to my router. I can see it if I scan, and evidently authenticate with it, but no connection is established, and I don't get an IP. I do get the message in wpa_cli:

WPA: Key negotiation completed with (mac address of router)
WPA: Key negotiation completed with (mac address of router)
WPA: Key negotiation completed with (mac address of router)
repeat forever

Also, my wireless network activity applet shows a green bar for 4 seconds, dead for half a second, then solid green again for 4 seconds, dead again, rinse, repeat.

WEP and unencrypted both work fine, and Windows can use WPA with no problems, so I know it's not the hardware. This is the only thing keeping me from using Linux at home full time.

Thanks in advance,
-Cam
 
Old 04-14-2005, 12:17 PM   #2
overheadcam
LQ Newbie
 
Registered: Apr 2005
Posts: 4

Original Poster
Rep: Reputation: 0
I'm an idiot. Sorry everyone. Could a mod please move this to "Linux Wireless Networking?"
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
suse 9.3 wpa_supplicant dhcp sabeltann Linux - Wireless Networking 6 09-21-2005 04:28 AM
Wpa_supplicant Problems Plz Help! scorpio1883 Linux - Wireless Networking 0 07-28-2005 03:25 AM
wpa_supplicant and ipw2100 problems in SUSE 9.2 overheadcam Linux - Wireless Networking 1 04-19-2005 01:08 PM
wpa_supplicant problems maddoggames Linux - Wireless Networking 2 01-22-2005 04:36 PM
Problems using Wpa_supplicant and linuxant Oostertoaster Linux - Wireless Networking 0 08-03-2004 08:01 AM


All times are GMT -5. The time now is 03:30 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration