LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Networking (http://www.linuxquestions.org/questions/linux-networking-3/)
-   -   WOL is not working after a software power off (http://www.linuxquestions.org/questions/linux-networking-3/wol-is-not-working-after-a-software-power-off-719354/)

marozsas 04-15-2009 01:26 PM

WOL is not working after a software power off
 
When in my Fedora 10 I power off the system, by using the gnome icon or even the command line "poweroff", it shut down the machine and power off it as expected - EVEN THE NIC. I can see its led is off !
This happens when I put the machine in hibernate mode too, but not in suspend mode.

When I power on and and power off it just after the POST messages, when grub is waiting a key to select an option, I can see the NIC's led is still blinking at each second or so.

When I power on the machine and select windows (dual boot system) and then power it off, it power off as expected, I mean, it leaves the NIC on - the led blinks even with the machine powered off.

As result, I can't wake up my machine remotely by using Wakeup-On-Lan since the NIC is powered off by Fedora.

There is a way to control this, or a work around ?
Do you think I must post a bug report on kernel list ?

grepmasterd 04-15-2009 02:31 PM

see

http://www.linuxquestions.org/questi...6/#post3464411

check the search details against your kernel version (uname -r)

marozsas 04-17-2009 09:35 AM

Thank you grepmasterd !

Yes, it is not a kernel bug, but a "feature" of network driver.
Looks like the network driver does not check the BIOS information about WOL and always initialize the NIC with WOL disabled.

Not a big problem at all. A simple "ethtool eth0 -s wol g" at boot time enable wol again.
In fact, in Fedora 10, just putting ETHTOOL_OPTS="wol g" on /etc/sysconfig/network-scripts/ifcfg-eth0 would do the trick.

thanks,

sipu123 07-14-2009 06:00 AM

hello i have applied these changes and WOL is working fine when i used it to wake my machine from turn off mode....

But it is not working when i switches my machine to sleep mode. My machine is not responding to magic packet sent , if it is in sleep mode. Also this all happens with ubuntu only .....If i go to sleep mode through Windows 7 ultimate. Then my machine can detect the magic packet and resume all the state of machine as earlier.

Can WOL for sleep/suspend/hibernate is possible in ubuntu......if yes do we require some more changes and what are those changes required.

please reply.

aurora72 10-27-2009 04:18 AM

Quote:

Originally Posted by sipu123 (Post 3607077)
hello i have applied these changes and WOL is working fine when i used it to wake my machine from turn off mode....

But it is not working when i switches my machine to sleep mode. My machine is not responding to magic packet sent , if it is in sleep mode. Also this all happens with ubuntu only...

I experience exactly the same problem with Ubuntu 9.04 on my 2002 make IBM Thinkpad:

When I turn off Ubuntu WOL works, (the led on the ethernet is on)
but when I put it to sleep mode, WOL just doesn't work (the led on the ethernet jack is off)

Any suggestions?


All times are GMT -5. The time now is 02:44 AM.