LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices

Reply
 
Search this Thread
Old 11-04-2010, 08:11 PM   #1
xp_newbie
Member
 
Registered: Nov 2006
Posts: 86

Rep: Reputation: 16
Question WOL doesn't work on my Ubuntu 8.04 system


I followed the instructions at http://ubuntuforums.org/showthread.php?t=360901 to be able to turn or my Ubuntu 8.04 workstation remotely. This is what I did on my workstation:

1. Enabled WOL in BIOS for ethernet adapter 0.
2. 'sudo ethtool eth' yielded "Supports Wake-on: pumbg" -- good!
3. ethtool -s eth0 wol g
4. 'sudo gedit /etc/rc.local' to add the following line before 'exit 0':
ethtool -s eth0 wol g
5. sudo shutdown -h -P now

I then tried (several times) to to turn the system on from a remote laptop (on the same subnet!) using the magic packet method.

Nothing happens (i.e. it doesn't turn on).

I tried a few more times to turn it on from the DD-WRT (on the same subnet).

Nothing happens (i.e. it doesn't turn on).

Any idea how to troubleshoot this and why it wouldn't work?

My workstation's ethernet, BTW, is controlled by an onboard Realtek RTL8110SC (part of the ABIT IP35 Pro motherboard).

Also, if this helps, here is the output of the command 'sudo ethtool eth0':
Code:
Settings for eth0:
        Supported ports: [ TP ]
        Supported link modes:   10baseT/Half 10baseT/Full 
                                100baseT/Half 100baseT/Full 
                                1000baseT/Full 
        Supports auto-negotiation: Yes
        Advertised link modes:  10baseT/Half 10baseT/Full 
                                100baseT/Half 100baseT/Full 
                                1000baseT/Full 
        Advertised auto-negotiation: Yes
        Speed: 100Mb/s
        Duplex: Full
        Port: Twisted Pair
        PHYAD: 0
        Transceiver: internal
        Auto-negotiation: on
        Supports Wake-on: pumbg
        Wake-on: g
        Current message level: 0x00000033 (51)
        Link detected: yes
Any tip, insight or advice would be greatly appreciated.

Thanks.
 
Old 11-05-2010, 01:18 PM   #2
Amdx2_x64
Member
 
Registered: Jun 2008
Distribution: Left LQ. Mods are too Rude!
Posts: 598

Rep: Reputation: 50
Ubuntu 10.* (even 9.*) has much better support for remote access. Would you be able to upgrade?
 
Old 11-05-2010, 01:22 PM   #3
xp_newbie
Member
 
Registered: Nov 2006
Posts: 86

Original Poster
Rep: Reputation: 16
Quote:
Originally Posted by Amdx2_x64 View Post
Ubuntu 10.* (even 9.*) has much better support for remote access. Would you be able to upgrade?
Not really as this is my stable development system with expensive development tools that can run on Ubuntu 8 only.

Also, I had no problems using WOL on an older Ubuntu 6.06 system, so I don't think the OS version is the issue.

I just need to troubleshoot this. Any ideas?
 
Old 11-05-2010, 05:29 PM   #4
Amdx2_x64
Member
 
Registered: Jun 2008
Distribution: Left LQ. Mods are too Rude!
Posts: 598

Rep: Reputation: 50
Quote:
Originally Posted by xp_newbie View Post
Not really as this is my stable development system with expensive development tools that can run on Ubuntu 8 only.

Also, I had no problems using WOL on an older Ubuntu 6.06 system, so I don't think the OS version is the issue.

I just need to troubleshoot this. Any ideas?

Not sure, sorry.
 
Old 11-05-2010, 06:34 PM   #5
eSelix
Senior Member
 
Registered: Oct 2009
Location: Wroclaw, Poland
Distribution: Arch, Kubuntu
Posts: 1,218

Rep: Reputation: 307Reputation: 307Reputation: 307Reputation: 307
1) Check that led on net card is still light after powering computer off.
2) Check status (ethtool eth0) after bringing interface down (ifdown eth0) if it has still "Wake-on: g"

Last edited by eSelix; 11-05-2010 at 06:40 PM.
 
Old 11-07-2010, 08:52 AM   #6
xp_newbie
Member
 
Registered: Nov 2006
Posts: 86

Original Poster
Rep: Reputation: 16
Question

eSelix, thanks so much for your expert guidance. Here are my answers:

Quote:
Originally Posted by eSelix View Post
1) Check that led on net card is still light after powering computer off.
The LED is OFF. It seems that this is where the problem lies. Any idea how to fix this?

Quote:
Originally Posted by eSelix View Post
2) Check status (ethtool eth0) after bringing interface down (ifdown eth0) if it has still "Wake-on: g"
Yes, after bringing the interface down, it still has "Wake-on: g".
 
Old 11-07-2010, 09:19 AM   #7
xp_newbie
Member
 
Registered: Nov 2006
Posts: 86

Original Poster
Rep: Reputation: 16
Lightbulb

Quote:
Originally Posted by xp_newbie View Post
The LED is OFF. It seems that this is where the problem lies. Any idea how to fix this?
This is seems like a motherboard issue, not a Linux one. My mainboard's BIOS version is 14 where the latest BIOS update 17 addresses a WOL issue: "Fixed the Wake Up by WAKE# of PCIe function abnormality."

I learned about this through a similar post in another forum, all thanks to eSelix. Thank you eSelix.

After I update the BIOS and test this functionality again, I will report back whether this solved the problem.
 
Old 11-07-2010, 08:04 PM   #8
xp_newbie
Member
 
Registered: Nov 2006
Posts: 86

Original Poster
Rep: Reputation: 16
Arrow

Quote:
Originally Posted by xp_newbie View Post
After I update the BIOS and test this functionality again, I will report back whether this solved the problem.
Update: Updating the BIOS from ver. 14 to ver. 17 didn't solve the problem.

That is, the green LED is still OFF when the PC is turned off.

It's unlikely that it's a Linux problem but if you know how to solve this problem or can recommend a forum that is most appropriate for such problems, that would be much appreciated.

Thanks.
 
Old 11-08-2010, 03:27 AM   #9
eSelix
Senior Member
 
Registered: Oct 2009
Location: Wroclaw, Poland
Distribution: Arch, Kubuntu
Posts: 1,218

Rep: Reputation: 307Reputation: 307Reputation: 307Reputation: 307
I also had problems with WoL in Ubuntu 8.10, but do not remember what I am did. This can be also kernel problem. What is your version? You can check in BIOS if you have enabled options to wakeup on events like PCI, PCIe... check all to enable for testing.
 
Old 11-08-2010, 08:29 AM   #10
xp_newbie
Member
 
Registered: Nov 2006
Posts: 86

Original Poster
Rep: Reputation: 16
Arrow

Quote:
Originally Posted by eSelix View Post
This can be also kernel problem. What is your version?
Are you sure it's not a motherboard/BIOS only problem? My Linux version is:
Code:
Linux XP 2.6.24-22-generic #1 SMP Mon Nov 24 19:35:06 UTC 2008 x86_64 GNU/Linux

Quote:
Originally Posted by eSelix View Post
You can check in BIOS if you have enabled options to wakeup on events like PCI, PCIe... check all to enable for testing.
I just checked all for testing as you said:
Code:
ACPI Suspend Type           S3 (Suspend-to-RAM)
- Resume by USB from S3     Enabled
Power Button Function       [Delay 4 Sec.]
Wake Up by WAKE# of PCIe    Enabled
Wake Up by PME# of PCI      Enabled
Wake Up by Onboard LAN1     Enabled
Wake Up by Onboard LAN2     Enabled
POWER ON Function           [Hot KEY]
- Hot Key Power ON          Ctrl-F1
Restore on AC Power Loss    Power Off
And the green LED would still turn OFF when a soft shutdown is performed. The Power ON via keyboard's hot key works perfectly, so I know that the motherboard's circuits are "listening" even when the computer is not in suspend/hibernate mode.

The only challenge now is to how to make the NIC's circuits listen...
 
Old 11-08-2010, 04:05 PM   #11
eSelix
Senior Member
 
Registered: Oct 2009
Location: Wroclaw, Poland
Distribution: Arch, Kubuntu
Posts: 1,218

Rep: Reputation: 307Reputation: 307Reputation: 307Reputation: 307
Which network driver are you using? I am using 'forcedeth', and 'modinfo' give me that:
Quote:
parm: phy_power_down:Power down phy and disable link when interface is down (1), or leave phy powered up (0). (int)
So this driver has a parameter, to control of powering network card. Maybe your driver also have such this parameter. I didn't changing that, I think this is set to '0' by default.
 
Old 11-11-2010, 09:33 AM   #12
xp_newbie
Member
 
Registered: Nov 2006
Posts: 86

Original Poster
Rep: Reputation: 16
Question

Quote:
Originally Posted by eSelix View Post
Which network driver are you using?
How can I tell which network driver I am using?

I did 'lsmod', it lists 93 modules (!) but I couldn't find a network module that can I use as a parameter for 'modinfo'. This is weird.
 
Old 11-11-2010, 03:54 PM   #13
eSelix
Senior Member
 
Registered: Oct 2009
Location: Wroclaw, Poland
Distribution: Arch, Kubuntu
Posts: 1,218

Rep: Reputation: 307Reputation: 307Reputation: 307Reputation: 307
Quote:
Originally Posted by xp_newbie View Post
How can I tell which network driver I am using?
Try:
Code:
dmesg | grep -E 'eth|net'
 
Old 11-11-2010, 09:36 PM   #14
xp_newbie
Member
 
Registered: Nov 2006
Posts: 86

Original Poster
Rep: Reputation: 16
Arrow

Quote:
Originally Posted by eSelix View Post
Try:
dmesg | grep -E 'eth|net'
OK, this generated many lines but I think that I was able to spot the network with this weird name (that's why I couldn't find it): r8169.

'modinfo r8169' yields:
Code:
filename:       /lib/modules/2.6.24-22-generic/kernel/drivers/net/r8169.ko
version:        2.2LK
license:        GPL
description:    RealTek RTL-8169 Gigabit Ethernet driver
author:         Realtek and the Linux r8169 crew <netdev@vger.kernel.org>
srcversion:     43B14ECBCCE4F7FF1A8D77E
alias:          pci:v00000001d00008168sv*sd00002410bc*sc*i*
alias:          pci:v00001737d00001032sv*sd00000024bc*sc*i*
alias:          pci:v000016ECd00000116sv*sd*bc*sc*i*
alias:          pci:v00001259d0000C107sv*sd*bc*sc*i*
alias:          pci:v00001186d00004300sv*sd*bc*sc*i*
alias:          pci:v000010ECd00008169sv*sd*bc*sc*i*
alias:          pci:v000010ECd00008168sv*sd*bc*sc*i*
alias:          pci:v000010ECd00008167sv*sd*bc*sc*i*
alias:          pci:v000010ECd00008136sv*sd*bc*sc*i*
alias:          pci:v000010ECd00008129sv*sd*bc*sc*i*
depends:        
vermagic:       2.6.24-22-generic SMP mod_unload 
parm:           rx_copybreak:Copy breakpoint for copy-only-tiny-frames (int)
parm:           use_dac:Enable PCI DAC. Unsafe on 32 bit PCI slot. (int)
parm:           debug:Debug verbosity level (0=none, ..., 16=all) (int)
Interesting.
 
Old 11-12-2010, 05:40 AM   #15
eSelix
Senior Member
 
Registered: Oct 2009
Location: Wroclaw, Poland
Distribution: Arch, Kubuntu
Posts: 1,218

Rep: Reputation: 307Reputation: 307Reputation: 307Reputation: 307
I have this driver on other PC, so I check WoL functionality on it tonight.
 
  


Reply

Tags
ubuntu, wol


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
HOWTO: Make "Wake on LAN" (WOL) Work tredegar Linux - Networking 6 02-26-2011 07:23 AM
Acer revo 3610 (ubuntu 9.10)- WOL not working rflores2323 Linux - Networking 3 12-26-2010 05:30 AM
Ubuntu Partition does not work on Multi System PC countrydance Linux - Desktop 2 10-15-2008 02:03 PM
ubuntu - Linksys LNE100TX v4 WOL moneyshotz Linux - Networking 2 06-02-2008 10:58 AM
wol for e100 driver doen't work under 2.6.x lunatic fringe Linux - Networking 0 01-10-2005 04:27 AM


All times are GMT -5. The time now is 02:45 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration