LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Networking (http://www.linuxquestions.org/questions/linux-networking-3/)
-   -   Wireless Tools doesn't refresh APs properly (http://www.linuxquestions.org/questions/linux-networking-3/wireless-tools-doesnt-refresh-aps-properly-789688/)

shibeaux 02-17-2010 06:25 AM

Wireless Tools doesn't refresh APs properly
 
Hi everybody!

I need to monitorize which Wi-Fi APs are in coverage, so periodically I perform a scan whith "sudo iwlist ath0 scan". The problem appears when disconnecting an AP (from the electrical network). In this case, iwconfig shows the disconnected AP during 30-40 seconds after the disconnection.

I'm trying to figure out how to order the kernel to actually refresh the list of in coverage APs, and avoid to show nets that were in coverage but aren't now.

Hope you can help me!

nimnull22 02-18-2010 02:46 PM

Quote:

Originally Posted by shibeaux (Post 3866744)
Hi everybody!

I need to monitorize which Wi-Fi APs are in coverage, so periodically I perform a scan whith "sudo iwlist ath0 scan". The problem appears when disconnecting an AP (from the electrical network). In this case, iwconfig shows the disconnected AP during 30-40 seconds after the disconnection.

I'm trying to figure out how to order the kernel to actually refresh the list of in coverage APs, and avoid to show nets that were in coverage but aren't now.

Hope you can help me!

Does iwconfig show the disconnected AP during 30-40 seconds after the disconnection or iwlist?

shibeaux 02-22-2010 06:07 AM

Sorry, I wrote iwconfig instead of iwlist.

The problem could be related to some driver cache that stores the list of APs in coverage, but i'm unable to figure out how to refresh it.

Any ideas?


All times are GMT -5. The time now is 11:51 PM.