LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices

Reply
 
Search this Thread
Old 04-20-2010, 04:01 PM   #1
noviciado
Member
 
Registered: Feb 2009
Distribution: Slackware 13.0 (2.6.29.6-smp)
Posts: 47

Rep: Reputation: 15
Wireless issues -- no network on wicd


Hello,

I've been using Slackware 13 without a problem for several months now, and the wireless card suddenly went undetected for no apparent reason. I switched pci slots and kept rebooting, checking with lspci, but it continued to be undetected. Without changing anything, other than giving up for the night, I rebooted the next day, and it was once again detected, though failing to connect to the wireless network.
I'm not sure if this is a sign of hardware issue or not..

here's some output:

lspci -nn
Code:
03:00.0 Network controller [0280]: RaLink RT2561/RT61 802.11g PCI [1814:0301]
ifconfig
Code:
wlan0     Link encap:Ethernet  HWaddr 00:1f:1f:1b:33:9b  
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)
iwlist scan
Code:
wlan0     No scan results
lshw
Code:
  *-network:0
       description: Wireless interface
       product: RT2561/RT61 802.11g PCI
       vendor: RaLink
       physical id: 0
       bus info: pci@0000:03:00.0
       logical name: wmaster0
       version: 00
       serial: 00:1f:1f:1b:33:9b
       width: 32 bits
       clock: 33MHz
       capabilities: pm bus_master cap_list logical ethernet physical wireless
       configuration: broadcast=yes driver=rt61pci latency=64 module=rt61pci multicast=yes wireless=IEEE 802.11bg
  *-network:1
       description: Ethernet interface
       product: 82562ET/EZ/GT/GZ - PRO/100 VE (LOM) Ethernet Controller
       vendor: Intel Corporation
       physical id: 8
       bus info: pci@0000:03:08.0
       logical name: eth0
       version: 03
       serial: 00:13:20:43:f2:60
       size: 10MB/s
       capacity: 100MB/s
       width: 32 bits
       clock: 33MHz
       capabilities: pm bus_master cap_list ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=e100 driverversion=3.5.23-k6-NAPI duplex=half firmware=N/A latency=64 link=no maxlatency=56 mingnt=8 module=e100 multicast=yes port=MII speed=10MB/s
I was originally using /etc/rc.d/rc.inet1.conf for my wireless configuration, but commented this out and tried wicd. no networks are detected (but I can confirm the network is up on another computer). I also tried booting debian from a live disk, but couldn't get things working there either.

I made sure wireless was detecting wlan0 in wicd and added my user to group netdev.

Thanks for reading. Any suggestions welcome.

**EDIT**
I just noticed the wireless networking subforum..
Thanks in advance if a moderator reads this and is able to move the post.

Last edited by noviciado; 04-20-2010 at 05:27 PM.
 
Old 04-20-2010, 05:57 PM   #2
nimnull22
Senior Member
 
Registered: Jul 2009
Distribution: OpenSuse 11.1, Fedora 14, Ubuntu 12.04/12.10, FreeBSD 9.0
Posts: 1,571

Rep: Reputation: 92
What will be an output of next commands:
ifdown wlan0
ifup wlan0

and after
dmesg | tail -n 20

Thanks
 
Old 04-20-2010, 08:51 PM   #3
noviciado
Member
 
Registered: Feb 2009
Distribution: Slackware 13.0 (2.6.29.6-smp)
Posts: 47

Original Poster
Rep: Reputation: 15
hm, I have no ifup/ifdown, but I assume ifconfig wlan0 up/down is what you're after?

Code:
bash-3.1# ifconfig wlan0 up
bash-3.1# ifconfig wlan0 down
bash-3.1# dmesg | tail -n 20
/dev/vmnet: open called by PID 3429 (vmnet-netifup)
/dev/vmnet: port on hub 1 successfully opened
/dev/vmnet: open called by PID 3432 (vmnet-dhcpd)
/dev/vmnet: hub 8 does not exist, allocating memory.
/dev/vmnet: port on hub 8 successfully opened
/dev/vmnet: open called by PID 3436 (vmnet-natd)
/dev/vmnet: port on hub 8 successfully opened
/dev/vmnet: open called by PID 3437 (vmnet-netifup)
/dev/vmnet: port on hub 8 successfully opened
/dev/vmnet: open called by PID 3420 (vmnet-bridge)
/dev/vmnet: hub 0 does not exist, allocating memory.
/dev/vmnet: port on hub 0 successfully opened
bridge-eth0: up
ADDRCONF(NETDEV_UP): eth0: link is not ready
bridge-eth0: attached
bridge-eth0: disabling the bridge
bridge-eth0: down
bridge-eth0: detached
vmnet1: no IPv6 routers present
vmnet8: no IPv6 routers present
 
Old 04-20-2010, 09:06 PM   #4
nimnull22
Senior Member
 
Registered: Jul 2009
Distribution: OpenSuse 11.1, Fedora 14, Ubuntu 12.04/12.10, FreeBSD 9.0
Posts: 1,571

Rep: Reputation: 92
Very interesting.
Can you please, type in root console:
ip link set wlan0 up

and then:

ip link show

Post output please.
 
Old 04-20-2010, 09:26 PM   #5
noviciado
Member
 
Registered: Feb 2009
Distribution: Slackware 13.0 (2.6.29.6-smp)
Posts: 47

Original Poster
Rep: Reputation: 15
Code:
bash-3.1# ip link set wlan0 up
bash-3.1# ip link show
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 16436 qdisc noqueue state UNKNOWN 
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
2: eth0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc pfifo_fast state DOWN qlen 1000
    link/ether 00:13:20:43:f2:60 brd ff:ff:ff:ff:ff:ff
3: wmaster0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UNKNOWN qlen 1000
    link/ieee802.11 00:1f:1f:1b:33:9b brd ff:ff:ff:ff:ff:ff
4: wlan0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc pfifo_fast state DOWN qlen 1000
    link/ether 00:1f:1f:1b:33:9b brd ff:ff:ff:ff:ff:ff
5: vmnet1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UNKNOWN qlen 1000
    link/ether 00:50:56:c0:00:01 brd ff:ff:ff:ff:ff:ff
6: vmnet8: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UNKNOWN qlen 1000
    link/ether 00:50:56:c0:00:08 brd ff:ff:ff:ff:ff:ff
 
Old 04-24-2010, 02:10 AM   #6
noviciado
Member
 
Registered: Feb 2009
Distribution: Slackware 13.0 (2.6.29.6-smp)
Posts: 47

Original Poster
Rep: Reputation: 15
anyone have an idea about the problem from all this output?
 
Old 04-24-2010, 01:41 PM   #7
nimnull22
Senior Member
 
Registered: Jul 2009
Distribution: OpenSuse 11.1, Fedora 14, Ubuntu 12.04/12.10, FreeBSD 9.0
Posts: 1,571

Rep: Reputation: 92
Question is what is your computer OS configuration and what is "vmnet" doing there. Is there any virtual machine on your computer?
 
Old 04-25-2010, 12:18 PM   #8
noviciado
Member
 
Registered: Feb 2009
Distribution: Slackware 13.0 (2.6.29.6-smp)
Posts: 47

Original Poster
Rep: Reputation: 15
The OS is Slackware 13.0 (2.6.29.6-smp), and yes there is a virtual machine on the computer (it never conflicted with my wireless for the past 5 months or so, though, so I don't know if there's any reason to suspect it as the culprit).
I swapped the pci wireless card into an older computer, and it works just fine, so I know the problem does not lie there either.
 
Old 04-27-2010, 09:27 PM   #9
noviciado
Member
 
Registered: Feb 2009
Distribution: Slackware 13.0 (2.6.29.6-smp)
Posts: 47

Original Poster
Rep: Reputation: 15
no one has a clue?
 
Old 05-06-2010, 01:11 AM   #10
noviciado
Member
 
Registered: Feb 2009
Distribution: Slackware 13.0 (2.6.29.6-smp)
Posts: 47

Original Poster
Rep: Reputation: 15
I'll give this another bump...

Is this just difficult to diagnose? Any other output I can offer?
 
Old 05-06-2010, 11:44 PM   #11
nimnull22
Senior Member
 
Registered: Jul 2009
Distribution: OpenSuse 11.1, Fedora 14, Ubuntu 12.04/12.10, FreeBSD 9.0
Posts: 1,571

Rep: Reputation: 92
bash-3.1# ifconfig wlan0 up
bash-3.1# ifconfig wlan0 down
And result is:

bridge-eth0: up
ADDRCONF(NETDEV_UP): eth0: link is not ready
bridge-eth0: attached
bridge-eth0: disabling the bridge
bridge-eth0: down
bridge-eth0: detached
vmnet1: no IPv6 routers present
vmnet8: no IPv6 routers present

Look: you told: bring WLAN0 up, but script brought UP eth0 as a bridge.
You know, it is your computer and your configuration, may be you just analyze it.

Last edited by nimnull22; 05-13-2010 at 12:06 AM.
 
Old 05-17-2010, 01:15 PM   #12
noviciado
Member
 
Registered: Feb 2009
Distribution: Slackware 13.0 (2.6.29.6-smp)
Posts: 47

Original Poster
Rep: Reputation: 15
I have no idea how to analyze that....but it appears that I don't have to. Doing nothing else but coming back to the computer a few days later, the network gets brought up automatically. I don't know if that's a sign of hardware failing, but the problem came and went without me changing any settings. Thanks for your help anyhow.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Wicd in current won't connect to wireless network. Fixed it with rebuilding grissiom Slackware 6 03-06-2010 12:16 AM
Do I need rc.inet[d,1,2], rc.pcmcia, & rc.wireless at boot if I use wicd w/wireless? agi93 Slackware 6 01-03-2010 07:07 AM
WICD tray icon says not connected, WICD manager says conneted to wired network?!?! intheshadows Linux - Newbie 1 12-24-2009 12:15 PM
Wicd cannot obtain an IP automatically in a wireless network with WPA enabled. kemsiro Slackware 30 10-14-2009 10:17 PM
Cannot connect to wireless network with wicd on Zenwalk Kenny_C Linux - Wireless Networking 1 04-07-2009 02:11 PM


All times are GMT -5. The time now is 12:55 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration