LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices

Reply
 
Search this Thread
Old 01-03-2010, 02:33 AM   #1
zibalas
LQ Newbie
 
Registered: Jan 2010
Posts: 15

Rep: Reputation: 0
Question Wireless + IPTV with Atheros ath9k


Hello,

I'm trying to make IPTV work on linux router that i made. Here's my setup: Athlon XP 2400+, two realtek lan cards and dlink DWA-552 (atheros 5416). On this hardware i have running alpine linux (kernel 2.6.30.10-grsec). I'm using hostapd to configure wireless access point. I've setup IGMP Proxy for lan(eth1) and wlan(wlan0). IPTV works fine on lan, but if i try to watch IPTV on wlan the whole network breaks down. VLC displays first couple of frames and then routers times out. When i kill VLC everything goes back to normal. I would really appreciate any kind of help. I'll provide any additional info necessary.

Regards,
Rick

igmpproxy.conf
Quote:
quickleave
phyint eth0 upstream ratelimit 0 threshold 1
altnet 10.0.101.0/24

phyint eth1 downstream ratelimit 0 threshold 1
phyint wlan0 downstream ratelimit 0 threshold 1

phyint lo disabled
phyint mon.wlan0 disabled
phyint wmaster0 disabled
Quote:
alpine:~# iptables --list
Chain INPUT (policy ACCEPT)
target prot opt source destination

Chain FORWARD (policy ACCEPT)
target prot opt source destination

Chain OUTPUT (policy ACCEPT)
target prot opt source destination
Quote:
alpine:~# iptables -t nat --list
Chain PREROUTING (policy ACCEPT)
target prot opt source destination

Chain POSTROUTING (policy ACCEPT)
target prot opt source destination
MASQUERADE all -- anywhere anywhere

Chain OUTPUT (policy ACCEPT)
target prot opt source destination
 
Old 01-03-2010, 10:44 AM   #2
nimnull22
Senior Member
 
Registered: Jul 2009
Distribution: OpenSuse 11.1, Fedora 14, Ubuntu 12.04/12.10, FreeBSD 9.0
Posts: 1,571

Rep: Reputation: 92
Hi.

If I understood you right you have:
Computer with 2 ethernet cards + wlan card.
One eth0 you use for uplink to internet, second eth1 for local network and wlan card for wireless network.
You can use IPTV from wired LAN, but can't from wireless.

Am I right?
 
Old 01-03-2010, 10:51 AM   #3
zibalas
LQ Newbie
 
Registered: Jan 2010
Posts: 15

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by nimnull22 View Post
Hi.

If I understood you right you have:
Computer with 2 ethernet cards + wlan card.
One eth0 you use for uplink to internet, second eth1 for local network and wlan card for wireless network.
You can use IPTV from wired LAN, but can't from wireless.

Am I right?
Correct. I've tried to update to 2.6.32.2-grsec kernel - same thing. I've also tried compat-wireless-2.6.32.2 driver - no luck
 
Old 01-03-2010, 10:54 AM   #4
nimnull22
Senior Member
 
Registered: Jul 2009
Distribution: OpenSuse 11.1, Fedora 14, Ubuntu 12.04/12.10, FreeBSD 9.0
Posts: 1,571

Rep: Reputation: 92
What is the routing table on your linux route computer:
route -n
 
Old 01-03-2010, 11:00 AM   #5
zibalas
LQ Newbie
 
Registered: Jan 2010
Posts: 15

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by nimnull22 View Post
What is the routing table on your linux route computer:
route -n
Quote:
alpine:~# route -n
192.168.0.0 0.0.0.0 255.255.255.128 U 0 0 0 br0
88.222.24.0 0.0.0.0 255.255.252.0 U 202 0 0 eth0
0.0.0.0 88.222.27.254 0.0.0.0 UG 202 0 0 eth0
and to answer your next question

Quote:
alpine:~# brctl show
bridge name bridge id STP enabled interfaces
br0 8000.000e2e590648 no wlan0
eth1
EDIT: same result with this igmpproxy.conf

Quote:
quickleave
phyint eth0 upstream ratelimit 0 threshold 1
altnet 10.0.101.0/24
phyint br0 downstream ratelimit 0 threshold 1
phyint lo disabled
phyint eth1 disabled
phyint wlan0 disabled
phyint mon.wlan0 disabled
phyint wmaster0 disabled

Last edited by zibalas; 01-03-2010 at 11:08 AM.
 
Old 01-03-2010, 11:10 AM   #6
nimnull22
Senior Member
 
Registered: Jul 2009
Distribution: OpenSuse 11.1, Fedora 14, Ubuntu 12.04/12.10, FreeBSD 9.0
Posts: 1,571

Rep: Reputation: 92
Quote:
Originally Posted by zibalas View Post
alpine:~# brctl show
bridge name bridge id STP enabled interfaces
br0 8000.000e2e590648 no wlan0
eth1
And how can you explain it. Where is the bridge mode enabled where isn't?
And why do you need bridge at all. Packets from your wireless LAN should go directly to eth0.
 
Old 01-03-2010, 11:22 AM   #7
zibalas
LQ Newbie
 
Registered: Jan 2010
Posts: 15

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by nimnull22 View Post
And how can you explain it. Where is the bridge mode enabled where isn't?
And why do you need bridge at all. Packets from your wireless LAN should go directly to eth0.
I need bridge because I want to treat wlan0 and eth1 as one device. I don't really need separate ip addresses for those two interfaces. But the problem is not the bridge. I had same results without the bridge. Just to make sure I've removed the bridge, once again got same result. Here's my new route -n

Quote:
alpine:~# route -n
Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface
192.168.0.0 0.0.0.0 255.255.255.128 U 0 0 0 eth1
192.168.0.128 0.0.0.0 255.255.255.128 U 0 0 0 wlan0
88.222.24.0 0.0.0.0 255.255.252.0 U 202 0 0 eth0
0.0.0.0 88.222.27.254 0.0.0.0 UG 202 0 0 eth0
 
Old 01-03-2010, 11:34 AM   #8
zibalas
LQ Newbie
 
Registered: Jan 2010
Posts: 15

Original Poster
Rep: Reputation: 0
I don't know if this will help or introduce more confusion but here goes. M y eth1 (LAN card) is actually plugged in DIR-300 which acts as access point / switch. If i connect to DIR-300 using wireless IPTV woks fine. DIR-300 has a "Wireless Enhance Mode on/off" setting under multicast settings. If i turn "Wireless Enhance Mode" off then I get same result with DIR-300: VLC displays couple of frames and stops working meanwhile ping to DIR-300 increases and eventually times out. IPTV works on DIR-300 wired connection. So as far as I understand i need to turn on "Wireless Enhance Mode" (whatever that is) on my wlan0. Does anyone have an idea what "Wireless Enhance Mode" might be?
 
Old 01-03-2010, 11:42 AM   #9
nimnull22
Senior Member
 
Registered: Jul 2009
Distribution: OpenSuse 11.1, Fedora 14, Ubuntu 12.04/12.10, FreeBSD 9.0
Posts: 1,571

Rep: Reputation: 92
Tell please your network configuration:
what are IPs on your wireless network?
what is GW for your network?
 
Old 01-03-2010, 11:48 AM   #10
zibalas
LQ Newbie
 
Registered: Jan 2010
Posts: 15

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by nimnull22 View Post
Tell please your network configuration:
what are IPs on your wireless network?
what is GW for your network?
Gateway is 192.168.0.1 (eth1)

Quote:
alpine:~# ifconfig eth1
eth1 Link encap:Ethernet HWaddr 00:0E:2E:59:06:48
inet addr:192.168.0.1 Bcast:192.168.0.128 Mask:255.255.255.128
inet6 addr: fe80::20e:2eff:fe59:648/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:38327 errors:0 dropped:0 overruns:0 frame:0
TX packets:37891 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:9179449 (8.7 MiB) TX bytes:17129152 (16.3 MiB)
Interrupt:16 Base address:0xc000
Quote:
alpine:~# ifconfig wlan0
wlan0 Link encap:Ethernet HWaddr 00:22:B0:BD:29:BA
inet addr:192.168.0.129 Bcast:192.168.0.255 Mask:255.255.255.128
inet6 addr: fe80::222:b0ff:febd:29ba/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:4295 errors:0 dropped:0 overruns:0 frame:0
TX packets:7904 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:788885 (770.3 KiB) TX bytes:5538086 (5.2 MiB)
Quote:
# dhcpd.conf

default-lease-time 600;
max-lease-time 7200;

ddns-update-style none;

authoritative;

subnet 192.168.0.0 netmask 255.255.255.128 {
range 192.168.0.50 192.168.0.127;
option routers 192.168.0.1;
option domain-name-servers 88.222.0.1, 88.223.0.1, 212.59.1.1;
}

subnet 192.168.0.128 netmask 255.255.255.128
{
range 192.168.0.150 192.168.0.254;
option routers 192.168.0.129;
option domain-name-servers 88.222.0.1, 88.223.0.1, 212.59.1.1;
}
 
Old 01-03-2010, 12:00 PM   #11
nimnull22
Senior Member
 
Registered: Jul 2009
Distribution: OpenSuse 11.1, Fedora 14, Ubuntu 12.04/12.10, FreeBSD 9.0
Posts: 1,571

Rep: Reputation: 92
It looks like your DHCP can lease Ip from two ranges:
1. range 192.168.0.50 192.168.0.127
2. range 192.168.0.150 192.168.0.254

IPTV doesn't work for both IP ranges?
 
Old 01-03-2010, 12:14 PM   #12
zibalas
LQ Newbie
 
Registered: Jan 2010
Posts: 15

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by nimnull22 View Post
It looks like your DHCP can lease Ip from two ranges:
1. range 192.168.0.50 192.168.0.127
2. range 192.168.0.150 192.168.0.254

IPTV doesn't work for both IP ranges?
When i used bridge there was only one IP range. So i don't think what's the problem. Currently wlan0 range is 192.168.0.150-192.168.0.254 and eth1 192.168.0.50-192.168.0.127.

Picture tells a 1000 words. So here's my network
Attached Images
File Type: png network.png (14.4 KB, 5 views)
 
Old 01-03-2010, 12:21 PM   #13
zibalas
LQ Newbie
 
Registered: Jan 2010
Posts: 15

Original Poster
Rep: Reputation: 0
... and also with Wireless Enhance Mode OFF ...

The idea is to get rid of DIR-300. That's why i have wlan0.
Attached Images
File Type: png network2.png (29.8 KB, 6 views)
 
Old 01-03-2010, 02:17 PM   #14
nimnull22
Senior Member
 
Registered: Jul 2009
Distribution: OpenSuse 11.1, Fedora 14, Ubuntu 12.04/12.10, FreeBSD 9.0
Posts: 1,571

Rep: Reputation: 92
I suggest to find manual for DIR-300 and find out what is "Wireless Enhance Mode".
Because may be you need to do something similar on alpine-linux.
 
Old 01-04-2010, 10:56 AM   #15
zibalas
LQ Newbie
 
Registered: Jan 2010
Posts: 15

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by nimnull22 View Post
I suggest to find manual for DIR-300 and find out what is "Wireless Enhance Mode".
Because may be you need to do something similar on alpine-linux.
I'm guessing that "Wireless Enhance Mode" might be setting multicast rate to some value. On linksys routers and apple airport you must set multicast rate to 6mbps or something in order to make IPTV work. Unfortunately ath9k doesn't support iwpriv mcast_rate And i can't get madwifi driver to work (but that's a topic for another thread) Did anyone else encountered this problem?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Slackware 13 wireless not working (ath9k) Cryophile Slackware 9 12-17-2009 06:10 PM
WG111T with new atheros kerneldriver ath9k barrios Linux - Networking 1 10-12-2009 01:53 PM
Atheros ath9k and wicd in Slackware64...can not connect em21701 Slackware 13 09-01-2009 01:18 AM
LXer: Visioneering Releases Four New IPTV Set-top Boxes; Sonata IPTV(TM) Delivers Unmatched Video Quality Over Broadband LXer Syndicated Linux News 0 06-22-2006 01:03 PM
LXer: Linux Powered Wireless Digital Signage Media Player based on IPTV ... LXer Syndicated Linux News 0 05-11-2006 02:54 PM


All times are GMT -5. The time now is 11:01 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration