LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices

Reply
 
Search this Thread
Old 06-11-2007, 12:06 PM   #1
ille.pugil42
Member
 
Registered: Dec 2005
Distribution: Slackware
Posts: 151

Rep: Reputation: 30
Windows ICS slow with Linux?


I've got dialup (unfortunately) and I am able to share from my wife's WinXP box to my box when running WinXP. When Slackware 11 came out I quickly downloaded that (from a site other than home :P ) and installed it. I was able to get the internet working through her computer in my Slack install, but the internet was horribly slow. I figured that I must have just configured something wrong and never got back to it. When my copy of Ubuntu 7.04 came in the mail, I nuked slack and installed it (not because I like Ubuntu as much, but it looks like we'll be supporting it at work). I was able to configure the internet again and was able to get access - but it was still slow. Pings go through about as fast as within windows, but any type of HTTP (or sadly World of Warcraft) traffic seems to have horribly high latencies.

The only settings I have are thus:

Wife's Computer (Windows XP)
Static IP: 192.168.1.100 (yes its not the default, but it works great XP<->XP)
Netmask: 255.255.255.0
DNS: XXX.XXX.XXX.XXX (Since my dialup is a bit silly with its DNS, I use another DNS service)

My Computer (XP/Ubuntu/Slackware)
Static IP: 192.168.1.101
Netmask: 255.255.255.0
DNS: XXX.XXX.XXX.XXX (Yes I put the specific DNS in both)
Gateway: 192.168.1.100

Again, this works great in windows, but the only thing keeping from ditching windows at this point is sadly internet connectivity (even WoW works now, but really slow with this connection). If anyone can shed some light on this situation, I'd be grateful.
 
Old 06-11-2007, 12:53 PM   #2
hacker supreme
Member
 
Registered: Oct 2006
Location: As far away from my username as possible
Distribution: Gentoo
Posts: 259
Blog Entries: 1

Rep: Reputation: 30
This is because it's being routed through the windows box, which is always going to mean increased latency due to the windows box having to pass each packet through the LAN interface, then route it through the dialup connection.

High traffic applications are going to be the most affected.

I have dealt with this before, I used to use this kind of setup myself.

Last edited by hacker supreme; 06-11-2007 at 01:34 PM.
 
Old 06-11-2007, 05:24 PM   #3
ille.pugil42
Member
 
Registered: Dec 2005
Distribution: Slackware
Posts: 151

Original Poster
Rep: Reputation: 30
I can buy that explanation *except* for the fact that it works just fine via XP<->XP. When I reboot into linux, the latency skyrockets. For an example, if I run World of Warcraft (yes on both computers) we can average 300-750ms latency on both computers. If I reboot into linux, I'm hitting 4000ms or more. And this was with Slackware and Ubuntu. I'm beginning to think there's some other networking setting and/or mode I need to change that I'm unaware of.
 
Old 06-11-2007, 05:55 PM   #4
Shadow_7
Senior Member
 
Registered: Feb 2003
Distribution: debian
Posts: 1,545

Rep: Reputation: 238Reputation: 238Reputation: 238
I'm not sure whether it's the windows box doing the NAT, or the linux box doing the NAT. Although the title of the thread would imply that the windows box is the one connected to the internet.

I have a linux box doing my NAT and internet connection. Here's some tips for what I have configured.

Change your MTU to 576 to the internet. And my internal network is 616 now, although it was at an MTU of 576. With this configuration I get more bandwidth on my dialup connection. I also had to add passive to the /etc/ppp/options file, otherwise NAT got a little flakey.

For me that means:
#/etc/ppp/options
MTU 576
passive

# ifconfig <interface> mtu 616

I've also come across this issue with 2.6.17+ kernels through usenet. You might try making some of these adjustments and see if it helps.

echo 0 > /proc/sys/net/ipv4/tcp_default_win_scale

http://www.builderau.com.au/program/...9277823,00.htm

http://dsd.lbl.gov/TCP-tuning/linux.html

My 616 issue was to overcome one site that seems to only load with a higher internal MTU. Although it may be the tcp_default_win_scale issue that contributed to it.

HTH
 
Old 06-12-2007, 11:32 AM   #5
sandgroper
Member
 
Registered: Jul 2004
Location: Perth , Western Australia
Distribution: Fedora Core 5 , Mint 9
Posts: 118

Rep: Reputation: 15
Smile

Quote:
Originally Posted by ille.pugil42
I've got dialup (unfortunately) and I am able to share from my wife's WinXP box to my box when running WinXP. When Slackware 11 came out I quickly downloaded that (from a site other than home :P ) and installed it. I was able to get the internet working through her computer in my Slack install, but the internet was horribly slow. I figured that I must have just configured something wrong and never got back to it. When my copy of Ubuntu 7.04 came in the mail, I nuked slack and installed it (not because I like Ubuntu as much, but it looks like we'll be supporting it at work). I was able to configure the internet again and was able to get access - but it was still slow. Pings go through about as fast as within windows, but any type of HTTP (or sadly World of Warcraft) traffic seems to have horribly high latencies.

The only settings I have are thus:

Wife's Computer (Windows XP)
Static IP: 192.168.1.100 (yes its not the default, but it works great XP<->XP)
Netmask: 255.255.255.0
DNS: XXX.XXX.XXX.XXX (Since my dialup is a bit silly with its DNS, I use another DNS service)

My Computer (XP/Ubuntu/Slackware)
Static IP: 192.168.1.101
Netmask: 255.255.255.0
DNS: XXX.XXX.XXX.XXX (Yes I put the specific DNS in both)
Gateway: 192.168.1.100

Again, this works great in windows, but the only thing keeping from ditching windows at this point is sadly internet connectivity (even WoW works now, but really slow with this connection). If anyone can shed some light on this situation, I'd be grateful.
The basic fact is that XP uses the address of 192.168.0.1 as it's default ICS setup and doesn't really like any other IP address.

Sure you may be able to use another IP address , but it may not work properly.

I have the same setup with 2 machines , both dual boot machines with Fedora and XP Pro on a dialup account.
When I run XP on the machine with the modem and access the internet using my other box running Fedora , I have no problems whatsoever and I don't experience and slow responses or downloads, it is at the same speed as the XP box.

Your linux box and IP addresses look OK , so does the DNS and netmask on the XP box.

So what you really need to do is to change the XP IP address back to the default 192.168.0.1 address.

Also you may want add a secondary DNS address to your XP DNS settings , use your ISPs and your other DNS address and swap them about to find which is the better as a primary and secondary DNS lookups.


.
 
Old 06-12-2007, 01:12 PM   #6
ille.pugil42
Member
 
Registered: Dec 2005
Distribution: Slackware
Posts: 151

Original Poster
Rep: Reputation: 30
Quote:
So what you really need to do is to change the XP IP address back to the default 192.168.0.1 address.
You know, I don't know why but I changed it previously and stuck with it since windows was operating properly with it. I'll try those out and let you know!
 
Old 06-14-2007, 04:57 AM   #7
Shadow_7
Senior Member
 
Registered: Feb 2003
Distribution: debian
Posts: 1,545

Rep: Reputation: 238Reputation: 238Reputation: 238
You might also check the results of

C:\>route PRINT

(or was it /PRINT? case does matter in this case for windows. route /? for it's cheat sheet.)

This should list your routing setup. If there's a ton of extra entries for gateways, that could account for some of the sluggishness. It seems that things in windows likes to reconfigure themselves so that you try gatewaying through spamware and others first, before getting out to the net.

Also change your MTU on the linux box. 1500 is the default, and that can slow down your browsers rendering speed. Since small content packets gets stuck in the queue while 1.5K media packets get downloaded. A setting of 576 is recommended for dialup connections.

# ifconfig <interface> mtu 576

You can also change your mtu on your windows interfaces, but it's not nearly as easy or cut and dry. And varies greatly depending on what version of windows your using. Most of which require some registry hacking.

My previous 616 resolution was apparently to overcome the tcp window scaling thing. When I changed it's settings I can access the site with a normal mtu now. Or maybe they fixed their site.

# echo 0>/proc/sys/net/ipv4/tcp_window_scaling

Which differs from the previous links naming convention. This applies to 2.6.17 or newer kernels. And has to do with coping with old routers that don't conform to the TCP/IP specifications. Although having windows as the gateway might not require this mod in your instance.

I'll also second that 192.168.0.1 thing as that is the windows default. Of course having that as your network, means having a netmask of 255.255.0.0.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
ICS Windows/Linux - Client not quite working right -.- Mmc245 Linux - Hardware 2 08-31-2005 08:23 AM
Linux & Windows ICS sysspoon Linux - Networking 3 08-26-2005 10:43 PM
Linux to Windows ICS AfterBurn Linux - Networking 6 01-31-2004 05:44 PM
Windows ICS and Debian Linux Minoru Linux - Networking 0 08-18-2003 06:30 PM
ICS with Linux and M$ Windows Amberdrake Linux - Networking 0 08-04-2003 04:50 PM


All times are GMT -5. The time now is 01:58 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration