LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices

Reply
 
Search this Thread
Old 01-11-2005, 12:39 PM   #1
Barca
LQ Newbie
 
Registered: Nov 2004
Location: Poland
Distribution: Slackware - best and only ;]
Posts: 29

Rep: Reputation: 15
Windows don't like ProFTPD? :/


I have newest proftpd installed. When I log in on my ftp from others linux machines, everything works great. Problem is, when on the client side is installed Microsoft Windows :/
I tried to login by IE, ftp command, Total Commaned and FlashFXP and there is always the same problem. I can log in, but listing of files always fails. All of those programs "think" and "think" and nothing happens. After 120 seconds, proftpd disconnect them.
Why can't I see any files? It happens on all accounts. For example (ftp command):

Microsoft Windows 2000 [Wersja 5.00.2195]
(C) Copyright 1985-1999 Microsoft Corp.

C:\>ftp
ftp> open **.**.**.** 5021
Połączony z **.**.**.**.
220 ::: Campnou FTP :::
Użytkownik (**.**.**.**none)): ****
331 Password required for go
Has│o:
230 User gosc logged in.
ftp> ls
200 PORT command successful
450 No files found
ftp> ls
200 PORT command successful
>>> here he waits 120 seconds and I'm getting mad <<<
421 no Transfer Timeout (120 seconds): closing control connection
ftp>

Thx for your help

PS I thought about one thing... I run my ftp on port 5021 because I haven't public IP, but I have ports 5000-6000 forwarded. Maybe it's the cause? When I connect by FlashFXP, he says sth about two ports which are beyond that range... Have I to forward any other ports? I'll try to log in to my ftp from windows in the same lan to see if my hypothese is true...
 
Old 01-11-2005, 02:11 PM   #2
BinaryBob
Member
 
Registered: Aug 2002
Posts: 117

Rep: Reputation: 15
hmmm

Going by your last paragraph - Have you tried setting the cleints to only use ports in the 5000-6000 range? Some of them allow for that. Also, have you tried, passive, and active modes?

Good Luck!
 
Old 01-11-2005, 02:33 PM   #3
Barca
LQ Newbie
 
Registered: Nov 2004
Location: Poland
Distribution: Slackware - best and only ;]
Posts: 29

Original Poster
Rep: Reputation: 15
I was right. When I log to my ftp from machine with Windows, which is located in the same LAN, everything goes fine. But, I sniffed with Ethereal, and Windows machine use only 5021 port to connect... So what's going on?
Idea with passive and active modes looks good for me, I'll try. Thanks for advice, BinaryBob

Anyone else, please?

//edit:

Yeah, the problem was in range of ports used to passive connection. I had to add to my proftpd.conf:

PassivePorts 5000 6000
MasqueradeAddress 80.53.15.86 # my public IP

And now it works Thank you.

Last edited by Barca; 01-15-2005 at 02:30 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
proftpd: proftpd startup failed tumana Linux - Newbie 14 06-17-2012 11:06 AM
Windows can't open files transferred thro' ProFTPd zatka Linux - Networking 3 02-08-2005 07:35 AM
windows connecting to proftpd dot_txt Linux - Networking 4 09-03-2004 12:10 PM
Disabling the chroot in proftpd and enabling root logins on ssh/proftpd jon_k Linux - Software 1 06-16-2004 10:27 AM
proftpd --- need help? could someone post a working proftpd.conf i could look at ZooRoPa Linux - Networking 1 04-02-2003 06:56 PM


All times are GMT -5. The time now is 03:11 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration