LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices



Reply
 
Search this Thread
Old 05-06-2004, 11:20 PM   #1
NetAX
Member
 
Registered: Mar 2004
Location: Boston, MA
Distribution: SuSE Linux Open/Enterprise, Red Hat, Ubuntu
Posts: 146

Rep: Reputation: 16
Win98 to Samba PDC write-access issue


Hi everybody, im currently using Samba version 2.2.8a as a Primary Domain Controller that authenticates users from Windows 98.

I've set everything up correctly. Users are able to logon as long as their username and password are found in the "smbpasswd" file. Their home directory can be found in network neighborhood based on their user name.

The problem i am having is being able to save files that are created on Windows 98 and then saving them to the Home directory of the user. When ever i try saving a file it tells me that i dont have the right security priviliges or something like that. I even setup a public folder and users have full read access.

I've tried many ways to allow write-access with no solution. I have tried altering the create mask integer for the share and other options such as:
printable =yes; read only= no; writable= yes; writelist =; None of these and a few other options that i dont remeber off the top of my head dont work.

Please someone point me in the right direction. I don't know if it has to do with the version i am using or if it is a Windows issue.


Smb.conf file:


# smb.conf is the main Samba configuration file. You find a full commented
# version at /usr/share/doc/packages/samba/examples/smb.conf.SuSE
# Date: 2003-09-23
# version at /usr/share/doc/packages/samba/examples/smb.conf.SuSE
# Date: 2003-09-23
[global]
workgroup= Tux-net
os level = 65
netbios name = cosmos

time server = Yes
security = server
unix extensions = Yes
encrypt passwords = yes
map to guest = Bad User
printing = CUPS
printcap name = CUPS
socket options = SO_KEEPALIVE IPTOS_LOWDELAY TCP_NODELAY
wins support = yes

veto files = /*.eml/*.nws/riched20.dll/*.{*}/
server string = Samba PDC %v %h
hosts allow = 172.16.4., 127.
log file = /var/log/messages/samba/log.%u
max log size = 50


smbpasswd file = /etc/samba/smbpasswd
unix password sync = yes
passwd program = /usr/bin/passwd%u

;;add user script = /usr/sbin/useradd -c Machine -d /dev/null -s /bin/false
domain master = yes
domain logons = yes
preferred master = yes

logon drive = z:
logon path = \\%L\Profiles\%u
logon home = \\%L\%u


logon script = netlogon.bat

[netlogon]
comment = Network Logon Service
path = /home/samba/netlogon
browseable = no
writable = no
share modes = no

[profiles]
path = /home/samba/profiles
browseable = no





[%U];;<=User share name

comment = Home Directory

writable = yes
writelist = achery
path = /home/netusers/%U
guest ok = yes
;; valid users = %U
;; create mask = 0775
;; directory mask = 0750
 
Old 05-07-2004, 01:32 PM   #2
dorian33
Member
 
Registered: Jan 2003
Location: Poland, Warsaw
Distribution: LFS, Gentoo
Posts: 587

Rep: Reputation: 32
Re: Win98 to Samba PDC write-access issue

Quote:
[%U];;<=User share name
comment = Home Directory
writable = yes
writelist = achery
path = /home/netusers/%U
guest ok = yes
;; valid users = %U
;; create mask = 0775
;; directory mask = 0750 [/B]
Try
Code:
[homes]
   comment = Home Directories

;; means only user see his own share
   browseable = no
;;
   writable = yes

;; worth to do set also:
   dos filetime resolution = yes
   dos filetimes =yes
This share is more natural for smb.conf and sets the correct rights for user.
 
Old 05-07-2004, 11:20 PM   #3
NetAX
Member
 
Registered: Mar 2004
Location: Boston, MA
Distribution: SuSE Linux Open/Enterprise, Red Hat, Ubuntu
Posts: 146

Original Poster
Rep: Reputation: 16
Thanx for the input dorian33, i dont think i tried the dos filetime options. I'll let you know how it tuns out.
 
Old 05-08-2004, 11:42 PM   #4
NetAX
Member
 
Registered: Mar 2004
Location: Boston, MA
Distribution: SuSE Linux Open/Enterprise, Red Hat, Ubuntu
Posts: 146

Original Poster
Rep: Reputation: 16
Alright i found the problem. It was a file permissions issue. The owner was set to "root". So i found a folder that was for users. i put in my smb.conf and tried saving it and it worked.

The problem i am having now is I cannot properly configure the folder i want to share for read-write or change the owner. When I type the command:

set facl -m user:jane:rwx, group:netusers:rwx /home/netusers

i get a reply telling me that the directory does not exist. Please reply if you have any input or info on how i can set the right acess permissions.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Samba PDC - XP client, Access is denied tstephens Linux - Networking 6 10-04-2007 01:59 AM
Help: Samba as PDC Issue - logging on with new user leisure Linux - Software 1 08-01-2005 12:06 PM
Samba PDC Windows Profile Issue danieltham Linux - Networking 3 02-08-2004 05:49 AM
samba PDC issue randomx Linux - Networking 4 02-26-2003 06:31 PM
samba PDC - user level access ilumin8d Linux - Networking 0 08-19-2001 04:09 PM


All times are GMT -5. The time now is 02:32 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration