LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Networking (http://www.linuxquestions.org/questions/linux-networking-3/)
-   -   Wifi won't reconnect after standby or hibernate (http://www.linuxquestions.org/questions/linux-networking-3/wifi-wont-reconnect-after-standby-or-hibernate-805682/)

franksjacket 05-03-2010 02:09 PM

Wifi won't reconnect after standby or hibernate
 
I am using WICD as my wireless network manager and it works connecting to a network for the first time. But when I resume my laptop from hibernate or standby, WICD will not reconnect to the network and gets stuck on obtaining an IP address. And if I try to change networks without hibernating I get the same problem.

Also, I notice that the network name is stagnant. I connect to multiple wifi networks a day because of school. When I leave my "home" network and connect to my "school" network WICD still says "Home:obtaining IP address" even thought it should say "school:obtaining IP address."

My thoughts are that it isn't releasing the network properly and when its trying to connect it can't because it still thinks it's connected. The only solution I have found is to restart my laptop every time I want to connect to a new network, or shut down every time I am done using my laptop, which is a major inconvenience. Please help.

Here is what I am using:
HP tx2000
Broadcom BCM4322
Ubuntu 10.04
WICD 1.7.0

maxmcbyte 05-03-2010 02:39 PM

You could restart the network.

1. /etc/init.d/networking restart

or restart the interface bound to your wireless adapter

2. sudo ifdown eth0 && sudo ifup eth0

You can use ifconfig to get info on your interfaces.

3. ifconfig

You can create a shell script to automate this and provide a link to it on your desktop. This way you can execute it whenever you need.

Hope this helps...

franksjacket 05-04-2010 02:50 AM

Quote:

Originally Posted by maxmcbyte (Post 3955944)
You could restart the network.

1. /etc/init.d/networking restart

or restart the interface bound to your wireless adapter

2. sudo ifdown eth0 && sudo ifup eth0

You can use ifconfig to get info on your interfaces.

3. ifconfig

You can create a shell script to automate this and provide a link to it on your desktop. This way you can execute it whenever you need.

Hope this helps...

Unfortunately this didn't solve the problem. I cannot switch between networks while the computer is on. Still looking for a solution.

maxmcbyte 05-07-2010 07:09 PM

"I am using WICD as my wireless network manager and it works connecting to a network for the first time. But when I resume my laptop from hibernate or standby, WICD will not reconnect to the network and gets stuck on obtaining an IP address."

If you issue the command without the quotes "/etc/init.d/networking restart"
that will restart your network.

"I cannot switch between networks while the computer is on"
I'll assume you are getting an IP address issued via DHCP. So, if you were using Network-A and then hibernated and then wanted to connect to Network-B you should be able to use your "WICD as my wireless network manager" *** AFTER ISSUING *** "/etc/init.d/networking restart" to connect.

Hope that helps...

SomeoneE1se 10-06-2010 09:01 PM

I had the same problem I solved it by reloading the kernel module

this solved my problem,

1) disconnect from all APs via WICD

2) run script

#!/bin/bash
#reload-bcm-wireless
modprobe -r b43 ssb wl
modprobe wl

3) connect as normal.

but I only had this problem when coming from a secure ap to an insecure ap.

Let me know if this works for you.

firehawk256 11-19-2010 10:10 AM

Just wanted to say I am having the exact same problem with wicd and the bcm4322 on debian. The solution of reloading the "wl" driver also worked for me.

Could this be a bug in the wl driver?

Geremia 08-29-2011 04:33 PM

DHCP Client at Fault
 
Quote:

Originally Posted by franksjacket (Post 3955906)
Igets stuck on obtaining an IP address

I have the same problem, too, when waking from suspend. The only way I can correct it is to disconnect from all networks, change the DHCP Client in Preferences-->External Programs, then reconnect again... Sometimes that works, and sometimes it doesn't...

No one has found an automatic fix to this problem? It appears to have something to do with the DHCP client. Thanks

Gerwar 09-22-2011 03:52 PM

I have a similar problem, but that happen to me also when the access-point goes down and goes up again, and i want to reconnect to it. I think the bug is either on the wl module, or in the wicd program, because, it seems (at least from what i have seen), that wicd goes through the hand shaking without receiving an acknowledgement.

redw0lfx 09-22-2011 05:11 PM

I have had similar problem when I had my Compaq laptop which had a broadcom wireless card on it. I believe the way I got around that was for the system to run a small script to stop the wireless interface, unload the wireless driver and then go to sleep. When it resumed from sleep, it would reload the wireless driver, and re-enable the wireless interface (Connect to the AP and issue a DHCP request).

layr 03-09-2012 10:17 AM

Quote:

Originally Posted by redw0lfx (Post 4479569)
I have had similar problem when I had my Compaq laptop which had a broadcom wireless card on it. I believe the way I got around that was for the system to run a small script to stop the wireless interface, unload the wireless driver and then go to sleep. When it resumed from sleep, it would reload the wireless driver, and re-enable the wireless interface (Connect to the AP and issue a DHCP request).

Could you please share your scripts?

Geremia 03-10-2012 10:17 AM

eth0 connected during standby freezes when waking up
 
If my machine's in standby and I connect ethernet, waking it from standby causes it to hang. Why is that? Thanks

layr 03-13-2012 05:39 PM

Bump for original subject.

layr 03-20-2012 08:45 AM

Bump2.

layr 03-26-2012 08:01 AM

The problem has self-healed. Only thing that has been changed, is removing 'connect automatically' from the networks concerned. But that's unconfirmed as of now.


All times are GMT -5. The time now is 06:55 AM.