LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Networking (http://www.linuxquestions.org/questions/linux-networking-3/)
-   -   WICD won't connect. (http://www.linuxquestions.org/questions/linux-networking-3/wicd-wont-connect-907829/)

Unr3a164 10-12-2011 03:48 PM

WICD won't connect.
 
So I finally installed Wicd the other night. After I first installed it I was able to connect to my WPA2 protected network. However, after shutting down and rebooting, wicd will not connect. The password has not changed, and neither has the encryption, but now whenever wicd tries to connect, it generates the error message, "Connection failed: Bad password" What am I doing wrong?

I am running Slackware 13.1 on a Lenovo netbook.

coralfang 10-13-2011 06:47 AM

I tend to get that on all distributions where i have used wicd from time to time. Not really sure of the cause, however i found a workaround that works for me most of the time (happens less often).

I changed in the preferences of wicd, to use the ioctl backend.

Unr3a164 10-14-2011 09:12 AM

Alright, I will try that when I get home tonight. See what happens. Thank you for the reply.

Unr3a164 10-14-2011 08:36 PM

Yea, that still didn't work. Still coming back with bad password. Any other ideas?

PTrenholme 10-14-2011 10:38 PM

Look in /var/lib/wicd/configurations to see if your configuration is correct. (The pasword there is encrypted, but the other settings can be checked.)

To verify that the password was properly saved, save the encrypted key string, click on the wicd tray icon, re-enter the password, and compare the save value with the new saved one.

Also, look at /var/log/wicd.log for other clues.

<edit>
Oh, some distributions (you didn't say which one of yours had the problem) want to start a preferred network application during the boot. If that's happening, wicd may be confused.
</edit>

Jenni 10-15-2011 12:06 AM

I've used wicd on slack 13.1 with no problems... if all your settings are correct, you could try deleting and re-entering the password?
Also are you automatically connecting to the network or reconnecting every time?


All times are GMT -5. The time now is 04:55 PM.