LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices

Reply
 
Search this Thread
Old 04-19-2005, 03:03 AM   #1
qutub110
LQ Newbie
 
Registered: Apr 2005
Location: Kuwait
Posts: 4

Rep: Reputation: 0
Why my Internet Sharing with Xp box not working?


Sharing Internet - OS � Linux � Fedora Core 1
--------------------------------------------------------------
I am new guy for Linux and I have Fedora C1 Server and there is Internet and working fine with Lan properly on Eth0. Now there is another NIC Eth1 with the below configuration with Lan. Now I want to Share my Internet with my Xp box which have Ip: 192.5.1.36 255.255.255.0 and GW 192.5.1.1 and I am also able to ping both box from both side succesfuly.

Also I am running Firestarter for Sharing Internet with the below Configuration

Firestarter Config
*********
External Device:
Eth0 with Ip add is assigned via DHCP

Connection Sharing :
enable NAT, Internal network device Eth1 with Autodetect internal Ip range.

Services:
Disable public access to all services

----------------------------------------------

$ /sbin/ifconfig
eth0 Link encap:Ethernet HWaddr 00:11:5B:87:0A:B9
inet addr:168.187.253.46 Bcast:168.187.253.47 Mask:255.255.255.240
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:82778 errors:0 dropped:5 overruns:0 frame:0
TX packets:9137 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:8470018 (8.0 Mb) TX bytes:877201 (856.6 Kb)
Interrupt:11 Base address:0xd400

eth1 Link encap:Ethernet HWaddr 00:40:05:9A:45:55
inet addr:192.5.1.11 Bcast:192.5.1.255 Mask:255.255.255.0
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:72040 errors:0 dropped:0 overruns:0 frame:0
TX packets:8140 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:6064354 (5.7 Mb) TX bytes:567542 (554.2 Kb)
Interrupt:10 Base address:0xec00

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:36467 errors:0 dropped:0 overruns:0 frame:0
TX packets:36467 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:10205230 (9.7 Mb) TX bytes:10205230 (9.7 Mb)

Please help me out in this issue How to configure in WinXp box and what Ip and port to be use to access internet from RH box? and whats wrong in above configuration on Eth1?

Qutub

Last edited by qutub110; 04-19-2005 at 03:07 AM.
 
Old 04-19-2005, 03:20 AM   #2
xukosky
Member
 
Registered: Apr 2005
Distribution: Becoming Sid
Posts: 142

Rep: Reputation: 15
If I am understanding you well, the GW of the XP box and the IP in eth1 are not the same... and they should
 
Old 04-19-2005, 03:58 AM   #3
qutub110
LQ Newbie
 
Registered: Apr 2005
Location: Kuwait
Posts: 4

Original Poster
Rep: Reputation: 0
Hi!

The Eth1 GW: 192.5.1.1 and Xp box GW: 192.5.1.1 both are having the same. Any other Idea?
 
Old 04-19-2005, 09:49 AM   #4
oberon-ken-obi
LQ Newbie
 
Registered: Jul 2004
Location: Oberon Australia
Distribution: Fedora Core3
Posts: 26

Rep: Reputation: 15
qutub110

try the firestarter mailing list at
http://lists.sourceforge.net/lists/l...restarter-user
OR
the Firestarter arhives
specifically
http://sourceforge.net/mailarchive/m...msg_id=2833591
Sounds like a FS issue to me (although im no expert)

Tomas generally gets on top of errors/issues quickly. He will certainly tell, you if its not FS soo enough.

Regards
Allan
 
Old 04-19-2005, 12:35 PM   #5
fr_laz
Member
 
Registered: Jan 2005
Location: Cork Ireland
Distribution: Debian
Posts: 384

Rep: Reputation: 32
Hi

Quote:
inet addr:192.5.1.11
That's your eth1 address, and your XP's gateway is, so you said, 192.5.1.1.

What's more, it would be nicer if you used private IP range on your LAN (192.168.0.0, 172.16.0.0, or 10.0.0.0 subnets are official private subnets, whereas 192.5.x.x is public and routable on Internet)... that wont work better, but that's the way people are supposed to do.

Last edited by fr_laz; 04-19-2005 at 12:38 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Sharing internet access with my Windows box ColdDeath Slackware 5 11-02-2005 03:08 PM
My internet sharing is not working cougyr Linux - Networking 1 05-15-2005 06:53 PM
Linux Box with 3 NICs for Internet sharing digihall7 Linux - Networking 3 04-30-2004 03:30 AM
Sharing Internet with a WinXP Box sovietpower Linux - Networking 2 11-13-2003 08:19 PM
Internet sharing via linux box on ASDL problem RIKUS Linux - Networking 1 08-20-2003 07:55 AM


All times are GMT -5. The time now is 02:13 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration