LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices

Reply
 
Search this Thread
Old 10-11-2008, 07:58 AM   #1
marcobjorge
LQ Newbie
 
Registered: Oct 2008
Posts: 4

Rep: Reputation: 0
why is bind updating reverse zone with updating zone 202.1.168.192.1.168.192.in-addr


Hi,

I have a problem and I hope someone could help.

bind is updating a reverse zone as follows:
Code:
updating zone '1.168.192.in-addr.arpa/IN': adding an RR at '202.1.168.192.1.168.192.in-addr.arpa' PTR
Does anyone know why...I can post my config files if needed.

Thanks,
Marco Jorge
 
Old 10-11-2008, 11:37 AM   #2
beadyallen
Member
 
Registered: Mar 2008
Location: UK
Distribution: Fedora, Gentoo
Posts: 209

Rep: Reputation: 36
Looks to me like you've missed off a '.' in your reverse file. So for example, you've maybe got something like:
Code:
202.0.168.192   IN PTR name.example.org.
If you're going to specify the full ip address (not just the 202), then you need to append a '.' to the full arpa name, or it'll get expanded as you've seen. So either:
Code:
 202.0.168.192.in-addr.arpa.   IN PTR name.example.org.
or
Code:
 202             IN PTR name.example.org.
should be what you want.

Last edited by beadyallen; 10-11-2008 at 11:39 AM.
 
Old 10-11-2008, 02:03 PM   #3
chort
Senior Member
 
Registered: Jul 2003
Location: Silicon Valley, USA
Distribution: OpenBSD 4.6, OS X 10.6.2, CentOS 4 & 5
Posts: 3,660

Rep: Reputation: 69
Are you trying to do dynamic DNS with dhcpd? If so, you have your subnet specified wrong in your dhcpd.conf.
 
Old 10-11-2008, 02:08 PM   #4
marcobjorge
LQ Newbie
 
Registered: Oct 2008
Posts: 4

Original Poster
Rep: Reputation: 0
Hi,

Thanks for your response beadyallen and chort.

Yes I am using DHCP + bind.

If the config file is wrong I don't think I can pinpoint the problem.

I am posting my main config files.

dhcpd.conf
Code:
ddns-update-style interim;
default-lease-time 600;
max-lease-time 3600;
option ip-forwarding on;
include "/etc/dhcp3/rndc.key";

zone wireless.network. {
        primary 192.168.1.1;
        key "rndc-key";
}

zone 1.168.192.in-addr.arpa. {
        primary 192.168.1.1;
        key "rndc-key";
}

zone wired.network. {
        primary 192.168.0.1;
        key "rndc-key";
}

zone 0.168.192.in-addr.arpa. {
        primary 192.168.0.1;
        key "rndc-key";
}

log-facility local7;

subnet 192.168.1.0 netmask 255.255.255.0 {
        authoritative;
        ddns-updates on;
        ddns-domainname "wireless.network";
        option domain-name "wireless.network wired.network";
        range 192.168.1.200 192.168.1.254;
        option domain-name-servers 192.168.1.1;
        option routers 192.168.1.1;
        ddns-rev-domainname "1.168.192.in-addr.arpa.";
}

subnet 192.168.0.0 netmask 255.255.255.0 {
        authoritative;
        ddns-updates on;
        ddns-domainname "wired.network";
        option domain-name "wired.network wireless.network";
        range 192.168.0.200 192.168.0.254;
        option domain-name-servers 192.168.0.1;
        option routers 192.168.0.1;
        ddns-rev-domainname "0.168.192.in-addr.arpa.";
}
named.conf
Code:
include "/etc/bind/rndc.key";

options {
     directory "/etc/bind";
     forwarders {212.55.154.174;};
};

controls {
     inet 127.0.0.1 allow {localhost;} keys { "rndc-key"; } ;
};

zone "network" IN {
        type master;
        file "/etc/bind/network.zone";
        allow-update { key "rndc-key"; };

};

zone "wired.network" {
        type master;
        file "/etc/bind/wired.zone";
        allow-update { key "rndc-key"; };
};

zone "wireless.network" {
        type master;
        file "/etc/bind/wireless.zone";
        allow-update { key "rndc-key"; };
};

zone "1.168.192.in-addr.arpa." {
        type master;
        file "/etc/bind/rev-wireless.zone";
        allow-update { key "rndc-key"; };
};

zone "0.168.192.in-addr.arpa." {
        type master;
        file "/etc/bind/rev-wired.zone";
        allow-update { key rndc-key; };
};

#zone "." {
#        type hint;
#        file "root.zone";
#};


logging {
        channel update_debug {
                file "/var/log/update-debug.log";
                severity  debug 3;
                print-category yes;
                print-severity yes;
                print-time     yes;
        };
        category update { update_debug; };
};
rev-wireless.zone
Code:
$ORIGIN .
$TTL 86400      ; 1 day
1.168.192.in-addr.arpa  IN SOA  wireless.network. root.wireless.network. (
                                10         ; serial
                                604800     ; refresh (1 week)
                                86400      ; retry (1 day)
                                2419200    ; expire (4 weeks)
                                86400      ; minimum (1 day)
                                )
                        NS      server.wireless.network.
$ORIGIN 1.168.192.in-addr.arpa.
$TTL 300        ; 5 minutes
202.1.168.192           PTR     laptop.wireless.network.
This last line
Code:
202.1.168.192           PTR     laptop.wireless.network.
has been generated when my laptop used dhcp to gain an IP.

It should just be:
Code:
202           PTR     laptop.wireless.network.
If you "see" (e.g. don't see) the missing dot or any other error that might cause the error I am getting I am grateful.


Best regards,
Marco Jorge

Last edited by marcobjorge; 10-11-2008 at 02:13 PM. Reason: chort posted a reply
 
Old 10-11-2008, 11:31 PM   #5
chort
Senior Member
 
Registered: Jul 2003
Location: Silicon Valley, USA
Distribution: OpenBSD 4.6, OS X 10.6.2, CentOS 4 & 5
Posts: 3,660

Rep: Reputation: 69
I would try shortening
Code:
        ddns-rev-domainname "1.168.192.in-addr.arpa.";
to
Code:
        ddns-rev-domainname "in-addr.arpa.";
(same for the 0.168.192 subnet) in dhcpd.conf.
 
Old 10-12-2008, 05:53 AM   #6
marcobjorge
LQ Newbie
 
Registered: Oct 2008
Posts: 4

Original Poster
Rep: Reputation: 0
Hi,

Thanks chort!!

That did the trick...although I really don't understand why!

I've seen other config files and they loked just like mine...

Again, thanks!

Best regards,
Marco Jorge
 
  


Reply

Tags
bind, dns, reverse


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
error: ** server can't find 79.20.168.192.in-addr.arpa: REFUSED mamtasahai1 Linux - General 17 05-07-2014 06:33 AM
[root@wlxxb ~]# telnet 192.168.192.12 25 Trying 192.168.192.12... telnet problem cnhawk386 Linux - Networking 1 10-10-2007 03:50 PM
pinging 192.168.0.10 from 192.168.2.101 cov Linux - Networking 12 05-03-2007 11:21 AM
What route to access daisy chained 2d router 192.168.1.1 after 192.168.0.1 (subnets?) Emmanuel_uk Linux - Networking 6 05-05-2006 02:47 AM
Is someone on my network?! ::ffff:192.168.0.10:ssh ::ffff:192.168.0.:38201 ESTABLISHE ming0 Linux - Security 4 04-12-2005 02:04 AM


All times are GMT -5. The time now is 02:12 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration