LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Networking (http://www.linuxquestions.org/questions/linux-networking-3/)
-   -   why is bind updating reverse zone with updating zone 202.1.168.192.1.168.192.in-addr (http://www.linuxquestions.org/questions/linux-networking-3/why-is-bind-updating-reverse-zone-with-updating-zone-202-1-168-192-1-168-192-in-addr-675658/)

marcobjorge 10-11-2008 06:58 AM

why is bind updating reverse zone with updating zone 202.1.168.192.1.168.192.in-addr
 
Hi,

I have a problem and I hope someone could help.

bind is updating a reverse zone as follows:
Code:

updating zone '1.168.192.in-addr.arpa/IN': adding an RR at '202.1.168.192.1.168.192.in-addr.arpa' PTR
Does anyone know why...I can post my config files if needed.

Thanks,
Marco Jorge

beadyallen 10-11-2008 10:37 AM

Looks to me like you've missed off a '.' in your reverse file. So for example, you've maybe got something like:
Code:

202.0.168.192  IN PTR name.example.org.
If you're going to specify the full ip address (not just the 202), then you need to append a '.' to the full arpa name, or it'll get expanded as you've seen. So either:
Code:

202.0.168.192.in-addr.arpa.  IN PTR name.example.org.
or
Code:

202            IN PTR name.example.org.
should be what you want.

chort 10-11-2008 01:03 PM

Are you trying to do dynamic DNS with dhcpd? If so, you have your subnet specified wrong in your dhcpd.conf.

marcobjorge 10-11-2008 01:08 PM

Hi,

Thanks for your response beadyallen and chort.

Yes I am using DHCP + bind.

If the config file is wrong I don't think I can pinpoint the problem.

I am posting my main config files.

dhcpd.conf
Code:

ddns-update-style interim;
default-lease-time 600;
max-lease-time 3600;
option ip-forwarding on;
include "/etc/dhcp3/rndc.key";

zone wireless.network. {
        primary 192.168.1.1;
        key "rndc-key";
}

zone 1.168.192.in-addr.arpa. {
        primary 192.168.1.1;
        key "rndc-key";
}

zone wired.network. {
        primary 192.168.0.1;
        key "rndc-key";
}

zone 0.168.192.in-addr.arpa. {
        primary 192.168.0.1;
        key "rndc-key";
}

log-facility local7;

subnet 192.168.1.0 netmask 255.255.255.0 {
        authoritative;
        ddns-updates on;
        ddns-domainname "wireless.network";
        option domain-name "wireless.network wired.network";
        range 192.168.1.200 192.168.1.254;
        option domain-name-servers 192.168.1.1;
        option routers 192.168.1.1;
        ddns-rev-domainname "1.168.192.in-addr.arpa.";
}

subnet 192.168.0.0 netmask 255.255.255.0 {
        authoritative;
        ddns-updates on;
        ddns-domainname "wired.network";
        option domain-name "wired.network wireless.network";
        range 192.168.0.200 192.168.0.254;
        option domain-name-servers 192.168.0.1;
        option routers 192.168.0.1;
        ddns-rev-domainname "0.168.192.in-addr.arpa.";
}

named.conf
Code:

include "/etc/bind/rndc.key";

options {
    directory "/etc/bind";
    forwarders {212.55.154.174;};
};

controls {
    inet 127.0.0.1 allow {localhost;} keys { "rndc-key"; } ;
};

zone "network" IN {
        type master;
        file "/etc/bind/network.zone";
        allow-update { key "rndc-key"; };

};

zone "wired.network" {
        type master;
        file "/etc/bind/wired.zone";
        allow-update { key "rndc-key"; };
};

zone "wireless.network" {
        type master;
        file "/etc/bind/wireless.zone";
        allow-update { key "rndc-key"; };
};

zone "1.168.192.in-addr.arpa." {
        type master;
        file "/etc/bind/rev-wireless.zone";
        allow-update { key "rndc-key"; };
};

zone "0.168.192.in-addr.arpa." {
        type master;
        file "/etc/bind/rev-wired.zone";
        allow-update { key rndc-key; };
};

#zone "." {
#        type hint;
#        file "root.zone";
#};


logging {
        channel update_debug {
                file "/var/log/update-debug.log";
                severity  debug 3;
                print-category yes;
                print-severity yes;
                print-time    yes;
        };
        category update { update_debug; };
};

rev-wireless.zone
Code:

$ORIGIN .
$TTL 86400      ; 1 day
1.168.192.in-addr.arpa  IN SOA  wireless.network. root.wireless.network. (
                                10        ; serial
                                604800    ; refresh (1 week)
                                86400      ; retry (1 day)
                                2419200    ; expire (4 weeks)
                                86400      ; minimum (1 day)
                                )
                        NS      server.wireless.network.
$ORIGIN 1.168.192.in-addr.arpa.
$TTL 300        ; 5 minutes
202.1.168.192          PTR    laptop.wireless.network.

This last line
Code:

202.1.168.192          PTR    laptop.wireless.network.
has been generated when my laptop used dhcp to gain an IP.

It should just be:
Code:

202          PTR    laptop.wireless.network.
If you "see" (e.g. don't see) the missing dot or any other error that might cause the error I am getting I am grateful.


Best regards,
Marco Jorge

chort 10-11-2008 10:31 PM

I would try shortening
Code:

        ddns-rev-domainname "1.168.192.in-addr.arpa.";
to
Code:

        ddns-rev-domainname "in-addr.arpa.";
(same for the 0.168.192 subnet) in dhcpd.conf.

marcobjorge 10-12-2008 04:53 AM

Hi,

Thanks chort!!

That did the trick...although I really don't understand why!

I've seen other config files and they loked just like mine...

Again, thanks!

Best regards,
Marco Jorge


All times are GMT -5. The time now is 03:16 AM.