LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices

Reply
 
Search this Thread
Old 10-06-2003, 12:06 AM   #1
mrsolo
Member
 
Registered: Jun 2002
Location: Where ever the Navy sends me
Distribution: Gentoo
Posts: 320

Rep: Reputation: 30
Weird bandwidth consumption


I have a router connected to my school's wan. I then have my server connected to one of the switched ports on my router. I also have a wireless access point connected to another switched port on the router which connects my wireless laptop to the lan. When my friends download huge files from my server, the bandwidth on my laptop is maxed out. How can that be if my friends are downloading from my server not my laptop? This didn't happen when I had my laptop connected via ethernet to the router. This is really strange to me.
 
Old 10-06-2003, 12:12 AM   #2
td_miles
Member
 
Registered: Sep 2003
Location: Australia
Distribution: RedHat
Posts: 51

Rep: Reputation: 15
You need to give some specifics. What type (brand/model) of router ? What type of connection back to schools wan ? What type of Wifi AP ?

What it sounds like is happening is that the router is actually acting as a "hub" so that it is sending the traffic out on all of its ports. One of these connects to the server and the other to the WAP. This means that the WAP will then xmit the packets over its wireless interface and hence max out the b/w for your notebook.

but thats just a guess
 
Old 10-06-2003, 12:52 AM   #3
mrsolo
Member
 
Registered: Jun 2002
Location: Where ever the Navy sends me
Distribution: Gentoo
Posts: 320

Original Poster
Rep: Reputation: 30
The router is a just a small D-Link DI-704 router w/ 4 switched 10/100 ports. The access point is a Netgear WAB102 dual band. The WAN type is actually the school's lan. You are absolutely right about the router acting like a HUB. I just installed the access point and it seems that the driver that I have for my Orinoco wireless card which has the Prism2 chipset, will only allow a max transfer of 600Kbytes/sec. This is crap, I have tried to turn down the txpower on the card but iwconfig reports that the feature is unavailable. One thing that might help, I used to have certain ports forwarded to my server by my router i.e., 80, 25, 21, 22, and so on, but what I did this time was made my server the demilitarized host, would that make a difference?
 
Old 10-06-2003, 01:15 AM   #4
td_miles
Member
 
Registered: Sep 2003
Location: Australia
Distribution: RedHat
Posts: 51

Rep: Reputation: 15
Just had a look at the D-Link site for any info and the is nothing worthwhile.

It says that it is a "switch" and usually things are these days. If the port forwarding is still setup, this could indeed be causing the problem.

I would suggest reseting the D-Link device (it should have a recessed button to press to do this) and start from scratch setting it up again.

As for only 600 kB/sec, this is about what I see when transferring over wireless (from memory I get about 670 KB/s). It's to be expected. If this isn't fast enough, then you'll have to either upgrade your wireless kit to the newer stuff that supports approx 50Mbit/s or plug the CAT5 cable back in for large transfers !
 
Old 10-06-2003, 02:10 AM   #5
mrsolo
Member
 
Registered: Jun 2002
Location: Where ever the Navy sends me
Distribution: Gentoo
Posts: 320

Original Poster
Rep: Reputation: 30
What card do you have and is it 802.11b? How far away is your access point from your computer and how strong is your link? My access point is about a foot away from my laptop and the link is about 66. Are you able to turn your txpower down on your wireless card? 600KB a second seems a little slow to me consdering it's supposed to be a 11Mbit connection, that means I should be getting around 1.3MB a sec transfers. I know that won't happen all the time but shouldn't it be higher than 600KB, say 800KB to 1MB a second?
 
Old 10-06-2003, 02:53 AM   #6
td_miles
Member
 
Registered: Sep 2003
Location: Australia
Distribution: RedHat
Posts: 51

Rep: Reputation: 15
Well, according to some reading, the best you are likely to see is just over 5Mbps. That is 5 MegaBITS per second. You can convert that into the transfer rate in MegaBYTES per second (what we have both quoted above) by dividing by eight (8 bits per byte). This is 5/8 = 0.625 MegaBYTES per second (ie. what you are getting).

refences:
http://www.broadbandproducts.com/wire_overview.html
http://www.pcstats.com/articleview.c...id=1428&page=3
http://www.broadbandhomecentral.com/...procedure.html

etc.


Remember, network speeds are usually quotes in MegaBITS, whereas transfer rates are usually quoted in MegaBYTES so there will always be a factor of eight difference.

As to why you only get 5 Mbps, that comes down to the wireless protocol and the inefficiencies of it. Nothing you can do about that.
 
Old 10-06-2003, 04:01 AM   #7
mrsolo
Member
 
Registered: Jun 2002
Location: Where ever the Navy sends me
Distribution: Gentoo
Posts: 320

Original Poster
Rep: Reputation: 30
Well, i guess that I will just have to make due with my avg transfer of 4-6 Mbps, thanks a lot
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
process memory consumption ilnli Linux - General 4 09-08-2005 08:13 PM
Vsftpd - how to limit download bandwidth but unlimited upload bandwidth? mpls mikeg Linux - Software 3 08-13-2005 02:52 PM
limit CPU consumption eantoranz Linux - Security 3 07-19-2005 09:32 PM
firewall power consumption Digital_Err0r Linux - Hardware 4 03-20-2005 01:36 PM
Slackware memory consumption muhkuhmasta Slackware 5 07-15-2004 06:51 AM


All times are GMT -5. The time now is 06:34 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration