LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices

Reply
 
LinkBack Search this Thread
Old 08-11-2011, 09:23 AM   #1
jglenton
LQ Newbie
 
Registered: Apr 2010
Posts: 5

Rep: Reputation: 0
Warning: failed to get speed and duplex from eth0, assumed to be 100Mb/sec and Full.


Hi,

I'm trying to setup bonding with Redhat 5.5 and for some reason I get the following message in /var/log/messages and when I run service network restart

Warning: failed to get speed and duplex from eth0, assumed to be 100Mb/sec and Full.

The cards are definitely 1Gb cards and this is reflected with the ethtool command:

[root@bxxxxxp network-scripts]# ethtool eth0
Settings for eth0:
Supported ports: [ TP ]
Supported link modes: 10baseT/Half 10baseT/Full
100baseT/Half 100baseT/Full
1000baseT/Full
Supports auto-negotiation: Yes
Advertised link modes: 10baseT/Half 10baseT/Full
100baseT/Half 100baseT/Full
1000baseT/Full
Advertised auto-negotiation: Yes
Speed: 1000Mb/s
Duplex: Full
Port: Twisted Pair
PHYAD: 1
Transceiver: internal
Auto-negotiation: on
Supports Wake-on: g
Wake-on: d
Link detected: yes


When I check the bond0 file I get the following:

[root@bxxxxxp network-scripts]# cat /proc/net/bonding/bond0
Ethernet Channel Bonding Driver: v3.4.0-1 (October 7, 2008)

Bonding Mode: load balancing (round-robin)
MII Status: up
MII Polling Interval (ms): 0
Up Delay (ms): 0
Down Delay (ms): 0

Slave Interface: eth0
MII Status: up
Speed: 100 Mbps
Duplex: full
Link Failure Count: 0
Permanent HW addr: bc:30:5b:d9:f5:02

Slave Interface: eth1
MII Status: up
Speed: 100 Mbps
Duplex: full
Link Failure Count: 0
Permanent HW addr: bc:30:5b:d9:f5:04

Not sure how to set it so the bond0 is set to 1Gb

Can anyone help please?

Thanks
James
 
Old 06-10-2012, 03:46 PM   #2
bryanle
LQ Newbie
 
Registered: Jun 2012
Posts: 1

Rep: Reputation: Disabled
To get the full speed of nic cards, set BONDING_OPTS (i.e. BONDING_OPTS="miimon=100 mode=0") in /etc/sysconfig/network-scripts/ifcfg-bond0. Don't set the bonding option in /etc/modprobe.d/bonding.conf (as example below). You will get the full capacity of nic card.

I got the same issue when I set the bonding option in the /etc/modprobe.d/bonding.conf as following:
alias bond0 bonding
options bond0 mode=5 miimon=100
 
  


Reply

Tags
bond0, bonding, duplex, full, warning


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
howto half/full duplex eth0 mickeyboa Fedora 2 02-25-2009 07:36 AM
how to set network speed to full duplex or mokku Linux - Networking 2 10-21-2008 05:37 PM
Cannot force 100mb/full duplex on debian etch ADxD_7 Linux - Networking 1 04-26-2008 07:12 AM
Running eth0 in full duplex rnturn Suse/Novell 2 12-23-2004 09:15 AM
how to configure network full duplex 100Mb ewlnxnewB Linux - Networking 1 01-28-2004 05:25 PM


All times are GMT -5. The time now is 10:52 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration